reload broken image

Bug #544183 reported by buzzdee on 2010-03-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Coccinella
Low
buzzdee

Bug Description

trying to reload a broken image produces the following exception:

can't read "fileTail": no such variable
can't read "fileTail": no such variable
    while executing
"::UI::MessageBox -icon error -title [mc "Error"] -type ok -message "No url found for the file \"$fileTail\" with MIME type $mime""
    (procedure "::Import::ReloadImage" line 12)
    invoked from within
"::Import::ReloadImage .wb3 2"
    invoked from within
".popupbroken invoke active"
    ("uplevel" body line 1)
    invoked from within
"uplevel #0 [list $w invoke active]"
    (procedure "tk::MenuInvoke" line 50)
    invoked from within
"tk::MenuInvoke .popupbroken 1"
    (command bound to event)

buzzdee (sebastia) wrote :

fixed with svn revision #2789.
The problem is that broken images created from within itcl files like Dice.itcl do not have a url assigned, and then the error message was broken. Now assigning values to "fileName" and "mime" before using it.

Changed in coccinella:
importance: Undecided → Low
assignee: nobody → buzzdee (sebastia)
status: New → Fix Committed
buzzdee (sebastia) on 2010-04-04
Changed in coccinella:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers