view business card gives immediately an error

Bug #497409 reported by mirkobau on 2009-12-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Coccinella
Medium
buzzdee

Bug Description

when opening a contact's business card, if the contact is without personal notes, i immediately receive this error:

extra characters after close-quote
extra characters after close-quote
    while executing
"::UI::MessageBox -type ok -icon error -title [mc "Error"] -message "[mc "Failed to obtain personal notes: %s", [lindex $queryElem 1]]"
# -messa..."
    invoked from within
(. . .)

The problem is in a single comma after the first argument to the 'mc' proc.
Another error comes out when correcting that comma: $dlg variable doesn't exist.

patch attached.

buzzdee (sebastia) on 2009-12-16
Changed in coccinella:
milestone: none → 0.96.18
buzzdee (sebastia) wrote :

I tried to reproduce the problem with latest svn version, but I do not get into the error condition with my server.
However, the comma is probably erroneous, and needs to be removed

does the problem vanish without your patch, when you add a note to a contact where the problem occurs?

do you know what kind of jabber server software is running on the other side? in case its a public server, where can I use it?
I'd like to reproduce the problem before applying the patch...

The server is mine and it's public: jabber.imatica.it

It runs the jabberd14-1.6.1.1.tar.gz server version, no transports configured.

Sorry, i can't do anything with business card window after the error comes up.

It's a TCL syntax error, it is very probable that you corrected it during normal programming.

let's correct that comma and that unexistent-variable problem, and go forward ;)

buzzdee (sebastia) on 2009-12-19
Changed in coccinella:
importance: Undecided → Medium
assignee: nobody → buzzdee (sebastia)
buzzdee (sebastia) wrote :

despite I was unable to register on your server, you are probably right that this seems to be wrong...
I commited a slightly cleaned up version of your patch to svn revision: 2772

Changed in coccinella:
status: New → Fix Committed
buzzdee (sebastia) on 2010-04-04
Changed in coccinella:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers