Enter password dialog: no focus

Bug #454527 reported by sander on 2009-10-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Coccinella
Low
buzzdee

Bug Description

When automatic login is enabled but no password is set, a dialog is shown to enter the password. However, focus is not set to the input field (usability issue).

buzzdee (sebastia) wrote :

It works for me on OpenBSD, using WindowMaker, the password field has focus, but I have the problem mentioned on Linux/KDE too.

sander (s-devrieze) wrote :

I got the same results on Mac OS X Tiger; the password field has focus whilst there is no correct focus on both Gnome/Metacity and Gnome/Compiz.

Do you accidentally have WindowMaker installed on your Linux deployment to test? If that also does not work, we know the bug is caused by something else such as a bug in the Tk toolkit that only exists on Linux for whatever reason.

buzzdee (sebastia) wrote :

I tried on Linux/Windowmaker. It seems the focus on the password field is randomly sometimes there, sometimes not.
I did not found a rule when it had focus, and why sometimes not.
I'll retest on the OpenBSD/Windowmaker box later, I did that only once there, maybe when I try more often, then sometimes the focus will there also not be set to the password field.

However, I also recognized sth. else:
when having "Plain text password" disabled in the profile used to automatically login, then after entering the password, then I am not allowed to login, because of wrong password.

When I enable "Plain text password" then it is taking the password I am entering, and it is working.
However, with the "plain text password" login disabled, I can login clicking in the roster on the login button.

buzzdee (sebastia) wrote :

Now after upgrading my notebook to OpenBSD 4.6, still using windowmaker, the password field on auto-loin doesn't have focus anymore.

Regarding the second problem I mentioned above, I opened a different bug report.

buzzdee (sebastia) wrote :

I appended a patch to contrib/ui/megaentry.tcl that puts the focus to the input field
works reliably for me with windowmaker for the password field, but it may break other things, not sure...

buzzdee (sebastia) on 2009-10-25
Changed in coccinella:
status: New → Fix Committed
buzzdee (sebastia) wrote :

fix committed with svn revision: #2748

sander (s-devrieze) on 2009-10-25
Changed in coccinella:
assignee: sander (s-devrieze) → buzzdee (buzzdee)
buzzdee (sebastia) on 2009-12-03
Changed in coccinella:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers