Crash when starting Coccinella with sounds enabled

Bug #204398 reported by sander on 2008-03-20
2
Affects Status Importance Assigned to Milestone
Coccinella
Critical
Mats

Bug Description

Mozart's Piano Sonata No. 19

Ingredients:
* huge roster
* sounds enabled
* PPC Mac
* Coccinella 0.96.6

Crash report here:
http://www.saint-andre.com/jabber/tmp/c-crash.txt

sander (s-devrieze) on 2008-03-20
Changed in coccinella:
assignee: nobody → matsben
importance: Undecided → Critical

I can see some QuickTime symbols here but the crash is in the main
thread. Either there is some kind of stack corruption in my
QuickTimeTcl, or it's a bug in the Tk core. Do you have any info on if
this happens if sound is enabled only, or if it appears anyway?

sander (s-devrieze) wrote :

Update on this: "stpeter: could not duplicate -- I ran C. for a few hours and it was fine"

So this may be difficult to fix.

Sounds like stack corruption. Just guessing here. But I don't trust
QuickTimeTcl on 8.5 since I access an internal struct MacDrawable assuming
there is a member Region visRgn or something when it now is a HIShape. It
could be anything but it's good to have the stack trace at least. If it is
stack corruption it doesn't help, though. I was thinking of installing the
latest ejabberd and write a script that registers 1000 users and keeps 100
of them online. That would be a stress test. I can run Tcl/Tk in the Xcode
debugger with al kinds of memory checks on. That should crash at the right
(wrong) place.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers