Subject should be sent before message

Bug #179940 reported by sander
2
Affects Status Importance Assigned to Milestone
Coccinella
Invalid
Medium
Mats

Bug Description

The subject is sent after the message. This is not logical and should be before the message.

URL: http://coccinella.im/node/161

sander (s-devrieze)
Changed in coccinella:
assignee: nobody → matsben
importance: Undecided → Medium
Revision history for this message
Mats (matsben) wrote :

It seems it is sent OK:
SEND: <message <email address hidden>' id='2' type='chat'><subject>wwwwwwww</subject><x xmlns='jabber:x:event'><composing/></x><thread>2ce5286f-63dc2c48</thread><body>---------------</body></message>

Both in the same message.

If I chat with myself:

SEND: <message <email address hidden>' id='4' type='chat'><subject>++++++++</subject><x xmlns='jabber:x:event'><composing/></x><active xmlns='http://jabber.org/protocol/chatstates'/><thread>3697bad4-bdf5e30</thread><body>---------------------</body></message>
RECV: <message <email address hidden>/Coccinella@Mats-Bengtssons-dator' <email address hidden>' xml:lang='sv' id='4' type='chat'><subject>++++++++</subject><x xmlns='jabber:x:event'><composing/></x><active xmlns='http://jabber.org/protocol/chatstates'/><thread>3697bad4-bdf5e30</thread><body>---------------------</body></message>

which is displayed in chat window as:

[16:05] <mats2> Ämne: ++++++++
[16:05] <mats2> ---------------------
[16:05] <mats2> Ämne: ++++++++
[16:05] <mats2> ---------------------

which looks OK.
However, Psi shows it in the wrong order.

sander (s-devrieze)
Changed in coccinella:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers