Errors in whiteboard

Bug #176527 reported by sander on 2007-12-15
10
Affects Status Importance Assigned to Milestone
Coccinella
High
Mats

Bug Description

Hook whiteboardTextInsertHook failed: 1
can't read "sprefs(voiceOther)": no such element in array
    while executing
"set voice $sprefs(voiceOther)"
    ("other" arm line 2)
    invoked from within
"switch -- $who {
 me {
     set voice $sprefs(voiceUs)
 }
 other {
     set voice $sprefs(voiceOther)
 }
    }"
    (procedure "::Speech::SpeakWBText" line 7)
    invoked from within
"::Speech::SpeakWBText other {}"
    ("eval" body line 1)
    invoked from within
"eval $func $args"
can't read "sprefs(voiceOther)": no such element in array
    while executing
"set voice $sprefs(voiceOther)"
    ("other" arm line 2)
    invoked from within
"switch -- $who {
 me {
     set voice $sprefs(voiceUs)
 }
 other {
     set voice $sprefs(voiceOther)
 }
    }"
    (procedure "::Speech::SpeakWBText" line 7)
    invoked from within
"::Speech::SpeakWBText other {}"
    ("eval" body line 1)
    invoked from within
"eval $func $args"

Hook whiteboardTextInsertHook failed: 1
can't read "sprefs(voiceOther)": no such element in array
    while executing
"set voice $sprefs(voiceOther)"
    ("other" arm line 2)
    invoked from within
"switch -- $who {
 me {
     set voice $sprefs(voiceUs)
 }
 other {
     set voice $sprefs(voiceOther)
 }
    }"
    (procedure "::Speech::SpeakWBText" line 7)
    invoked from within
"::Speech::SpeakWBText other {yes it does - !}"
    ("eval" body line 1)
    invoked from within
"eval $func $args"
can't read "sprefs(voiceOther)": no such element in array
    while executing
"set voice $sprefs(voiceOther)"
    ("other" arm line 2)
    invoked from within
"switch -- $who {
 me {
     set voice $sprefs(voiceUs)
 }
 other {
     set voice $sprefs(voiceOther)
 }
    }"
    (procedure "::Speech::SpeakWBText" line 7)
    invoked from within
"::Speech::SpeakWBText other {yes it does - !}"
    ("eval" body line 1)
    invoked from within
"eval $func $args"

sander (s-devrieze) wrote :

...and lot's of other errors follow.

It seems to be related with entering text in the whiteboard.

Changed in coccinella:
assignee: nobody → matsben
importance: Undecided → High
Mats (matsben) wrote :

Didn't happen on linux where there is no speech support. The code was so badly written that the bug showed up even if speech was switched off.

Changed in coccinella:
status: New → Fix Committed
sander (s-devrieze) on 2007-12-20
Changed in coccinella:
milestone: none → 0.96.4.1
sander (s-devrieze) on 2008-01-09
Changed in coccinella:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers