Usability: wrong password behaviour

Bug #147392 reported by sander on 2007-09-30
2
Affects Status Importance Assigned to Milestone
Coccinella
Wishlist
buzzdee

Bug Description

Current situation:
when a user enters a wrong password and tries to login, he gets and error and the login window is closed.

This better should be:
when a user enters a wrong password and tries to login, he gets and error and the login window is reopened so that the user can try again with a new password, or so that he can select another profile.

sander (s-devrieze) on 2007-09-30
Changed in coccinella:
assignee: nobody → matsben
importance: Undecided → Wishlist
buzzdee (sebastia) on 2009-10-14
Changed in coccinella:
milestone: none → 0.96.16
assignee: Mats (matsben) → buzzdee (sebastia)
status: New → Confirmed
buzzdee (sebastia) wrote :

after failed authentication, the error message window is shown. Clicking the OK button, opens the Login window again.

Also when on auto-login, a wrong password was supplied, the login window is opened after clicking OK in the error window

The last used profile is remembered.

Works for me with OpenBSD/Windowmaker/ejabberd

may probably need some more tests with different servers.

Changed in coccinella:
status: Confirmed → Won't Fix
status: Won't Fix → In Progress
buzzdee (sebastia) wrote :

should be fixed with svn revision #2752

Instead of a OK message window that is dismissed, a YESNO window shows up, containing the error message and asking the user whether he want to try again.
If the user chooses NO, then the window just dismisses, and thats it,
If the user chooses YES, then the Login window shows up, where the user can enter the password again, or has the opportunity to do some other changes to the profile.

Changed in coccinella:
status: In Progress → Fix Committed
buzzdee (sebastia) on 2009-12-03
Changed in coccinella:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers