Error when receiving a normal message

Bug #147234 reported by sander
2
Affects Status Importance Assigned to Milestone
Coccinella
Fix Released
High
Mats

Bug Description

Hook displayMessageHook failed: 1
item "1001" doesn't exist
    while executing
"$locals(wtbl) item state set $uid read"
    (procedure "MarkMsgAsRead" line 17)
    invoked from within
"MarkMsgAsRead $argsA(-msgid)"
    (procedure "::MailBox::DisplayMessageHook" line 5)
    invoked from within
"::MailBox::DisplayMessageHook { aaaaa

aaaa} -subject eee -from <email address hidden>/Tka -time 20070930T15:54:56 -msgid 1001"
    ("eval" body line 1)
    invoked from within
"eval $func $args"
item "1001" doesn't exist
    while executing
"$locals(wtbl) item state set $uid read"
    (procedure "MarkMsgAsRead" line 17)
    invoked from within
"MarkMsgAsRead $argsA(-msgid)"
    (procedure "::MailBox::DisplayMessageHook" line 5)
    invoked from within
"::MailBox::DisplayMessageHook { aaaaa

aaaa} -subject eee -from <email address hidden>/Tka -time 20070930T15:54:56 -msgid 1001"
    ("eval" body line 1)
    invoked from within
"eval $func $args"

sander (s-devrieze)
Changed in coccinella:
assignee: nobody → matsben
importance: Undecided → Medium
Revision history for this message
Mats (matsben) wrote :

This actually only shows up when there is no metakit, which I normally always have. That's why I haven't seen it before.

Changed in coccinella:
importance: Medium → High
status: New → Confirmed
Revision history for this message
Mats (matsben) wrote :

I was running ino this (TreeCtrl):
You may run into trouble if tagExpr looks like an item id or other keyword; also, tagExpr must look like a single list element since item descriptions are properly-formed lists. To be safe you may want to use the tag qualifier followed by tagExpr .

Changed in coccinella:
status: Confirmed → Fix Committed
sander (s-devrieze)
Changed in coccinella:
milestone: none → 0.96.4
sander (s-devrieze)
Changed in coccinella:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers