Interface font size is not applied to roster texts

Bug #146968 reported by sander
4
Affects Status Importance Assigned to Milestone
Coccinella
Low
Mats

Bug Description

When I change the font size using the info menu, all texts get bigger fonts including the chat window texts. The problem is that the fonts in the roster do not change.

This bug only appears in the following roster styles:
* Flat
* Avatar
* Avatar Large

sander (s-devrieze)
Changed in coccinella:
assignee: nobody → matsben
importance: Undecided → Low
sander (s-devrieze)
description: updated
Revision history for this message
Mats (matsben) wrote :

The Font Size menu only changes the smallest font which is called CociSmallFont. This is used in many places but the avatar styles except small have the normal font named CociDefaultFont which wont change. If you see the to of RosterAvatar.tcl you'll see which styles are using which named font.
The idea with font sizes was to increase readabllity by increasing the *smallest* size. Perhaps the CociDefaultFont should scale as well? This is a separet question.

Changed in coccinella:
status: New → Confirmed
Revision history for this message
sander (s-devrieze) wrote : Re: [Bug 146968] Re: Interface font size is not applied to roster texts

Probably, I don't see why not???

2007/10/2, Mats <email address hidden>:
> The Font Size menu only changes the smallest font which is called CociSmallFont. This is used in many places but the avatar styles except small have the normal font named CociDefaultFont which wont change. If you see the to of RosterAvatar.tcl you'll see which styles are using which named font.
> The idea with font sizes was to increase readabllity by increasing the *smallest* size. Perhaps the CociDefaultFont should scale as well? This is a separet question.
>
> ** Changed in: coccinella
> Status: New => Confirmed
>
> --
> Interface font size is not applied to roster texts
> https://bugs.launchpad.net/bugs/146968
> You received this bug notification because you are a direct subscriber
> of the bug.
>
>

--
Mvg, Sander Devrieze.

Revision history for this message
Mats (matsben) wrote :

Noted.

/Mats

On 10/2/07, sander <email address hidden> wrote:
> Probably, I don't see why not???
>
> 2007/10/2, Mats <email address hidden>:
> > The Font Size menu only changes the smallest font which is called
> CociSmallFont. This is used in many places but the avatar styles except
> small have the normal font named CociDefaultFont which wont change. If you
> see the to of RosterAvatar.tcl you'll see which styles are using which named
> font.
> > The idea with font sizes was to increase readabllity by increasing the
> *smallest* size. Perhaps the CociDefaultFont should scale as well? This is
> a separet question.
> >
> > ** Changed in: coccinella
> > Status: New => Confirmed
> >
> > --
> > Interface font size is not applied to roster texts
> > https://bugs.launchpad.net/bugs/146968
> > You received this bug notification because you are a direct subscriber
> > of the bug.
> >
> >
>
>
> --
> Mvg, Sander Devrieze.
>
> --
> Interface font size is not applied to roster texts
> https://bugs.launchpad.net/bugs/146968
> You received this bug notification because you are a bug assignee.
>

Revision history for this message
Mats (matsben) wrote :

Now the default font is also affected by the "Font Size" menu.

Changed in coccinella:
status: Confirmed → Fix Committed
sander (s-devrieze)
Changed in coccinella:
milestone: none → 0.96.4
sander (s-devrieze)
Changed in coccinella:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions