Camera application cannot record video

Bug #258110 reported by xiayi on 2008-08-15
12
Affects Status Importance Assigned to Milestone
Cheese
Expired
High
Classmate PC
Critical
Unassigned
cheese (Ubuntu)
Undecided
Oliver Grawert
Hardy
Undecided
Unassigned
Intrepid
Undecided
Oliver Grawert
gstreamer0.10 (Ubuntu)
Undecided
Oliver Grawert
Hardy
Undecided
Unassigned
Intrepid
Undecided
Oliver Grawert

Bug Description

Run "cheese", select video and start recording.Try clicking "stop recording" but there's no response.

Oliver Grawert (ogra) wrote :

hmm, no, seems that doesnt help, the actual problem here is that the whole UI gets unresponsive as soon as video is recorded while the above fix is only for ending the record process (which cant even be triggered without being able to click the button)... (note that cheese is far from being ready for mainstream usage and we might not find the necessary fixes in time, the parties asking for its inclusion on the cmpc image were made aware of that since the beginning ....)

Oliver Grawert (ogra) wrote :

linking to the upstream bug in gnome

Changed in cheese:
status: Unknown → Confirmed
Changed in cheese:
status: Confirmed → Incomplete
Colin Watson (cjwatson) wrote :

xiayi, there's no priority set on this bug - is this release-critical or not?

It looks like a fix for this involves incorporating gstreamer 0.10.20, which would be a very invasive and potentially destabilising change. As I understand it, the alternatives seem likely to be to drop cheese, or to document that it's currently necessary to force-quit the application.

xiayi (yi-xia) on 2008-08-21
Changed in cmpc:
importance: Undecided → Critical

Hi,
 Thank you for the analysis.
 It is critical. Cheese is the only application in this image that drives the hardware camera on CMPC. If its recording function is lost, so will be the camera's. I'll update its priority.
 And if cheese has to be dropped, we still need a substitute to make the camera run.

Best Regards
Xia Yi

-----Original Message-----
From: <email address hidden> [mailto:<email address hidden>] On Behalf Of Colin Watson
Sent: 2008年8月20日 20:59
To: Xia, Yi
Subject: [Bug 258110] Re: Camera application cannot record video

xiayi, there's no priority set on this bug - is this release-critical or
not?

It looks like a fix for this involves incorporating gstreamer 0.10.20,
which would be a very invasive and potentially destabilising change. As
I understand it, the alternatives seem likely to be to drop cheese, or
to document that it's currently necessary to force-quit the application.

--
Camera application cannot record video
https://bugs.launchpad.net/bugs/258110
You received this bug notification because you are a direct subscriber
of the bug.

Status in Cheese Camera Application: Incomplete
Status in Application and image devlopment around the Classmate PC: New

Bug description:
Run "cheese", select video and start recording.Try clicking "stop recording" but there's no response.

rpcutts (rpcutts) wrote :

I believe I have this issue.

I start cheese, press video, press Start Recording
The image capture goes black and the app never responds.

I have to Force Quit.

Oliver Grawert (ogra) wrote :

apparently my firefox cant upload debdiffs atm ... this bug needs two fixes (and thus two SRUs), one for cheese, teh other for gstreamer
cheese: http://people.ubuntu.com/~ogra/cheese_2.22.3-0ubuntu2.debdiff
gstreamer: http://people.ubuntu.com/~ogra/gstreamer0.10_0.10.18-4ubuntu2.debdiff

Oliver Grawert (ogra) wrote :

both uploaded to hardy-proposed now ...

Changed in cmpc:
status: New → In Progress
Changed in cheese:
status: New → In Progress
status: New → In Progress
Changed in gstreamer0.10:
status: New → In Progress
status: New → Fix Committed
Changed in cheese:
status: In Progress → Fix Committed
Oliver Grawert (ogra) wrote :

correction, teh cheese versioning needs to be ubuntu1.1, debdiff is at
http://people.ubuntu.com/~ogra/cheese_2.22.3-0ubuntu1.1.debdiff

Changed in cheese:
status: Incomplete → Confirmed
xiayi (yi-xia) wrote :

hi, I saw sth like 80_fix_webcam.patch in the diff file. Is it the fix for #258110?

Oliver Grawert (ogra) wrote :

yes, but that patch also needs the gstreamer fixes that were uploaded...
as outlined on https://wiki.ubuntu.com/StableReleaseUpdates both packages wait for the quarantaine to expire and two positive comments from testers.
feel free to install them on an image from the hardy-proposed repository and confirm they work ... the faster we get positive comments on this bug the earlier i can roll the final image.
cheese is not used in normal ubuntu, so it is not that critical, but we need to avoid any regressions in gstreamer so that needs very tough testing...

Changed in cheese:
status: Confirmed → Incomplete
Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Martin Pitt (pitti) wrote :

Please upload the fixes to intrepid ASAP, too.

Changed in cheese:
assignee: nobody → ogra
Changed in gstreamer0.10:
assignee: nobody → ogra
Changed in cheese:
status: Incomplete → Invalid
Oliver Grawert (ogra) wrote :

confirming, code change is in cheese-2.24.0 in intrepid

Changed in cheese:
status: In Progress → Fix Released
Oliver Grawert (ogra) wrote :

code change confirmed to be in gstreamer0.10-0.10.21 in intrepid

Changed in gstreamer0.10:
status: In Progress → Fix Released
xiayi (yi-xia) wrote :

Where could I get the patch for the bug? Is there a link to download?

Martin Pitt (pitti) wrote :

xiayi, see comment 14 for instructions: https://wiki.ubuntu.com/Testing/EnableProposed

xiayi (yi-xia) wrote :

Cheese is updated from 2.22.3-0ubuntu1 to 2.22.3-0ubuntu1.1. Now it's improved and videos can be saved. But it takes more than 1 minutes to stop recording after "stop" is clicked and user can no longer start recording after that until cheese is restarted.

Martin Pitt (pitti) wrote :

Both copied to hardy-updates.

Changed in cheese:
status: Fix Committed → Fix Released
Changed in gstreamer0.10:
status: Fix Committed → Fix Released
Changed in cheese:
importance: Unknown → High
status: Invalid → Expired
Oliver Grawert (ogra) on 2014-09-29
Changed in cmpc:
status: In Progress → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.