CM

guides / documentation page needs some text tweaks

Bug #775219 reported by rejon on 2011-05-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
CM
Critical
Bassel Safadi

Bug Description

This http://api.creationmix.com/guides page is to plug into the being developed /developers page

The ideas is that it just is documentation of the API and has tests of it.

The "CreatinMix API" should be spelled "CreationMix API".

First off, there is a menu on the top of the page:
* API Documentation
* Create an App
* Feeds
* Community

All of those links go to the same page, the current one...

This page needs to be named Documentation so url should be http://api.creationmix.com/documentation

This page currently has:

What is CreationMix?

[ some text ]

CreationMix API

[ some text ]
* list out all the main API sections either on this page until too long or make separate pages for each section
* "API Tests" link to tests of each api call...if can be on the same documentation page, then great.

Authorize Your App

* need to be logged in for this to work on the main page.
** Does it make sense for this to be on the main CM site then? I think it might. I need opinion here.
* one logged in users can register multiple accounts
* need a listing of registered apps here
** next to each, need to de-authorize the app with a button

###

Now, back to the top menu. If there pages that can be linked to from API Documentation, then link it. For "Create an App" should change to "Your Apps" and/or "Authorize Your App" Should be the same on the main guides page and in the menu, then I have no idea what should be in Feeds. I think should rename that page to Examples, and give 3 examples of using the API.

Community should be renamed "Developer Community" and link to http://creationmix.com/developer

The order of the menu items in the menu should be:

* API Documentation (main page)
* API Examples
* API Tests
* Your Apps
* Developer Community

Ok? This needs to be done, like yesterday. Also, documentation how these pages can be updated should go up on the http://api.creationmix.com/private with username/passwords for the admin there on the main page or an accounts page.

rejon (rejon) on 2011-05-01
summary: - guides page needs some text tweaks
+ guides / documentation page needs some text tweaks
description: updated
Bassel Safadi (bassel) wrote :

Renamed the page to CreationMix API Documentation, and changed the url to /documentation

Changed in cm:
status: Confirmed → Triaged
Bassel Safadi (bassel) wrote :

fixed, the links, now community point to http://creationmix.com/about
is that correct? the social media links will be there, right?

Yes.

On 5/3/11 4:12 AM, "Bassel Safadi" <email address hidden> wrote:

> fixed, the links, now community point to http://creationmix.com/about
> is that correct? the social media links will be there, right?

rejon (rejon) wrote :

In the spec on this bug, Community is to be changed to "Developer
Community" and should be linked to /developer

Waiting on jacky + greg to get that added.

Jon

On Mon, May 2, 2011 at 3:12 PM, Bassel Safadi <email address hidden> wrote:
> fixed, the links, now community point to http://creationmix.com/about
> is that correct? the social media links will be there, right?
>
> --
> You received this bug notification because you are a member of CM
> Developers, which is subscribed to CM.
> https://bugs.launchpad.net/bugs/775219
>
> Title:
>  guides / documentation page needs some text tweaks
>

--
Jon Phillips
http://rejon.org/ | http://fabricatorz.com/
chat/skype: kidproto | irc: rejon
+1.415.830.3884 (global) | +1-510-499-0894 (sf)
+86-187-1003-9974 (beijing)

rejon (rejon) wrote :

this is vital to the release

Bassel Safadi (bassel) wrote :

feeds and reqeusts are merged so no need for feeds page. it's a matter of adding routes now. doing the liscense one

Changed in cm:
status: Triaged → Fix Released
status: Fix Released → In Progress
rejon (rejon) on 2011-05-20
Changed in cm:
status: In Progress → Fix Released
status: Fix Released → Triaged
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints