race condition in dep8 test

Bug #1836593 reported by Scott Moser on 2019-07-15
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cloud-utils
Medium
Unassigned
cloud-utils (Ubuntu)
Medium
Unassigned
Disco
Low
Rafael David Tinoco

Bug Description

[Impact]

 * As can be seen in dep8 tests on published results [1], there seems to be a race condition on tear down of at least one of the growpart tests. We seem to see it most on ppc64el [2]. I'm attaching cloud-utils-ppc64el-0.31-0ubuntu1.log that came from [3].

[Test Case]

* It seems that the test that fails (at least in the 2 cases I saw) is 'growpart-loop'.

The relevant output in the log is this:

    unmount /tmp/test-growpart.VyOylU/mp
    clearing parts [1] from /dev/loop0
    delpart /dev/loop0 1
    delpart: failed to remove partition: Device or resource busy
    FAIL: ./test/test-growpart failed. pt_type=dos resizer=sfdisk

I've copied the relevant portion of the log to attached 'short.log'.

[Regression Potential]

* Minor potential as the only changes being added are "udevadm settle". This will likely add a bit of more time to execution but won't change the logic of what was already being done (just serialize udev events).

[Other Info]

[1] https://autopkgtest.ubuntu.com/packages/cloud-utils
[2] https://autopkgtest.ubuntu.com/packages/cloud-utils/eoan/ppc64el
[3] https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-eoan/eoan/ppc64el/c/cloud-utils/20190712_175132_5ffd5@/log.gz

--

Related branches

Scott Moser (smoser) wrote :
Changed in cloud-utils:
status: New → Confirmed
Changed in cloud-utils (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
Scott Moser (smoser) on 2019-07-15
Changed in cloud-utils:
status: Confirmed → Fix Committed
Scott Moser (smoser) on 2019-07-15
Changed in cloud-utils:
importance: Undecided → Medium
Changed in cloud-utils (Ubuntu Disco):
status: New → In Progress
importance: Undecided → Low
assignee: nobody → Rafael David Tinoco (rafaeldtinoco)
description: updated

Hello Scott, or anyone else affected,

Accepted cloud-utils into disco-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/cloud-utils/0.31-0ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-disco to verification-done-disco. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-disco. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in cloud-utils (Ubuntu Disco):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-disco

All autopkgtests for the newly accepted cloud-utils (0.31-0ubuntu1.1) for disco have finished running.
The following regressions have been reported in tests triggered by the package:

cloud-utils/0.31-0ubuntu1.1 (amd64, i386, ppc64el, arm64, s390x)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/disco/update_excuses.html#cloud-utils

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cloud-utils - 0.31-5-gef42f6b5-0ubuntu1

---------------
cloud-utils (0.31-5-gef42f6b5-0ubuntu1) eoan; urgency=medium

  * New upstream snapshot.
    - test-growpart: fix logic error resulting in test failure.
      [Scott Moser] (LP: #1842682)
    - Fix race condition in test-growpart teardown seen on ppc64el.
      [Scott Moser] (LP: #1836593)

 -- Scott Moser <email address hidden> Wed, 04 Sep 2019 11:07:42 -0400

Changed in cloud-utils (Ubuntu):
status: Confirmed → Fix Released

I confirm version 0.31-0ubuntu1.1 indeed fixes the issue.

tags: added: verification-done verification-done-disco
removed: verification-needed verification-needed-disco

Hello Scott, or anyone else affected,

Accepted cloud-utils into disco-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/cloud-utils/0.31-0ubuntu1.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-disco to verification-done-disco. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-disco. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

tags: added: verification-needed verification-needed-disco
removed: verification-done verification-done-disco

Look at:

https://bugs.launchpad.net/ubuntu/+source/cloud-utils/+bug/1810857/comments/12
https://bugs.launchpad.net/ubuntu/+source/cloud-utils/+bug/1835124/comments/23

This particular item I can't verify as it is an intermittent race condition in ppc64el arch, but, afaict, the SRU did not step into any other functionality (as you can prove by other verifications).

Because of that I'm marking this as verification-done.

tags: added: verification-done verification-done-disco
removed: verification-needed verification-needed-disco
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cloud-utils - 0.31-0ubuntu1.2

---------------
cloud-utils (0.31-0ubuntu1.2) disco; urgency=medium

  * test-growpart: fix logic error resulting in test failure.
    [Scott Moser] (LP: #1842682)

cloud-utils (0.31-0ubuntu1.1) disco; urgency=medium

  * fix race condition in test-growpart teardown seen on ppc64el (LP: #1836593)
  * growpart: fix bug when file image ends in a digit (LP: #1835124)
  * fix spelling error in ec2metadata (LP: #1810857)

 -- Rafael David Tinoco <email address hidden> Fri, 06 Sep 2019 10:47:23 -0300

Changed in cloud-utils (Ubuntu Disco):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for cloud-utils has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers