growpart: Fails for disk symlinks (e.g. /dev/disk/by-id)

Bug #1744406 reported by Kevin Locke on 2018-01-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cloud-utils
Low
Unassigned

Bug Description

When growpart is called on a disk symlink, it fails with an error similar to the following:

    # growpart /dev/disk/by-id/google-disk-name 1
    FAILED: failed to get start and end for /dev/disk/by-id/google-disk-name1 in /dev/disk/by-id/google-disk-name

This occurs because the partition device path in /dev/disk/by-id is to add "-part1" rather than just "1" so the awk expression for finding the partition start/end does not find the partition.

Thanks,
Kevin

P.S. I have a fix which will be sent in a merge request shortly.

Related branches

Scott Moser (smoser) on 2018-10-19
Changed in cloud-utils:
importance: Undecided → Low
status: New → Confirmed
Scott Moser (smoser) on 2018-10-19
Changed in cloud-utils:
status: Confirmed → Fix Committed

This bug is believed to be fixed in cloud-utils in version 0.31. If this is still a problem for you, please make a comment and set the state back to New

Thank you.

Changed in cloud-utils:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers