ubuntu-cloudimg-query does not return xenial ami

Bug #1593451 reported by CJ Cotton on 2016-06-16
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cloud-utils
Medium
Scott Moser
cloud-utils (Ubuntu)
Medium
Unassigned

Bug Description

Attempting to use ubuntu-cloudimg-query from the cloud-utils to query for the xenial distro in us-west-2. It keeps returning "no matching ami id found, but '%{ami}' in output format", however it is able to look it up with the url format and return it correctly. It does not return any information for Xenial when you remove additional filters.

Examples:

$ ubuntu-cloudimg-query xenial
no matching ami id found, but '%{ami}' in output format

$ ubuntu-cloudimg-query -v xenial
no matching ami id found, but '%{ami}' in output format

$ ubuntu-cloudimg-query xenial us-west-2
no matching ami id found, but '%{ami}' in output format

$ ubuntu-cloudimg-query --format '%{url}\n' xenial
https://cloud-images.ubuntu.com/server/releases/xenial/release-20160610/ubuntu-16.04-server-cloudimg-amd64.tar.gz

$ ubuntu-cloudimg-query --format '%{ami}\n' xenial
no matching ami id found, but '%{ami}' in output format

Distros & PKGVER tested on:
Package: cloud-utils
Versions:
0.27-0ubuntu24
--> cloud-utils is already the newest version (0.27-0ubuntu24).

$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=16.04
DISTRIB_CODENAME=xenial
DISTRIB_DESCRIPTION="Ubuntu 16.04 LTS"

$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=14.04
DISTRIB_CODENAME=trusty
DISTRIB_DESCRIPTION="Ubuntu 14.04.4 LTS"

CJ Cotton (mikachewie) on 2016-06-16
description: updated
Scott Moser (smoser) wrote :

This is a result of 'ebs' type being dropped for xenial, and replaced with ebs-ssd, as seen comparing

http://cloud-images.ubuntu.com/query/xenial/server/released.txt
to
https://cloud-images.ubuntu.com/query/trusty/server/released.current.txt
I believe that change was by design.

The change necessary to ubuntu-cloudimg-query is attached.

Changed in cloud-utils:
status: New → Confirmed
Scott Moser (smoser) wrote :

fix-committed in revno 296

Changed in cloud-utils:
assignee: nobody → Scott Moser (smoser)
status: Confirmed → Fix Committed
importance: Undecided → Medium
Changed in cloud-utils (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
tags: added: patch
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cloud-utils - 0.29-0ubuntu2

---------------
cloud-utils (0.29-0ubuntu2) yakkety; urgency=medium

  * bin/ubuntu-cloudimg-query: fix xenial default to be ebs-ssd
    as traditional ebs are no longer available. (LP: #1593451)

  [Ryan Harper]
  * bin/mount-image-callback: fix shortopt parsing (LP: #1604011)

 -- Scott Moser <email address hidden> Mon, 18 Jul 2016 10:48:38 -0400

Changed in cloud-utils (Ubuntu):
status: Confirmed → Fix Released
Scott Moser (smoser) wrote :

fixed in 0.30

Changed in cloud-utils:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers