recent versions of util-linux do not like how growpart calls partx

Bug #1587971 reported by Lars Kellogg-Stedman on 2016-06-01
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
cloud-utils
Medium
Unassigned
cloud-utils (Ubuntu)
Medium
Unassigned

Bug Description

With util-linux 2.28, calling:

  partx --update /dev/vda 1

Yields:

  partx: partition and disk name do not match

Looking at the man page -- even for older versions -- it looks like the syntax should actually be:

  partx --update /dev/vda1

Or:

  partx --update --nr 1 /dev/vda

(originally reported in https://bugzilla.redhat.com/show_bug.cgi?id=1327337)

Lars Kellogg-Stedman (larsks) wrote :

The above description isn't entirely correct; partx is actually being invoked like this:

    partx --update 1 /dev/vda

But the error is the same:

    partx: partition and disk name do not match

And the solution is the same:

    partx --update --nr 1 /dev/vda

Scott Moser (smoser) on 2016-06-01
Changed in cloud-utils:
status: New → Confirmed
importance: Undecided → Medium
Scott Moser (smoser) wrote :

fix-committed in trunk at revno 291.
Thank you, Lars.

Changed in cloud-utils (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
Changed in cloud-utils:
status: Confirmed → Fix Committed

The attachment "0001-fix-partx-invocation.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Scott Moser (smoser) wrote :

fix released in 0.29

Changed in cloud-utils:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cloud-utils - 0.29-0ubuntu1

---------------
cloud-utils (0.29-0ubuntu1) yakkety; urgency=medium

  * New upstream release.
    * cloud-localds: fix creation of vfat filesystems. (LP: #1431537)
      [Kamal Mostafa]
    * cloud-localds: better errors on missing vfat tools and
      Suggest mtools. (LP: #1431533)
    * growpart: fix use of partx for newer util-linux versions.
      (LP: #1587971) [Lars Kellogg-Stedman]
    * Add license file. (LP: #1294338)

 -- Scott Moser <email address hidden> Mon, 06 Jun 2016 13:05:42 -0400

Changed in cloud-utils (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers