cloud tests ssh time out

Bug #1861921 reported by Ahmed on 2020-02-04
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cloud-init
Medium
Ryan Harper

Bug Description

The function platforms/instance._wait_for_system causes ssh timeout on Azure cloud tests in the instance.start after initializing VM. Here is the tracebacks before and after removing it.

Before

FULL: https://paste.ubuntu.com/p/zJ3DNKxRTx/

https://paste.ubuntu.com/p/QyBnfrhVSs/

After removing

FULL: https://paste.ubuntu.com/p/JfksGJyRYc/
https://paste.ubuntu.com/p/gxKZffv2zd/

Something in platforms/instance._wait_for_system is causing this, don't want to mess with it because it's also used in ec2 and other cloud tests.

I found the easiest way to reproduce this is by going idle.

-- Added verbose logging to investigate

Thanks

Ahmed (ahosmanmsft) on 2020-02-04
description: updated
Ryan Harper (raharper) wrote :

Could you include the the code change you applied between the before/after?

Changed in cloud-init:
status: New → Incomplete
Chad Smith (chad.smith) on 2020-02-06
Changed in cloud-init:
status: Incomplete → Triaged
assignee: nobody → Ryan Harper (raharper)
Ryan Harper (raharper) on 2020-02-07
Changed in cloud-init:
importance: Undecided → Medium
status: Triaged → In Progress

This bug is believed to be fixed in cloud-init in version 20.1. If this is still a problem for you, please make a comment and set the state back to New

Thank you.

Changed in cloud-init:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers