cloud-init on xenial may generate network config on every boot

Bug #1819913 reported by Ryan Harper on 2019-03-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cloud-init
Undecided
Dan Watkins

Bug Description

On at least EC2 with cloud-init xenial release, the Ec2 datasource allows the EventType.BOOT
event to update metadata and will regenerate network configuration on each boot. Cloud-init releases newer than Xenial are not affected since cloud-init will detect
which datasource to use and does not perform searching.

Related branches

Ryan Harper (raharper) wrote :

cloud-init collect-logs from ec2 instance.

Changed in cloud-init:
status: New → In Progress
assignee: nobody → Dan Watkins (daniel-thewatkins)

This bug is fixed with commit f2fd6eac to cloud-init on branch master.
To view that commit see the following URL:
https://git.launchpad.net/cloud-init/commit/?id=f2fd6eac

Changed in cloud-init:
status: In Progress → Fix Committed

This bug is believed to be fixed in cloud-init in version 19.1. If this is still a problem for you, please make a comment and set the state back to New

Thank you.

Changed in cloud-init:
status: Fix Committed → Fix Released
Chad Smith (chad.smith) wrote :

The content fixing this was subsequently reverted due to causing tracebacks on upgrade path
https://git.launchpad.net/cloud-init/commit/?id=6322c2ddf4b68a8e7cc467a07fb20a1d151a2ef3

reopening until a resolution is provided

Changed in cloud-init:
status: Fix Released → New
Chad Smith (chad.smith) on 2019-05-17
Changed in cloud-init:
status: New → Confirmed

This bug is believed to be fixed in cloud-init in version 19.3. If this is still a problem for you, please make a comment and set the state back to New

Thank you.

Changed in cloud-init:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers