ubuntu-core: snappy supported or not?

Bug #1814296 reported by Ondrej Kubik on 2019-02-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cloud-init
Medium
Chad Smith

Bug Description

This is confusing:
Running Cloud-init v. 18.4
Using snappy module, getting warning: "snappy module will be dropped in 18.3 release"

Do we travel back in time?

Actual log:

[ 67.530402] cloud-init[2118]: Cloud-init v. 18.4-0ubuntu1~16.04.2 running 'modules:config' at Fri, 01 Feb 2019 14:43:30 +0000. Up 66.77 seconds.
[ 70.191507] cloud-init[2169]: Cloud-init v. 18.4-0ubuntu1~16.04.2 running 'modules:final' at Fri, 01 Feb 2019 14:43:33 +0000. Up 69.54 seconds.
[ 70.192446] cloud-init[2169]: 2019-02-01 14:43:34,232 - cc_snappy.py[WARNING]: DEPRECATION: snappy module will be dropped in 18.3 release. Use snap module instead
[ 70.443315] cloud-init[2169]: 2019-02-01 14:43:34,483 - util.py[WARNING]: Running module ssh-authkey-fingerprints (<module 'cloudinit.config.cc_ssh_authkey_fingerprints' from '/usr/lib/python3/dist-packages/cloudinit/config/cc_ssh_authkey_fingerprints.py'>) failed

Related branches

Chad Smith (chad.smith) wrote :

Good bug, valid and we can drop this upstream module now as snap module should cover all of these use cases.

Changed in cloud-init:
status: New → Confirmed
importance: Undecided → Medium
Chad Smith (chad.smith) on 2019-02-04
Changed in cloud-init:
assignee: nobody → Chad Smith (chad.smith)
status: Confirmed → In Progress
Ondrej Kubik (ondrak) wrote :

I have spoken too early.
I have problem creating user with snap module, but apart of that specific bug snap module seems to work fine.
So I'm +1 to deprecate snappy module

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers