cloud-init should support iproute2 tools

Bug #1739023 reported by Robert Schweikert on 2017-12-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cloud-init
Medium
Unassigned

Bug Description

Older ifconig, route, netstat, and arp tools are being deprecated on Linux distributions. cloud-init should in all cases support the newer iproute2 tools.

ifconfig used in:
    cloudinit/sources/DataSourceAzure.py
    cloudinit/netinfo.py
    tools/mock-meta.py

netstat used in:
    cloudinit/netinfo.py

route used in:
    cloudinit/config/cc_disable_ec2_metadata.py

Related branches

Scott Moser (smoser) on 2017-12-19
Changed in cloud-init:
status: New → Confirmed
importance: Undecided → Medium
Robert Schweikert (rjschwei) wrote :

cloudinit/sources/DataSourceAzure.py -> ifconfig used only in freeBSD block
tools/mock-meta.py -> ifconfig in comment

No changes needed for those files.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers