cloud-init resizefs fails when booting with root=PARTUUID=

Bug #1725067 reported by Steve Langasek on 2017-10-20
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cloud-init
High
Chad Smith
cloud-init (Ubuntu)
Medium
Chad Smith
Xenial
Medium
Unassigned
Zesty
Medium
Unassigned
Artful
Medium
Chad Smith

Bug Description

http://pad.lv/1725067
https://bugs.launchpad.net/ubuntu/+source/cloud-init/+bug/1725067

=== Begin SRU Template ===
[Impact]
Growing the root partition would not resize and leave a Traceback in /var/log/cloud-init.log if both:
 a.) The device /dev/root did not exist
     -- this case only hit xenial only because zesty already had a /dev/root created in the image so resize succeeded.
 b.) the kernel command line included PARTUUID=<value>
     -- This potential SRU regression occurred because of code restructuring that still discovered (and logged) but didn't use the discovered kernel_cmdline root device path when resizing.

[Test Case]
get-proposed-image is
  https://github.com/cloud-init/qa-scripts/blob/master/scripts/get-proposed-cloudimg
It downloads a cloud image of a given release, and then creates a -proposed
image with cloud-init upgraded.

A script 'recreate.sh' will run each of the steps below automated.
  https://github.com/cloud-init/ubuntu-sru/blob/master/bugs/lp-1684869/recreate.sh

NOTE: By default the images downloaded start off as 2Gig partitions, by requesting a 10G sparse qcow2 image resizefs should find the partition and resize it to the full 10Gig. If resizefs fails, we'd still be stuck with a 2GB response for "df -h /". This is what failed on our previous SRU proposal. The disk stayed at 2G instead of being resized to 10G.

1.) get a (proposed) disk image image.
  and convert it to raw so you can read the partuuid with sfdisk
  (get-proposed-image does this, if not,
  'qemu-img convert -O raw orig.img orig.raw')
  ./get-proposed-image

2.) get the partition uuid of the first partition
   # for xenial images that are dos partition table rather than gpt
   # we need to convert that with:
   # sgdisk --mbrtogpt $raw
   $ raw=yakkety-server-cloudimg-amd64-proposed.raw
   $ ptuuid=$(sfdisk --part-uuid $raw 1)

3.) create a nocloud seed
   $ printf "%s\n%s\n%s\n%s\n" "#cloud-config" "password: passw0rd" \
        "chpasswd: {expire: False}" "ssh_pwauth: True" > my-user-data
   $ echo "instance-id: $(uuidgen || echo i-abcdefg)" > my-meta-data
   $ cloud-localds my-seed.img my-user-data my-meta-data

4.) extract kernel from inside the image
   $ sudo mount-image-callback $raw -- mchroot sh -xc 'cat /boot/vmlinu?-*' > kernel

5.) boot instance with disk backed by the raw disk above.

   $ qemu-img create -f qcow2 -b $raw disk.img 10G
   $ qemu-system-x86_64 -enable-kvm \
       -drive file=disk.img,if=ide,index=0 -drive file=my-seed.img,if=ide \
       -net nic -net user,hostfwd=tcp::2222-:22 \
       -snapshot -m 768 -nographic -echr 0x05 \
       -kernel kernel \
       -append "root=PARTUUID=${ptuuid} ro console=tty1 console=ttyS0"

6.) log in, verify / has been resized.
   log in with 'ubuntu' and password 'passw0rd'
    $ df -h /
    Filesystem Size Used Avail Use% Mounted on
    /dev/root 9.6G 1009M 8.6G 11% /

[Regression Potential]
Regressions would surface as the root filesystem not being correctly resized.
The user would find themselves with not as much disk as expected.

[Other Info]
The qemu-system-x86 command above uses ide devices. This is because
the ide device emulated by qemu is built into the -generic kernel,
while the more common virtio-block or virtio-scsi are not. If you
attach those device types, it will fail with 'cant find root'.

Note that this was a regression of changes added in
 * bug 1684869: growing root partition does not always work with root=PARTUUID=
 * bug 1677376: growing partitions does not work when booted without initramfs

The issue probably is only seen if using the version of cloud-init
in xenial-proposed. Zesty and artful kernels or userspace made the change
actually not regress. However we will verify functionality for the uploaded
version in each of x, z, a.

[Other Info]
Upstream commit at
  https://git.launchpad.net/cloud-init/commit/?id=17a15f9e0a

=== End SRU Template ===

A freshly built Ubuntu 17.10 image that's configured to boot without initramfs by passing root=PARTUUID=<uuid> on the kernel commandline comes up degraded because cloud-init fails to resize the root partition.

Oct 20 00:07:30 ubuntu cloud-init[493]: 2017-10-20 00:07:30,656 - util.py[WARNING]: Failed to resize filesystem (cmd=('resize2fs', '/dev/root'))
Oct 20 00:07:30 ubuntu cloud-init[493]: 2017-10-20 00:07:30,662 - util.py[WARNING]: Running module resizefs (<module 'cloudinit.config.cc_resizefs' from '/usr/lib/python3/dist-packages/cloudinit/config/cc_resizefs.py'>) failed

Looking at the code, I see that there are two separate implementations of rootdev_from_cmdline, one in cloudinit/util.py and one in cloudinit/config/cc_resizefs.py; and the second does not handle partuuid.

>>> from cloudinit.util import rootdev_from_cmdline
>>> rootdev_from_cmdline('BOOT_IMAGE=/boot/vmlinuz-4.4.0-1007-kvm root=PARTUUID=f122607f-3631-4411-bd34-de4bed76e0f7 ro console=tty1 console=ttyS0 systemd.log_level=debug')
'/dev/disk/by-partuuid/f122607f-3631-4411-bd34-de4bed76e0f7'
>>> from cloudinit.config.cc_resizefs import rootdev_from_cmdline
>>> rootdev_from_cmdline('OT_IMAGE=/boot/vmlinuz-4.4.0-1007-kvm root=PARTUUID=f122607f-3631-4411-bd34-de4bed76e0f7 ro console=tty1 console=ttyS0 systemd.log_level=debug')
'/dev/PARTUUID=f122607f-3631-4411-bd34-de4bed76e0f7'
>>>

This is related to bug #1684869; I'm not sure if it's the same bug reintroduced or if was never fixed properly on trunk (17.1).

Related bugs:
 * bug 1684869: growing root partition does not always work with root=PARTUUID=
 * bug 1685291: RFC: virtio and virtio-scsi should be built in
 * bug 1677376: growing partitions does not work when booted without initramfs

Related branches

Steve Langasek (vorlon) wrote :

Actually, cc_resizefs.rootdev_from_cmdline exists but appears to be unused. I'm not sure why this is failing, then.

Changed in cloud-init (Ubuntu):
importance: Undecided → Medium
Steve Langasek (vorlon) wrote :

This code from cc_resizefs.py in the 0.7.9 SRU is missing from 17.1 in artful.

    container = util.is_container()

   # Ensure the path is a block device.
    if (devpth == "/dev/root" and not os.path.exists(devpth) and
            not container):
        devpth = util.rootdev_from_cmdline(util.get_cmdline())
        if devpth is None:
            log.warn("Unable to find device '/dev/root'")
            return
        log.debug("Converted /dev/root to '%s' per kernel cmdline", devpth)

Steve Langasek (vorlon) on 2017-10-20
description: updated
Steve Langasek (vorlon) wrote :

This regression is present in the cloud-init 17.1-18-gd4f70470-0ubuntu1~16.04.2 SRU currently in xenial-proposed. Marking up the bugs appropriately to stop the line on that SRU, since this breaks our GAed 16.04 minimal images.

tags: added: regression-proposed
Changed in cloud-init (Ubuntu):
status: New → Triaged
Scott Moser (smoser) on 2017-10-20
description: updated
Scott Moser (smoser) on 2017-10-23
Changed in cloud-init:
status: New → Confirmed
status: Confirmed → Triaged
importance: Undecided → High
Chad Smith (chad.smith) on 2017-10-23
Changed in cloud-init:
status: Triaged → In Progress
assignee: nobody → Chad Smith (chad.smith)
Changed in cloud-init (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Chad Smith (chad.smith)
Scott Moser (smoser) on 2017-10-23
description: updated
description: updated
Changed in cloud-init (Ubuntu Xenial):
status: New → Confirmed
Changed in cloud-init (Ubuntu Zesty):
status: New → Confirmed
Scott Moser (smoser) on 2017-10-23
description: updated
Chad Smith (chad.smith) on 2017-10-24
Changed in cloud-init (Ubuntu Xenial):
status: Confirmed → Fix Committed
Changed in cloud-init (Ubuntu Zesty):
status: Confirmed → Fix Committed
Changed in cloud-init:
status: In Progress → Fix Released
Changed in cloud-init (Ubuntu Artful):
status: In Progress → Fix Committed
Changed in cloud-init (Ubuntu Xenial):
importance: Undecided → Medium
Changed in cloud-init (Ubuntu Zesty):
importance: Undecided → Medium

An upload of cloud-init to xenial-proposed has been rejected from the upload queue for the following reason: "Please re-upload including the changelog entries from the unreleased version in -proposed in the .changes file. Thanks!".

Chris Halse Rogers (raof) wrote :

An upload of cloud-init to zesty-proposed has been rejected from the upload queue for the following reason: "Please re-upload including the changelog entries from the unreleased version in -proposed in the .changes file. Thanks!".

tags: added: verification-needed verification-needed-artful

Hello Steve, or anyone else affected,

Accepted cloud-init into artful-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/cloud-init/17.1-25-g17a15f9e-0ubuntu1~17.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-artful to verification-done-artful. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-artful. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Chris Halse Rogers (raof) wrote :

Hello Steve, or anyone else affected,

Accepted cloud-init into zesty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/cloud-init/17.1-25-g17a15f9e-0ubuntu1~17.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-zesty to verification-done-zesty. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-zesty. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed-zesty
Chris Halse Rogers (raof) wrote :

Hello Steve, or anyone else affected,

Accepted cloud-init into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/cloud-init/17.1-25-g17a15f9e-0ubuntu1~16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed-xenial
Chad Smith (chad.smith) wrote :

=== Abridged SRU verification output ====
./recreate.sh xenial
...
Preparing to unpack .../cloud-init_17.1-25-g17a15f9e-0ubuntu1~16.04.1_all.deb ...
...
# login ubuntu/pwd
$ cat /run/cloud-init/result.json
{
 "v1": {
  "datasource": "DataSourceNoCloud [seed=/dev/sdb][dsmode=net]",
  "errors": []
 }
}
$ df -h /
Filesystem Size Used Avail Use% Mounted on
/dev/root 9.6G 979M 8.6G 11% /

$ grep Trace /var/log/cloud-init.log
$

$ ./recreate.sh zesty
...
Preparing to unpack .../cloud-init_17.1-25-g17a15f9e-0ubuntu1~17.04.1_all.deb ...
#login ubuntu/pwd
$ cat /run/cloud-init/result.json
{
 "v1": {
  "datasource": "DataSourceNoCloud [seed=/dev/sdb][dsmode=net]",
  "errors": []
 }
}
$ df -h /
Filesystem Size Used Avail Use% Mounted on
/dev/root 9.6G 1023M 8.6G 11% /
$ grep Trace /var/log/cloud-init.log
$

$ ./recreate.sh artful
...
Preparing to unpack .../cloud-init_17.1-25-g17a15f9e-0ubuntu1~17.10.1_all.deb ...

$ cat /run/cloud-init/result.json
{
 "v1": {
  "datasource": "DataSourceNoCloud [seed=/dev/sdb][dsmode=net]",
  "errors": []
 }
}
$ df -h /
Filesystem Size Used Avail Use% Mounted on
/dev/root 9.6G 1.1G 8.6G 11% /
$ grep Trace /var/log/cloud-init.log
$

=== End Abridged SRU verification output ====

tags: added: verification-done verification-done-artful verification-done-xenial verification-done-zesty
removed: verification-needed verification-needed-artful verification-needed-xenial verification-needed-zesty
Chad Smith (chad.smith) on 2017-10-25
description: updated
description: updated
description: updated
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cloud-init - 17.1-25-g17a15f9e-0ubuntu1~17.10.1

---------------
cloud-init (17.1-25-g17a15f9e-0ubuntu1~17.10.1) artful-proposed; urgency=medium

  * New upstream snapshot.
    - resizefs: Fix regression when system booted with root=PARTUUID=
      (LP: #1725067)
    - tools: make yum package installation more reliable
    - citest: fix remaining warnings raised by integration tests.
    - citest: show the class actual class name in results.
    - ntp: fix config module schema to allow empty ntp config
      (LP: #1724951)
    - tools: disable fastestmirror if using proxy [Joshua Powers]
    - schema: Log debug instead of warning when jsonschema is not available.
      (LP: #1724354)

 -- Chad Smith <email address hidden> Mon, 23 Oct 2017 15:07:35 -0600

Changed in cloud-init (Ubuntu):
status: Fix Committed → Fix Released
Changed in cloud-init (Ubuntu Artful):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for cloud-init has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Hello Steve, or anyone else affected,

Accepted cloud-init into zesty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/cloud-init/17.1-27-geb292c18-0ubuntu1~17.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-zesty to verification-done-zesty. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-zesty. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed verification-needed-zesty
removed: verification-done verification-done-zesty
Łukasz Zemczak (sil2100) wrote :

Hello Steve, or anyone else affected,

Accepted cloud-init into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/cloud-init/17.1-27-geb292c18-0ubuntu1~16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed-xenial
removed: verification-done-xenial
Chad Smith (chad.smith) wrote :

=== Abridged SRU verification output ====
./recreate.sh xenial
...
Preparing to unpack .../cloud-init_17.1-27-geb292c18-0ubuntu1~16.04.1_all.deb ...
...
# login ubuntu/pwd

ubuntu@ubuntu:~$ cat /run/cloud-init/result.json
{
 "v1": {
  "datasource": "DataSourceNoCloud [seed=/dev/sdb][dsmode=net]",
  "errors": []
 }
}
ubuntu@ubuntu:~$ df -h /
Filesystem Size Used Avail Use% Mounted on
/dev/root 9.6G 996M 8.6G 11% /
ubuntu@ubuntu:~$ grep Trace /var/log/cloud-init.log
ubuntu@ubuntu:~$

$ ./recreate.sh zesty
...
Preparing to unpack .../cloud-init_17.1-27-geb292c18-0ubuntu1~17.04.1_all.deb ...
#login ubuntu/pwd
ubuntu@ubuntu:~$ cat /run/cloud-init/result.json
{
 "v1": {
  "datasource": "DataSourceNoCloud [seed=/dev/sdb][dsmode=net]",
  "errors": []
 }
}
ubuntu@ubuntu:~$ df -h /
Filesystem Size Used Avail Use% Mounted on
/dev/root 9.6G 1021M 8.6G 11% /
ubuntu@ubuntu:~$ grep Trace /var/log/cloud-init.log
ubuntu@ubuntu:~$

$ ./recreate.sh artful
...
Preparing to unpack .../cloud-init_17.1-27-geb292c18-0ubuntu1~17.10.1_all.deb ...

ubuntu@ubuntu:~$ cat /run/cloud-init/result.json
{
 "v1": {
  "datasource": "DataSourceNoCloud [seed=/dev/sdb][dsmode=net]",
  "errors": []
 }
}
ubuntu@ubuntu:~$ df -h /
Filesystem Size Used Avail Use% Mounted on
/dev/root 9.6G 1.1G 8.5G 11% /
ubuntu@ubuntu:~$ grep Trace /var/log/cloud-init.log
ubuntu@ubuntu:~$

=== End Abridged SRU verification output ====

tags: added: verification-done verification-done-xenial verification-done-zesty
removed: verification-needed verification-needed-xenial verification-needed-zesty
Launchpad Janitor (janitor) wrote :
Download full text (7.3 KiB)

This bug was fixed in the package cloud-init - 17.1-27-geb292c18-0ubuntu1~17.04.1

---------------
cloud-init (17.1-27-geb292c18-0ubuntu1~17.04.1) zesty-proposed; urgency=medium

  * New upstream snapshot.
    - EC2: Limit network config to fallback nic, fix local-ipv4 only
      instances. (LP: #1728152)
    - Gentoo: Use "rc-service" rather than "service". [Carlos Konstanski]

cloud-init (17.1-25-g17a15f9e-0ubuntu1~17.04.1) zesty-proposed; urgency=medium

  * New upstream snapshot.
    - resizefs: Fix regression when system booted with root=PARTUUID=
      (LP: #1725067)
    - tools: make yum package installation more reliable
    - citest: fix remaining warnings raised by integration tests.
    - citest: show the class actual class name in results.
    - ntp: fix config module schema to allow empty ntp config
      (LP: #1724951)
    - tools: disable fastestmirror if using proxy [Joshua Powers]

cloud-init (17.1-18-gd4f70470-0ubuntu1~17.04.2) zesty-proposed; urgency=medium

  * cherry-pick 41152f1: schema: Log debug instead of warning when
    jsonschema is absent (LP: #1724354)

cloud-init (17.1-18-gd4f70470-0ubuntu1~17.04.1) zesty-proposed; urgency=medium

  * drop the following cherry picks, now incorporated in snapshot.
    + debian/patches/cpick-a2f8ce9c-Do-not-provide-systemd-fsck-drop...
  * debian/copyright: dep5 updates, reorganize, add Apache 2.0 license.
    (LP: #1718681)
  * debian/control: drop dependency on python3-prettytable
  * debian/rules: install rsyslog file with 0644 mode instead of 0755.
  * debian/rules, debian/apport-launcher.py: add an apport hook. (LP: #1607345)
  * New upstream snapshot (LP: #1721847)
    - simpletable: Fix get_string method to return table-formatted string
    - net: Handle bridge stp values of 0 and convert to boolean type
      [Chad Smith]
    - tools: Give specific --abbrev=8 to "git describe"
    - network: bridge_stp value not always correct [Ryan Harper]
    - tests: re-enable tox with nocloud-kvm support [Joshua Powers]
    - systemd: remove limit on tasks created by cloud-init-final.service.
      [Robert Schweikert]
    - suse: Support addition of zypper repos via cloud-config.
      [Robert Schweikert]
    - tests: Combine integration configs and testcases [Joshua Powers]
    - Azure, CloudStack: Support reading dhcp options from systemd-networkd.
      [Dimitri John Ledkov]
    - packages/debian/copyright: remove mention of boto and MIT license
    - systemd: only mention Before=apt-daily.service on debian based distros.
      [Robert Schweikert]
    - Add missing simpletable and simpletable tests for failed merge
      [Chad Smith]
    - Remove prettytable dependency, introduce simpletable [Andrew Jorgensen]
    - debian/copyright: dep5 updates, reorganize, add Apache 2.0 license.
      [Joshua Powers]
    - tests: remove dependency on shlex [Joshua Powers]
    - AltCloud: Trust PATH for udevadm and modprobe.
    - DataSourceOVF: use util.find_devs_with(TYPE=iso9660)
      [Ryan Harper]
    - tests: remove a temp file used in bootcmd tests.
    - release 17.1
    - doc: document GCE datasource. [Arnd Hannemann]
    - suse: updates to templates to support openSUSE and SLES.
      [...

Read more...

Changed in cloud-init (Ubuntu Zesty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (7.3 KiB)

This bug was fixed in the package cloud-init - 17.1-27-geb292c18-0ubuntu1~16.04.1

---------------
cloud-init (17.1-27-geb292c18-0ubuntu1~16.04.1) xenial-proposed; urgency=medium

  * New upstream snapshot.
    - EC2: Limit network config to fallback nic, fix local-ipv4 only
      instances. (LP: #1728152)
    - Gentoo: Use "rc-service" rather than "service". [Carlos Konstanski]

cloud-init (17.1-25-g17a15f9e-0ubuntu1~16.04.1) xenial-proposed; urgency=medium

  * New upstream snapshot.
    - resizefs: Fix regression when system booted with root=PARTUUID=
      (LP: #1725067)
    - tools: make yum package installation more reliable
    - citest: fix remaining warnings raised by integration tests.
    - citest: show the class actual class name in results.
    - ntp: fix config module schema to allow empty ntp config
      (LP: #1724951)
    - tools: disable fastestmirror if using proxy [Joshua Powers]

cloud-init (17.1-18-gd4f70470-0ubuntu1~16.04.2) xenial-proposed; urgency=medium

  * cherry-pick 41152f1: schema: Log debug instead of warning when
    jsonschema is absent (LP: #1724354)

cloud-init (17.1-18-gd4f70470-0ubuntu1~16.04.1) xenial-proposed; urgency=medium

  * drop the following cherry picks, now incorporated in snapshot.
    + debian/patches/cpick-a2f8ce9c-Do-not-provide-systemd-fsck-drop...
  * debian/copyright: dep5 updates, reorganize, add Apache 2.0 license.
    (LP: #1718681)
  * debian/control: drop dependency on python3-prettytable
  * debian/rules: install rsyslog file with 0644 mode instead of 0755.
  * debian/rules, debian/apport-launcher.py: add an apport hook. (LP: #1607345)
  * New upstream snapshot. (LP: #1721847)
    - simpletable: Fix get_string method to return table-formatted string
    - net: Handle bridge stp values of 0 and convert to boolean type
      [Chad Smith]
    - tools: Give specific --abbrev=8 to "git describe"
    - network: bridge_stp value not always correct [Ryan Harper]
    - tests: re-enable tox with nocloud-kvm support [Joshua Powers]
    - systemd: remove limit on tasks created by cloud-init-final.service.
      [Robert Schweikert]
    - suse: Support addition of zypper repos via cloud-config.
      [Robert Schweikert]
    - tests: Combine integration configs and testcases [Joshua Powers]
    - Azure, CloudStack: Support reading dhcp options from systemd-networkd.
      [Dimitri John Ledkov]
    - packages/debian/copyright: remove mention of boto and MIT license
    - systemd: only mention Before=apt-daily.service on debian based distros.
      [Robert Schweikert]
    - Add missing simpletable and simpletable tests for failed merge
      [Chad Smith]
    - Remove prettytable dependency, introduce simpletable [Andrew Jorgensen]
    - debian/copyright: dep5 updates, reorganize, add Apache 2.0 license.
      [Joshua Powers]
    - tests: remove dependency on shlex [Joshua Powers]
    - AltCloud: Trust PATH for udevadm and modprobe.
    - DataSourceOVF: use util.find_devs_with(TYPE=iso9660)
      [Ryan Harper]
    - tests: remove a temp file used in bootcmd tests.
    - release 17.1
    - doc: document GCE datasource. [Arnd Hannemann]
    - suse: updates to templates to support openSUSE and SLES.
  ...

Read more...

Changed in cloud-init (Ubuntu Xenial):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers