unittests: OpenStack DS escape or timeout

Bug #1714376 reported by Joshua Powers on 2017-08-31
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cloud-init
Medium
Chad Smith

Bug Description

Similar to LP: #1714117, there appears to be a pair of tests that are escaping and timing out, resulting in extra time that is not required for the unit tests:

tests.unittests.test_datasource.test_openstack.TestOpenStackDataSource.test_datasource
tests.unittests.test_datasource.test_openstack.TestOpenStackDataSource.test_bad_datasource_meta

Here are the raw results and methodology:
Python 2 results: https://paste.ubuntu.com/25441590/
Python 3 results: https://paste.ubuntu.com/25441592/

$ git clone https://git.launchpad.net/cloud-init
$ cd cloud-init
# pip[3] install --user -r requirements.txt -r test-requirements.txt nose-timer
$ python[3] -m nose --with-timer --timer-ok 1 --timer-warning 1 --timer-top-n 10 tests/unittests

Related branches

Joshua Powers (powersj) on 2017-08-31
Changed in cloud-init:
status: New → Confirmed
Joshua Powers (powersj) wrote :

The root cause of the delay is the ds_os.get_data() command timing out.

Chad Smith (chad.smith) on 2017-09-06
Changed in cloud-init:
importance: Undecided → Medium
assignee: nobody → Chad Smith (chad.smith)
status: Confirmed → In Progress

This bug is believed to be fixed in cloud-init in 17.1. If this is still a problem for you, please make a comment and set the state back to New

Thank you.

Changed in cloud-init:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers