ds-identify does not recognize Fujitsu Cloud Service S5 as OVF

Bug #1698669 reported by mikespub
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cloud-init
Fix Released
Medium
Scott Moser

Bug Description

**************************************************************************
# A new feature in cloud-init identified possible datasources for #
# this system as: #
# ['Ec2', 'None'] #
# However, the datasource used was: OVF #
# #
# In the future, cloud-init will only attempt to use datasources that #
# are identified or specifically configured. #
# For more information see #
# https://bugs.launchpad.net/bugs/1669675 #
# #
# If you are seeing this message, please file a bug against #
# cloud-init at #
# https://bugs.launchpad.net/cloud-init/+filebug?field.tags=dsid #
# Make sure to include the cloud provider your instance is #
# running on.

1. Cloud provider is Fujitsu Cloud Service S5, after upgrading from Ubuntu 14 to 16.04.2 LTS
2. 0.7.9-113-g513e99e0-0ubuntu1~16.04.1
3. None
4.

Related branches

Revision history for this message
mikespub (mikespub) wrote :
Revision history for this message
Scott Moser (smoser) wrote :

Hi,
It looks like this cloud uses ovf datasource, and that they did so by attaching a disk to with an filesystem label OVFENV.

I think that there might be two bugs in the 'dscheck_OVF' in ds-identify that we could fix.
a.) has_cdrom seems to have returned false. I was relying on udev to have created a /dev/cdrom link to /dev/sr0. its possible that has not happened at the point the generator was run.
b.) we should consider a filesystem label OVFENV as indicating there is an ovf environment file on a cdrom (especially when it is on a sr0 device as is the case here).

Changed in cloud-init:
status: New → Confirmed
importance: Undecided → Medium
Scott Moser (smoser)
summary: - cloud-init datasource used was OVF
+ ds-identify does not recognize Fujitsu Cloud Service S5 as OVF
tags: added: dsid-block-xenial
Chad Smith (chad.smith)
Changed in cloud-init:
status: Confirmed → Fix Committed
assignee: nobody → Scott Moser (smoser)
Revision history for this message
Scott Moser (smoser) wrote : Fixed in Cloud-init 18.1

This bug is believed to be fixed in cloud-init in 18.1. If this is still a problem for you, please make a comment and set the state back to New

Thank you.

Changed in cloud-init:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.