NoCloud source doesn't work on FreeBSD

Bug #1645824 reported by Andres Montalban on 2016-11-29
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
cloud-init
Medium
Gonéri Le Bouder

Bug Description

Hey guys,

I'm trying to use cloud-init on FreeBSD using CD to seed metadata, the thing is that it had some issues:

- Mount option 'sync' is not allowed for cd9660 filesystem.
- I optimized the list of filesystems that needed to be scanned for metadata by having three lists (vfat, iso9660, and label list) and then checking against them to see which filesystem option needs to be passed to mount command.

Additionally I'm going to push some changes to FreeBSD cloud-init package so it can build last version. I will open another ticket for fixing networking in FreeBSD as it doesn't support sysfs (/sys/class/net/) by default.

Thanks!

Related branches

Andres Montalban (amontalban) wrote :
Hongjiang Zhang (redriver) wrote :

I think you'd better follow http://cloudinit.readthedocs.io/en/latest/topics/hacking.html to create a merge request, then other developers will help you review code.

Scott Moser (smoser) wrote :

Andres,
Sorry for the very slow reply.

In order to accept your patch, I'll need you to sign the Contributors agreement.
That process is described at http://cloudinit.readthedocs.io/en/latest/topics/hacking.html .

Please feel free to ping me via email or irc (smoser) if you have any questions.

Changed in cloud-init:
status: New → Confirmed
importance: Undecided → Medium
Gonéri Le Bouder (goneri) wrote :

Hi, I've just faced the same problem and I end up with a similar patch that I pushed for review: https://code.launchpad.net/~goneri/cloud-init/+git/cloud-init/+merge/364997
I've also signed the agreement.

sammohung76 (sammohung76) wrote :

I'll duplicate my comment from #1819871

--
 created Makefile for FreeBSD ports https://pastebin.com/p1Y5NGzg which points to goneri repository: https://github.com/goneri/cloud-init/tree/freebsd ( for more convenient testing ).

Unfortunately cidata storage still not determined by cloud-init:

glabel status -s
gptid/4a827d3c-56b7-11e9-a07c-00a0989c11ae N/A vtbd0p1
                            msdosfs/EFISYS N/A vtbd0p1
                            iso9660/cidata N/A cd1

logs are attached below.

Also utils.py in cloud-init-output.log still print:

 util.py[WARNING]: Unable to determine distribution, template expansion may have unexpected results

despite /usr/local/etc/cloud/cloud.cfg:
..
system_info:
   # This will affect which distro class gets used
   distro: freebsd
   # Default user name + that default users groups (if added/used)
...

sammohung76 (sammohung76) wrote :
sammohung76 (sammohung76) wrote :
Gonéri Le Bouder (goneri) wrote :

Hi,

I realized yesterday that the default datasource_list on FreeBSD does not include NoCloud.

Could you retry with: https://github.com/goneri/cloud-init/tree/freebsd I rebased the branch yesterday evening and it should just work fine for you.

Gonéri Le Bouder (goneri) wrote :

If you get any kind of problem, please attach your data-source image.

Changed in cloud-init:
assignee: nobody → Gonéri Le Bouder (goneri)

This bug is fixed with commit 937555fd to cloud-init on branch master.
To view that commit see the following URL:
https://git.launchpad.net/cloud-init/commit/?id=937555fd

Changed in cloud-init:
status: Confirmed → Fix Committed

This bug is believed to be fixed in cloud-init in version 19.1. If this is still a problem for you, please make a comment and set the state back to New

Thank you.

Changed in cloud-init:
status: Fix Committed → Fix Released
Gonéri Le Bouder (goneri) wrote :

For the record, the NoCloud provider is still broken because it depends on the blkid command which only exists on Linux: https://code.launchpad.net/~goneri/cloud-init/+git/cloud-init/+merge/365630

This bug is fixed with commit 0f869532 to cloud-init on branch master.
To view that commit see the following URL:
https://git.launchpad.net/cloud-init/commit/?id=0f869532

Changed in cloud-init:
status: Fix Released → Fix Committed

This bug is believed to be fixed in cloud-init in version 19.2. If this is still a problem for you, please make a comment and set the state back to New

Thank you.

Changed in cloud-init:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers