Calls "service walinuxagent start" in Azure data source

Bug #1538522 reported by Bastian Blank on 2016-01-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cloud-init
Medium
Unassigned
cloud-init (Ubuntu)
Medium
Unassigned

Bug Description

Hi

cloud-init calls "service walinuxagent start" in the Azure data source during "init" phase.

Currently walinuxagent.service in Ubuntu 15.10 specifies:
| After=cloud-final.service
This asks systemd to start if much later, after the "final" phase.

New enough systemd version as available in Ubuntu 15.10 and Debian Stretch will just ignore the relation, as it is a deadlock and start the service in this place. Older version as in Debian Jessie will block the whole boot.

Is there a reason to explicitely start walinuxagent instead of relying on order in systemd?

Bastian

Related branches

Revision history for this message
Lars Kellogg-Stedman (larsks) wrote :

...and systems running NetworkManager store it somewhere *else*:

  $ ps -fe | grep dhclient
  root 27312 27292 0 Apr11 ? 00:00:00 /sbin/dhclient -d -q -sf /usr/libexec/nm-dhcp-helper -pf /var/run/dhclient-eth0.pid -lf /var/lib/NetworkManager/dhclient-e4599575-5a21-46c1-bfe3-62cb23268b69-eth0.lease -cf /var/lib/NetworkManager/dhclient-eth0.conf eth0

Revision history for this message
Lars Kellogg-Stedman (larsks) wrote :

(Sorry, that last comment was on the wrong bug)

Revision history for this message
Scott Moser (smoser) wrote :

Well, this is configurable. you can make the command be whatever you want in user-data.
But cloud-init started the walinuxagent because it needs walinuxagent to do some work for it, and cluod-init is at that point blocking most of boot. So without the start, it wouldnt be started.

The fix I'd like to apply is to remove the need for cloud-init to use walinuxagent at all, and instead use the '__builtin__' agent command that makes cloud-init do what walinuxagent did for us.

Changed in cloud-init:
importance: Undecided → Medium
status: New → Confirmed
Scott Moser (smoser) on 2016-11-22
Changed in cloud-init:
status: Confirmed → Fix Committed
Scott Moser (smoser) on 2016-12-02
Changed in cloud-init (Ubuntu):
importance: Undecided → Medium
status: New → Fix Released
Revision history for this message
Scott Moser (smoser) wrote :

This is fixed in cloud-init 0.7.9.

Changed in cloud-init:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers