In Ubuntu 12.10, the legacy 'user' cloud-config option is not handled properly

Bug #1100920 reported by Clint Byrum on 2013-01-17
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
OpenStack Heat
Invalid
Undecided
Unassigned
cloud-init
Medium
Unassigned
cloud-init (Ubuntu)
Medium
Unassigned
Quantal
Medium
Unassigned
Raring
Medium
Unassigned

Bug Description

When trying to use HEAT with Ubuntu 12.10, the following cloud-config is used:

--------_BEGIN_------------
runcmd:
 - setenforce 0 > /dev/null 2>&1 || true

user: ec2-user

cloud_config_modules:
 - locale
 - set_hostname
 - ssh
 - timezone
 - update_etc_hosts
 - update_hostname
 - runcmd

# Capture all subprocess output into a logfile
# Useful for troubleshooting cloud-init issues
output: {all: '| tee -a /var/log/cloud-init-output.log'}
--------_END_-----------
This results in ec2-user being created, but no SSH keys for it.

Related branches

Clint Byrum (clint-fewbar) wrote :

Linking to HEAT to document the problem. May need to work around broken version of cloud-init once it is understood fully.

Changed in heat:
status: New → Invalid
status: Invalid → New
Clint Byrum (clint-fewbar) wrote :

I'm closing the heat task. Heat is doing the right thing here, I think cloud-init was just doing the wrong one.

Changed in cloud-init:
status: New → In Progress
Changed in heat:
status: New → Invalid
Changed in cloud-init (Ubuntu Quantal):
status: New → Triaged
importance: Undecided → Medium
Clint Byrum (clint-fewbar) wrote :

Just FYI, the fix that is going into trunk requires some things to be present in /etc/cloud/cloud.cfg. I'm not sure fixing this is worth a conffile update, so we might have to just leave this as a Won't Fix for quantal unless we do something clever, and clever usually leads to regressions.. :-P

Changed in cloud-init (Ubuntu Raring):
status: New → Triaged
importance: Undecided → Medium
Changed in cloud-init:
status: In Progress → Fix Committed
Scott Moser (smoser) on 2013-01-31
Changed in cloud-init:
importance: Undecided → Medium
Scott Moser (smoser) wrote :

I'm pretty sure that the trunk commit "just works" when applied to quantal. I'm attaching a deb here and the patch that built it, mainly for future reference.

I would appreciate feedback as to whether or not it works though. The reason (i think) it "just works" without a config change as Clint suggested is that the distro class in quantal returned a dict for 'get_default_user' the same as trunk does. The difference is one just comes from code (quantal) and the other from config (raring/trunk).
b

Scott Moser (smoser) wrote :
tags: added: patch

Excerpts from Scott Moser's message of 2013-01-31 14:19:24 UTC:
> I'm pretty sure that the trunk commit "just works" when applied to
> quantal. I'm attaching a deb here and the patch that built it, mainly
> for future reference.
>
> I would appreciate feedback as to whether or not it works though. The reason (i think) it "just works" without a config change as Clint suggested is that the distro class in quantal returned a dict for 'get_default_user' the same as trunk does. The difference is one just comes from code (quantal) and the other from config (raring/trunk).
> b
>

You may be right, I don't think I actually tried the patch backported, I just tried trunk on quantal. So perhaps it is SRU'able.

Scott Moser (smoser) wrote :

This change made it into 0.7.2~bzr795-0ubuntu1 but it is not listed in the changelog.

Changed in cloud-init (Ubuntu Raring):
status: Triaged → Fix Released
Clint Byrum (clint-fewbar) wrote :

I can confirm that Ubuntu 13.04 images work fine with Heat now.

Scott Moser (smoser) wrote :

fixed in 0.7.2

Changed in cloud-init:
status: Fix Committed → Fix Released
Rolf Leggewie (r0lf) wrote :

quantal has seen the end of its life and is no longer receiving any updates. Marking the quantal task for this ticket as "Won't Fix".

Changed in cloud-init (Ubuntu Quantal):
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers