Comment 0 for bug 1756426

grub-legacy-ec2 is missing from the squashfs image.
It is a recommends of ubuntu-server. Why would a package that
is a recommends be removed from generated images?

It seems like there must be a cleaner way to handle that.

# cat /etc/cloud/build.info
build_name: server
serial: 20180315

# dpkg-query --show ubuntu-server
ubuntu-server 1.413

# apt-cache show ubuntu-server | grep Recomm
Recommends: grub-legacy-ec2, lxd, snapd

# dpkg-query --show grub-legacy-ec2 lxd snapd
grub-legacy-ec2
lxd 3.0.0~beta5-0ubuntu2
snapd 2.31.1+18.04

Why is