simplestreams metadata is corrupt

Bug #1929703 reported by G
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cloud-images
Undecided
Unassigned

Bug Description

After running: uvt-simplestreams-libvirt --verbose sync arch=amd64 release=focal

I get this error

```
Traceback (most recent call last):
  File "/usr/bin/uvt-simplestreams-libvirt", line 27, in <module>
    uvtool.libvirt.simplestreams.main()
  File "/usr/lib/python2.7/dist-packages/uvtool/libvirt/simplestreams.py", line 329, in main
    args.func(args)
  File "/usr/lib/python2.7/dist-packages/uvtool/libvirt/simplestreams.py", line 269, in main_sync
    tmirror.sync(smirror, initial_path)
  File "/usr/lib/python2.7/dist-packages/simplestreams/mirrors/__init__.py", line 91, in sync
    return self.sync_index(reader, path, data, content)
  File "/usr/lib/python2.7/dist-packages/simplestreams/mirrors/__init__.py", line 254, in sync_index
    self.sync(reader, path=epath)
  File "/usr/lib/python2.7/dist-packages/simplestreams/mirrors/__init__.py", line 85, in sync
    content, payload = reader.read_json(path)
  File "/usr/lib/python2.7/dist-packages/simplestreams/mirrors/__init__.py", line 43, in read_json
    return raw, self.policy(content=raw, path=path)
  File "/usr/lib/python2.7/dist-packages/uvtool/libvirt/simplestreams.py", line 258, in policy
    content, keyring=args.keyring)
  File "/usr/lib/python2.7/dist-packages/simplestreams/util.py", line 290, in read_signed
    raise e
subprocess.CalledProcessError: Command '['gpgv', u'--keyring=/usr/share/keyrings/ubuntu-cloudimage-keyring.gpg', '-']' returned non-zero exit status 2
```

I am running ubuntu server 18.04.5, fresh installation.
I try to run ```gpgv -v --keyring /usr/share/keyrings/ubuntu-cloudimage-keyring.gpg -``` but it just run forever

Revision history for this message
Robie Basak (racb) wrote :

Thank you for a report.

This is a signature verification failure, rather than specifically a bug in uvtool - though I accept the error message could be better.

The problem is that the metadata available from http://cloud-images.ubuntu.com/releases/streams/v1/com.ubuntu.cloud:released:download.sjson appears truncated and is missing its signature. Download attached.

affects: uvtool → cloud-images
summary: - uvt-simplestreams-libvirt shows gpgv error
+ simplestreams metadata is corrupt
Revision history for this message
Joshua Powers (powersj) wrote :

The streams were regenerated and are now live.

Changed in cloud-images:
status: New → Fix Released
Revision history for this message
G (garitaca) wrote :

Thank you guys for the prompt response and quick fix! It is working now.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers