Ubuntu 16.04 (Xenial Xerus) OVA doesn't boot due to incorrect firmware metadata

Bug #1615875 reported by JM Lopez
46
This bug affects 10 people
Affects Status Importance Assigned to Milestone
cloud-images
Undecided
Unassigned

Bug Description

OVA:
 - name: xenial-server-cloudimg-amd64.ova
 - MD5 (xenial-server-cloudimg-amd64.ova) = bc4d8f15fa498d31d69bacd8f7cffb75
Failing on:
 - VirtualBox Version 5.0.18 r106667
 - VMware Fusion Professional Version 8.1.1 (3771013)
Problem:
 - VM does not boot. it might be stuck in GRUB by a missing file?
Error message:
 - error: file `/boot/grub/i386-pc/efi_gop.mod` not found.
 - error: file `/boot/grub/i386-pc/efi_uga.mod` not found.
Screenshot:
 - VMware Fusion: https://www.dropbox.com/s/qphrw897xhqrmqs/Screen%20Shot%202016-08-22%20at%209.51.04%20PM.png?dl=0
- VirtualBox: https://www.dropbox.com/s/t1xm6vm3tyfwxno/Screen%20Shot%202016-08-22%20at%209.40.08%20PM.png?dl=0

JM Lopez (i-jm-l)
tags: added: xenial
Revision history for this message
JM Lopez (i-jm-l) wrote :
Revision history for this message
Kristian Jensen (spexxter) wrote :

Confirmed on ESX 5.5 and ESX 6.0

Changed in cloud-images:
status: New → Confirmed
Revision history for this message
Erik Lönroth (erik-lonroth) wrote :

I can confirm this as well on 6.5.0 4564106

Revision history for this message
Sabari Murugesan (smurugesan) wrote :

The OVF descriptor on the OVA has the wrong firmware as BIOS instead of EFI. Changing that helps to boot on VMware hypervisors.

<vmw:Config ovf:required="false" vmw:key="firmware" vmw:value="bios"/>

to
<vmw:Config ovf:required="false" vmw:key="firmware" vmw:value="efi"/>

Can someone fix this ?

Revision history for this message
Dan Watkins (oddbloke) wrote :

Could someone test the OVA at http://cloud-images.ubuntu.com/artful/current/artful-server-cloudimg-amd64.ova and check whether the issue exhibits in the latest version of Ubuntu?

summary: - Ubuntu 16.04 (Xenial Xerus) OVA
+ Ubuntu 16.04 (Xenial Xerus) OVA doesn't boot due to incorrect firmware
+ metadata
Changed in cloud-images:
status: Confirmed → Incomplete
Revision history for this message
SooYoung Kim (piranha77) wrote :

I had a similar problem.

In my case, the error message is as follows:
"The OVF package is invalid and cannot be deployed."
"The following manifest file entry (line 1) is invalid: SHA256(ubuntu-xenial-16.04-cloudimg.vmdk ..."

I tried to edit the ova file as above (bios -> efi). BUT, it is not worked for me.

I solved this problem by using VMware OVF Tool with "--skipManifestGeneration" as follows.

---------------------
c:\Users\<myhome>\Downloads>"C:\Program Files\VMware\VMware OVF Tool\ovftool.exe" --skipManifestGeneration -o "ubuntu-16.04-server-cloudimg-amd64.ova" "ubuntu-16.04-server-cloudimg-amd64-skipManifestGeneration.ova
Opening OVA source: ubuntu-16.04-server-cloudimg-amd64.ova
The manifest validates
Opening OVA target: ubuntu-16.04-server-cloudimg-amd64-skipManifestGeneration.ova
Writing OVA package: ubuntu-16.04-server-cloudimg-amd64-skipManifestGeneration.ova
Transfer Completed
Completed successfully
--------------------

Revision history for this message
Launchpad Janitor (janitor) wrote :

[Expired for cloud-images because there has been no activity for 60 days.]

Changed in cloud-images:
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers