[SRU] Neutron Stable Releases

Bug #1899051 reported by Chris MacNaughton on 2020-10-08
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Cloud Archive
Undecided
Unassigned
Stein
Undecided
Unassigned
Train
Undecided
Unassigned
Ussuri
Undecided
Unassigned
neutron (Ubuntu)
Undecided
Unassigned
Focal
Undecided
Unassigned

Bug Description

[Impact]
This release sports mostly bug-fixes and we would like to make sure all of our supported customers have access to these improvements. The update contains the following package updates:

neutron:

Ussuri - 16.2.0
Train - 15.3.0
Stein - 14.4.0

[Test Case]
The following SRU process was followed:
https://wiki.ubuntu.com/OpenStackUpdates

In order to avoid regression of existing consumers, the OpenStack team will run their continuous integration test against the packages that are in -proposed. A successful run of all available tests will be required before the proposed packages can be let into -updates.

The OpenStack team will be in charge of attaching the output summary of the executed tests. The OpenStack team members will not mark ‘verification-done’ until this has happened.

[Regression Potential]
In order to mitigate the regression potential, the results of the
aforementioned tests are attached to this bug.

Changed in cloud-archive:
status: New → Invalid
description: updated
description: updated

Hello Chris, or anyone else affected,

Accepted neutron into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/neutron/2:16.2.0-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in neutron (Ubuntu):
status: New → Invalid
Changed in neutron (Ubuntu Focal):
status: New → Fix Committed
tags: added: verification-needed verification-needed-focal
Corey Bryant (corey.bryant) wrote :

Hello Chris, or anyone else affected,

Accepted neutron into ussuri-proposed. The package will build now and be available in the Ubuntu Cloud Archive in a few hours, and then in the -proposed repository.

Please help us by testing this new package. To enable the -proposed repository:

  sudo add-apt-repository cloud-archive:ussuri-proposed
  sudo apt-get update

Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-ussuri-needed to verification-ussuri-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-ussuri-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-ussuri-needed
Download full text (10.8 KiB)

Verification was performed on Focal + Proposed:

======
Totals
======
Ran: 97 tests in 1502.8423 sec.
 - Passed: 89
 - Skipped: 8
 - Expected Fail: 0
 - Unexpected Success: 0
 - Failed: 0
Sum of execute time for each test: 2256.9578 sec.

Full run details follow

{1} tempest.api.compute.flavors.test_flavors.FlavorsV2TestJSON.test_get_flavor [0.291654s] ... ok
{1} tempest.api.compute.flavors.test_flavors.FlavorsV2TestJSON.test_list_flavors [0.100626s] ... ok
{3} tempest.api.compute.security_groups.test_security_group_rules.SecurityGroupRulesTestJSON.test_security_group_rules_create [5.852957s] ... ok
{3} tempest.api.compute.security_groups.test_security_group_rules.SecurityGroupRulesTestJSON.test_security_group_rules_list [8.871421s] ... ok
{1} tempest.api.compute.security_groups.test_security_groups.SecurityGroupsTestJSON.test_security_groups_create_list_delete [19.450940s] ... ok
{0} tempest.api.compute.servers.test_create_server.ServersTestManualDisk.test_list_servers [0.218269s] ... ok
{0} tempest.api.compute.servers.test_create_server.ServersTestManualDisk.test_verify_server_details [0.001641s] ... ok
{3} tempest.api.compute.servers.test_create_server.ServersTestJSON.test_list_servers [0.677721s] ... ok
{3} tempest.api.compute.servers.test_create_server.ServersTestJSON.test_verify_server_details [0.001008s] ... ok
{1} tempest.api.compute.servers.test_create_server.ServersTestBootFromVolume.test_list_servers [0.196485s] ... ok
{1} tempest.api.compute.servers.test_create_server.ServersTestBootFromVolume.test_verify_server_details [0.001675s] ... ok
{3} setUpClass (tempest.api.identity.admin.v2.test_users.UsersTestJSON) ... SKIPPED: Identity api v2 is not enabled
{3} tempest.api.identity.admin.v3.test_roles.RolesV3TestJSON.test_role_create_update_show_list [0.277102s] ... ok
{3} tempest.api.identity.admin.v3.test_services.ServicesTestJSON.test_create_update_get_service [1.188815s] ... ok
{2} tempest.api.compute.servers.test_attach_interfaces.AttachInterfacesUnderV243Test.test_add_remove_fixed_ip [223.580724s] ... ok
{3} tempest.api.image.v2.test_images.BasicOperationsImagesTest.test_delete_image [0.523510s] ... ok
{3} tempest.api.image.v2.test_images.BasicOperationsImagesTest.test_register_upload_get_image_file [0.918954s] ... ok
{3} tempest.api.image.v2.test_images.BasicOperationsImagesTest.test_update_image [0.171424s] ... ok
{3} tempest.api.image.v2.test_versions.VersionsTest.test_list_versions [0.018722s] ... ok
{1} tempest.api.identity.admin.v3.test_groups.GroupsV3TestJSON.test_group_users_add_list_delete [4.173502s] ... ok
{3} setUpClass (tempest.api.network.test_ports.PortsIpV6TestJSON) ... SKIPPED: IPv6 Tests are disabled.
{1} tempest.api.identity.admin.v3.test_policies.PoliciesTestJSON.test_create_update_delete_policy [1.525329s] ... ok
{2} tempest.api.identity.admin.v3.test_credentials.CredentialsTestJSON.test_credentials_create_get_update_delete [0.800136s] ... ok
{2} tempest.api.identity.admin.v3.test_domains.DomainsTestJSON.test_create_update_delete_domain [1.187642s] ... ok
{1} tempest.api.identity.admin.v3.test_regions.RegionsTestJSON.test_create_region_with_specific_id [0.386268s] ... ok
{2} setUpClass (tempest.api.identity....

tags: added: verification-done verification-done-focal
removed: verification-needed verification-needed-focal
Download full text (11.1 KiB)

Verification was performed on Bionic with the Cloud Archive + Proposed:

======
Totals
======
Ran: 97 tests in 821.1883 sec.
 - Passed: 89
 - Skipped: 8
 - Expected Fail: 0
 - Unexpected Success: 0
 - Failed: 0
Sum of execute time for each test: 1208.4573 sec.

Full run details follow

{1} tempest.api.compute.flavors.test_flavors.FlavorsV2TestJSON.test_get_flavor [0.177959s] ... ok
{1} tempest.api.compute.flavors.test_flavors.FlavorsV2TestJSON.test_list_flavors [0.064595s] ... ok
{3} tempest.api.compute.security_groups.test_security_group_rules.SecurityGroupRulesTestJSON.test_security_group_rules_create [5.102454s] ... ok
{3} tempest.api.compute.security_groups.test_security_group_rules.SecurityGroupRulesTestJSON.test_security_group_rules_list [2.957893s] ... ok
{1} tempest.api.compute.security_groups.test_security_groups.SecurityGroupsTestJSON.test_security_groups_create_list_delete [11.424765s] ... ok
{0} tempest.api.compute.servers.test_create_server.ServersTestManualDisk.test_list_servers [0.283428s] ... ok
{0} tempest.api.compute.servers.test_create_server.ServersTestManualDisk.test_verify_server_details [0.001776s] ... ok
{1} tempest.api.compute.servers.test_create_server.ServersTestBootFromVolume.test_list_servers [0.219229s] ... ok
{1} tempest.api.compute.servers.test_create_server.ServersTestBootFromVolume.test_verify_server_details [0.000963s] ... ok
{3} tempest.api.compute.servers.test_create_server.ServersTestJSON.test_list_servers [0.254627s] ... ok
{3} tempest.api.compute.servers.test_create_server.ServersTestJSON.test_verify_server_details [0.001240s] ... ok
{2} tempest.api.compute.servers.test_attach_interfaces.AttachInterfacesUnderV243Test.test_add_remove_fixed_ip [156.288916s] ... ok
{1} tempest.api.identity.admin.v3.test_groups.GroupsV3TestJSON.test_group_users_add_list_delete [3.094502s] ... ok
{3} setUpClass (tempest.api.identity.admin.v2.test_users.UsersTestJSON) ... SKIPPED: Identity api v2 is not enabled
{3} tempest.api.identity.admin.v3.test_roles.RolesV3TestJSON.test_role_create_update_show_list [1.622578s] ... ok
{1} tempest.api.identity.admin.v3.test_policies.PoliciesTestJSON.test_create_update_delete_policy [2.364963s] ... ok
{2} tempest.api.identity.admin.v3.test_credentials.CredentialsTestJSON.test_credentials_create_get_update_delete [1.382396s] ... ok
{3} tempest.api.identity.admin.v3.test_services.ServicesTestJSON.test_create_update_get_service [1.754964s] ... ok
{1} tempest.api.identity.admin.v3.test_regions.RegionsTestJSON.test_create_region_with_specific_id [0.325298s] ... ok
{2} tempest.api.identity.admin.v3.test_domains.DomainsTestJSON.test_create_update_delete_domain [2.045405s] ... ok
{3} tempest.api.image.v2.test_images.BasicOperationsImagesTest.test_delete_image [0.788031s] ... ok
{2} setUpClass (tempest.api.identity.v2.test_api_discovery.TestApiDiscovery) ... SKIPPED: Identity api v2 is not enabled
{3} tempest....

tags: added: verification-ussuri-done
removed: verification-ussuri-needed

The verification of the Stable Release Update for neutron has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package neutron - 2:16.2.0-0ubuntu1

---------------
neutron (2:16.2.0-0ubuntu1) focal; urgency=medium

  * d/control: Update VCS paths for move to lp:~ubuntu-openstack-dev.
  * New stable point release for OpenStack Stein (LP: #1899051).
  * d/p/skip-iptest.patch: Refreshed.
  * d/p/Ensure-fip-ip-rules-deleted-when-fip-removed.patch: Removed because
    change landed upstream.

 -- Chris MacNaughton <email address hidden> Mon, 12 Oct 2020 09:07:49 +0000

Changed in neutron (Ubuntu Focal):
status: Fix Committed → Fix Released
Corey Bryant (corey.bryant) wrote :

The verification of the Stable Release Update for neutron has completed successfully and the package has now been released to -updates. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Corey Bryant (corey.bryant) wrote :

This bug was fixed in the package neutron - 2:16.2.0-0ubuntu1~cloud0
---------------

 neutron (2:16.2.0-0ubuntu1~cloud0) bionic-ussuri; urgency=medium
 .
   * New upstream release for the Ubuntu Cloud Archive.
 .
 neutron (2:16.2.0-0ubuntu1) focal; urgency=medium
 .
   * d/control: Update VCS paths for move to lp:~ubuntu-openstack-dev.
   * New stable point release for OpenStack Stein (LP: #1899051).
   * d/p/skip-iptest.patch: Refreshed.
   * d/p/Ensure-fip-ip-rules-deleted-when-fip-removed.patch: Removed because
     change landed upstream.

Corey Bryant (corey.bryant) wrote :

Chris, neutron 15.3.0 is in train-proposed. Can you verify it as well? The reason it didn't automatically update the bug is probably because debuild -v didn't specify the verion prior to the 15.3.0 version (ie. I think there is more than one new version in the changelog).

Corey Bryant (corey.bryant) wrote :

Same for stein ^

tags: added: verification-stein-needed verification-train-needed
Download full text (10.8 KiB)

Verification was performed with the Train Cloud Archive on Bionic:

======
Totals
======
Ran: 97 tests in 696.2879 sec.
 - Passed: 89
 - Skipped: 8
 - Expected Fail: 0
 - Unexpected Success: 0
 - Failed: 0
Sum of execute time for each test: 1021.8918 sec.

Summary of tests run:

{1} tempest.api.compute.flavors.test_flavors.FlavorsV2TestJSON.test_get_flavor [0.262465s] ... ok
{1} tempest.api.compute.flavors.test_flavors.FlavorsV2TestJSON.test_list_flavors [0.066181s] ... ok
{3} tempest.api.compute.security_groups.test_security_group_rules.SecurityGroupRulesTestJSON.test_security_group_rules_create [7.228734s] ... ok
{1} tempest.api.compute.security_groups.test_security_groups.SecurityGroupsTestJSON.test_security_groups_create_list_delete [4.738256s] ... ok
{3} tempest.api.compute.security_groups.test_security_group_rules.SecurityGroupRulesTestJSON.test_security_group_rules_list [5.572697s] ... ok
{0} tempest.api.compute.servers.test_create_server.ServersTestManualDisk.test_list_servers [0.478649s] ... ok
{0} tempest.api.compute.servers.test_create_server.ServersTestManualDisk.test_verify_server_details [0.000753s] ... ok
{3} tempest.api.compute.servers.test_create_server.ServersTestJSON.test_list_servers [0.265917s] ... ok
{3} tempest.api.compute.servers.test_create_server.ServersTestJSON.test_verify_server_details [0.000725s] ... ok
{1} tempest.api.compute.servers.test_create_server.ServersTestBootFromVolume.test_list_servers [0.181951s] ... ok
{1} tempest.api.compute.servers.test_create_server.ServersTestBootFromVolume.test_verify_server_details [0.001049s] ... ok
{2} tempest.api.compute.servers.test_attach_interfaces.AttachInterfacesUnderV243Test.test_add_remove_fixed_ip [120.368779s] ... ok
{3} setUpClass (tempest.api.identity.admin.v2.test_users.UsersTestJSON) ... SKIPPED: Identity api v2 is not enabled
{2} tempest.api.identity.admin.v3.test_credentials.CredentialsTestJSON.test_credentials_create_get_update_delete [0.202004s] ... ok
{3} tempest.api.identity.admin.v3.test_roles.RolesV3TestJSON.test_role_create_update_show_list [0.408403s] ... ok
{2} tempest.api.identity.admin.v3.test_domains.DomainsTestJSON.test_create_update_delete_domain [1.280511s] ... ok
{2} setUpClass (tempest.api.identity.v2.test_api_discovery.TestApiDiscovery) ... SKIPPED: Identity api v2 is not enabled
{3} tempest.api.identity.admin.v3.test_services.ServicesTestJSON.test_create_update_get_service [3.253293s] ... ok
{2} tempest.api.identity.v3.test_domains.DefaultDomainTestJSON.test_default_domain_exists [0.175675s] ... ok
{1} tempest.api.identity.admin.v3.test_groups.GroupsV3TestJSON.test_group_users_add_list_delete [5.458857s] ... ok
{3} tempest.api.image.v2.test_images.BasicOperationsImagesTest.test_delete_image [0.392156s] ... ok
{3} tempest.api.image.v2.test_images.BasicOperationsImagesTest.test_register_upload_get_image_file [0.954285s] ... ok
{3} tempest.api.image.v2.test_images.BasicOperationsImagesTest.test_update_image [0.123411s] ... ok
{1} tempest.api.identity.admin.v3.test_policies.PoliciesTestJSON.test_create_update_delete_policy [0.598007s] ... ok
{3} tempest.api.image.v2.test_versions.VersionsTest.test_list_versions [0.010004s] ... ok
{3} setUpClass ...

tags: added: verification-train-done
removed: verification-train-needed
Download full text (10.8 KiB)

Verification was performed with the Stein Cloud Archive on Bionic:

======
Totals
======
Ran: 97 tests in 685.4942 sec.
 - Passed: 89
 - Skipped: 8
 - Expected Fail: 0
 - Unexpected Success: 0
 - Failed: 0
Sum of execute time for each test: 1074.9082 sec.

Summary of tests run:

{1} tempest.api.compute.flavors.test_flavors.FlavorsV2TestJSON.test_get_flavor [0.187747s] ... ok
{1} tempest.api.compute.flavors.test_flavors.FlavorsV2TestJSON.test_list_flavors [0.067206s] ... ok
{3} tempest.api.compute.security_groups.test_security_group_rules.SecurityGroupRulesTestJSON.test_security_group_rules_create [1.311727s] ... ok
{3} tempest.api.compute.security_groups.test_security_group_rules.SecurityGroupRulesTestJSON.test_security_group_rules_list [8.541252s] ... ok
{1} tempest.api.compute.security_groups.test_security_groups.SecurityGroupsTestJSON.test_security_groups_create_list_delete [16.926876s] ... ok
{0} tempest.api.compute.servers.test_create_server.ServersTestManualDisk.test_list_servers [1.308775s] ... ok
{0} tempest.api.compute.servers.test_create_server.ServersTestManualDisk.test_verify_server_details [0.000830s] ... ok
{3} tempest.api.compute.servers.test_create_server.ServersTestJSON.test_list_servers [0.225572s] ... ok
{3} tempest.api.compute.servers.test_create_server.ServersTestJSON.test_verify_server_details [0.001396s] ... ok
{1} tempest.api.compute.servers.test_create_server.ServersTestBootFromVolume.test_list_servers [0.186995s] ... ok
{1} tempest.api.compute.servers.test_create_server.ServersTestBootFromVolume.test_verify_server_details [0.000916s] ... ok
{2} tempest.api.compute.servers.test_attach_interfaces.AttachInterfacesUnderV243Test.test_add_remove_fixed_ip [152.968351s] ... ok
{3} setUpClass (tempest.api.identity.admin.v2.test_users.UsersTestJSON) ... SKIPPED: Identity api v2 is not enabled
{3} tempest.api.identity.admin.v3.test_roles.RolesV3TestJSON.test_role_create_update_show_list [2.154145s] ... ok
{2} tempest.api.identity.admin.v3.test_credentials.CredentialsTestJSON.test_credentials_create_get_update_delete [1.656506s] ... ok
{1} tempest.api.identity.admin.v3.test_groups.GroupsV3TestJSON.test_group_users_add_list_delete [8.051045s] ... ok
{3} tempest.api.identity.admin.v3.test_services.ServicesTestJSON.test_create_update_get_service [1.737159s] ... ok
{3} tempest.api.image.v2.test_images.BasicOperationsImagesTest.test_delete_image [0.600384s] ... ok
{2} tempest.api.identity.admin.v3.test_domains.DomainsTestJSON.test_create_update_delete_domain [1.309934s] ... ok
{3} tempest.api.image.v2.test_images.BasicOperationsImagesTest.test_register_upload_get_image_file [0.964685s] ... ok
{3} tempest.api.image.v2.test_images.BasicOperationsImagesTest.test_update_image [0.134652s] ... ok
{1} tempest.api.identity.admin.v3.test_policies.PoliciesTestJSON.test_create_update_delete_policy [1.713314s] ... ok
{2} setUpClass (tempest.api.identity.v2.test_api_discovery.TestApiDiscovery) ... SKIPPED: Identity api v2 is not enabled
{0} tempest.api.compute.servers.test_server_actions.ServerActionsTestJSON.test_reboot_server_hard [28.673241s] ... ok
{3} tempest.api.image.v2.test_versions.VersionsTest.test_list_versions [0.008911s] ... ok
{2} t...

tags: added: verification-stein-done
removed: verification-stein-needed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers