[SRU] stein stable releases

Bug #1837905 reported by Sahid Orentino on 2019-07-25
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu Cloud Archive
High
Unassigned
Stein
High
Unassigned
cinder (Ubuntu)
Undecided
Unassigned
Disco
High
Unassigned
horizon (Ubuntu)
Undecided
Unassigned
Disco
High
Unassigned

Bug Description

[Impact]
This release sports mostly bug-fixes and we would like to make sure all of our supported customers have access to these improvements. The update contains the following package updates:

cinder 14.0.1
horizon 15.1.0

[Test Case]
The following SRU process was followed:
https://wiki.ubuntu.com/OpenStackUpdates

In order to avoid regression of existing consumers, the OpenStack team will run their continuous integration test against the packages that are in -proposed. A successful run of all available tests will be required before the proposed packages can be let into -updates.

The OpenStack team will be in charge of attaching the output summary of the executed tests. The OpenStack team members will not mark ‘verification-done’ until this has happened.

[Regression Potential]
In order to mitigate the regression potential, the results of the
aforementioned tests are attached to this bug.

[Discussion]
n/a

description: updated
no longer affects: cinder
Changed in cinder (Ubuntu Disco):
status: New → Triaged
importance: Undecided → High
Changed in cinder (Ubuntu):
status: New → Invalid
Changed in horizon (Ubuntu):
status: New → Invalid
Changed in horizon (Ubuntu Disco):
status: New → Triaged
importance: Undecided → High

Hello Sahid, or anyone else affected,

Accepted cinder into disco-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/cinder/2:14.0.1-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-disco to verification-done-disco. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-disco. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in cinder (Ubuntu Disco):
status: Triaged → Fix Committed
tags: added: verification-needed verification-needed-disco
Brian Murray (brian-murray) wrote :

Hello Sahid, or anyone else affected,

Accepted horizon into disco-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/horizon/3:15.1.0-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-disco to verification-done-disco. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-disco. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in horizon (Ubuntu Disco):
status: Triaged → Fix Committed
Corey Bryant (corey.bryant) wrote :

Note: horizon had an ftbfs because I didn't upload it with the xstatic orig tar file. That's been fixed in the disco unapproved queue.

Changed in horizon (Ubuntu Disco):
status: Fix Committed → Triaged
Corey Bryant (corey.bryant) wrote :

Moving horizon back to triaged due to comment #4.

Corey Bryant (corey.bryant) wrote :

SRU team, there are 2 uploads of horizon 3:15.1.0-0ubuntu1.1 in the disco unapproved queue. Please review the one with the following .changes and reject the other: https://launchpadlibrarian.net/435373762/horizon_15.1.0-0ubuntu1.1_source.changes

Łukasz Zemczak (sil2100) wrote :

Hello Sahid, or anyone else affected,

Accepted horizon into disco-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/horizon/3:15.1.0-0ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-disco to verification-done-disco. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-disco. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in horizon (Ubuntu Disco):
status: Triaged → Fix Committed
James Page (james-page) wrote :

Hello Sahid, or anyone else affected,

Accepted cinder into stein-proposed. The package will build now and be available in the Ubuntu Cloud Archive in a few hours, and then in the -proposed repository.

Please help us by testing this new package. To enable the -proposed repository:

  sudo add-apt-repository cloud-archive:stein-proposed
  sudo apt-get update

Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-stein-needed to verification-stein-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-stein-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-stein-needed
James Page (james-page) wrote :

Hello Sahid, or anyone else affected,

Accepted horizon into stein-proposed. The package will build now and be available in the Ubuntu Cloud Archive in a few hours, and then in the -proposed repository.

Please help us by testing this new package. To enable the -proposed repository:

  sudo add-apt-repository cloud-archive:stein-proposed
  sudo apt-get update

Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-stein-needed to verification-stein-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-stein-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

======
Totals
======
Ran: 92 tests in 1103.8351 sec.
 - Passed: 84
 - Skipped: 8
 - Expected Fail: 0
 - Unexpected Success: 0
 - Failed: 0
Sum of execute time for each test: 544.0273 sec.

tags: added: verification-stein-done
removed: verification-stein-needed
Corey Bryant (corey.bryant) wrote :

@Sahid, can you sanity test the horizon dashboard for this? Thanks, Corey

Corey Bryant (corey.bryant) wrote :

This will also need testing on bionic with stein-proposed.

Hello Corey, sanity tests done for stein-proposed.

======
Totals
======
Ran: 92 tests in 2057.0000 sec.
 - Passed: 84
 - Skipped: 8
 - Expected Fail: 0
 - Unexpected Success: 0
 - Failed: 0
Sum of execute time for each test: 1007.9851 sec.

It is to note that a regression in charm-neutron-api fixed by:

  https://review.opendev.org/#/c/680956/

tags: added: verification-done-disco
removed: verification-needed-disco
tags: removed: verification-needed
tags: added: verification-done-bionic
removed: verification-done-disco
Łukasz Zemczak (sil2100) wrote :

Is this tested for disco or not? I am asking since I saw verification-done-disco tags set, then changed to verification-done-bionic - but there does not seem to be any bionic upload in -proposed right now.

Can we treat this as tested?

Yes, disco has been verified by "verification-done-stein" since the default for stein is disco. Is that makes sense for you?

Alvaro Uria (aluria) wrote :

Hi. The bug that affects Horizon (bug 1834747) has been marked as invalid for the cloud-archive project. However, this is still a problem in bionic-stein deployments, which cause error 500s and are fixed by upgrading to the -proposed version (15.1.0).

What is missing to have "openstack-dashboard" package and its dependencies in -updates?

Thank you.

Łukasz Zemczak (sil2100) wrote :

So to confirm: the disco-proposed packages:

https://launchpad.net/ubuntu/+source/cinder/2:14.0.1-0ubuntu1
https://launchpad.net/ubuntu/+source/horizon/3:15.1.0-0ubuntu1.1

Have been tested from disco-proposed, correct? Is there any reason why the tag is not set to verification-done-disco in that case?

Done in #10 with sanitychekc for horizon #13, #14, #15.

As mentioned #21. stein is deployed by default with disco. I was just not aware of that a tag 'verification-done-disco' should also be set. Since 'verification-done-stein' implicitly implies disco.

James Page (james-page) wrote :

@sahid

If testing was done of the disco-proposed updates, please use the 'verification-done-disco' tag as this is the one that the SRU team use for tracking purposes - verification-done-stein is not used by the SRU team or the OpenStack team for the UCA.

tags: added: verification-needed-disco
removed: verification-done-bionic
James Page (james-page) wrote :

I've reset the 'verification-needed-disco' tag and dropped the bionic one pending confirmation from @sahid.

======
Totals
======
Ran: 92 tests in 1489.0000 sec.
 - Passed: 84
 - Skipped: 8
 - Expected Fail: 0
 - Unexpected Success: 0
 - Failed: 0
Sum of execute time for each test: 697.9893 sec.

tags: added: verification-done-disco
removed: verification-needed-disco
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cinder - 2:14.0.1-0ubuntu1

---------------
cinder (2:14.0.1-0ubuntu1) disco; urgency=medium

  [ Corey Bryant ]
  * d/gbp.conf: Create stable/stein branch.

  [ Sahid Orentino Ferdjaoui ]
  * New stable point release for OpenStack Stein (LP: #1837905).

 -- Sahid Orentino Ferdjaoui <email address hidden> Mon, 29 Jul 2019 08:36:06 +0200

Changed in cinder (Ubuntu Disco):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for cinder has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package horizon - 3:15.1.0-0ubuntu1.1

---------------
horizon (3:15.1.0-0ubuntu1.1) disco; urgency=medium

  * No change rebuild to pick up xstatic orig tarball.

horizon (3:15.1.0-0ubuntu1) disco; urgency=medium

  [ Corey Bryant ]
  * d/gbp.conf: Create stable/stein branch.

  [ Sahid Orentino Ferdjaoui ]
  * New stable point release for OpenStack Stein (LP: #1837905).
  * d/p/set-min-version-of-python-cinderclient-to-4.0.0.patch: Dropped.
    Fixed in upstream 15.1.0.

 -- Corey Bryant <email address hidden> Wed, 31 Jul 2019 10:06:53 -0400

Changed in horizon (Ubuntu Disco):
status: Fix Committed → Fix Released
Corey Bryant (corey.bryant) wrote :

The verification of the Stable Release Update for cinder has completed successfully and the package has now been released to -updates. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Corey Bryant (corey.bryant) wrote :

This bug was fixed in the package cinder - 2:14.0.1-0ubuntu1~cloud0
---------------

 cinder (2:14.0.1-0ubuntu1~cloud0) bionic-stein; urgency=medium
 .
   * New upstream release for the Ubuntu Cloud Archive.
 .
 cinder (2:14.0.1-0ubuntu1) disco; urgency=medium
 .
   [ Corey Bryant ]
   * d/gbp.conf: Create stable/stein branch.
 .
   [ Sahid Orentino Ferdjaoui ]
   * New stable point release for OpenStack Stein (LP: #1837905).

Corey Bryant (corey.bryant) wrote :

The verification of the Stable Release Update for horizon has completed successfully and the package has now been released to -updates. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Corey Bryant (corey.bryant) wrote :

This bug was fixed in the package horizon - 3:15.1.0-0ubuntu1.1~cloud0
---------------

 horizon (3:15.1.0-0ubuntu1.1~cloud0) bionic-stein; urgency=medium
 .
   * New upstream release for the Ubuntu Cloud Archive.
 .
 horizon (3:15.1.0-0ubuntu1.1) disco; urgency=medium
 .
   * No change rebuild to pick up xstatic orig tarball.
 .
 horizon (3:15.1.0-0ubuntu1) disco; urgency=medium
 .
   [ Corey Bryant ]
   * d/gbp.conf: Create stable/stein branch.
 .
   [ Sahid Orentino Ferdjaoui ]
   * New stable point release for OpenStack Stein (LP: #1837905).
   * d/p/set-min-version-of-python-cinderclient-to-4.0.0.patch: Dropped.
     Fixed in upstream 15.1.0.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers