[SRU] stein stable releases

Bug #1831754 reported by Sahid Orentino on 2019-06-05
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ubuntu Cloud Archive
High
Unassigned
Stein
High
Unassigned
neutron (Ubuntu)
Undecided
Unassigned
Disco
High
Unassigned
nova (Ubuntu)
Undecided
Unassigned
Disco
High
Unassigned

Bug Description

[Impact]
This release sports mostly bug-fixes and we would like to make sure all of our supported customers have access to these improvements. The update contains the following package updates:

neutron 14.0.2
nova 19.0.1

[Test Case]
The following SRU process was followed:
https://wiki.ubuntu.com/OpenStackUpdates

In order to avoid regression of existing consumers, the OpenStack team will run their continuous integration test against the packages that are in -proposed. A successful run of all available tests will be required before the proposed packages can be let into -updates.

The OpenStack team will be in charge of attaching the output summary of the executed tests. The OpenStack team members will not mark ‘verification-done’ until this has happened.

[Regression Potential]
In order to mitigate the regression potential, the results of the
aforementioned tests are attached to this bug.

[Discussion]
n/a

Changed in neutron (Ubuntu):
status: New → Invalid
Changed in neutron (Ubuntu Disco):
status: New → Triaged
importance: Undecided → High
description: updated

Hello Sahid, or anyone else affected,

Accepted neutron into disco-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/neutron/2:14.0.1-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-disco to verification-done-disco. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-disco. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in neutron (Ubuntu Disco):
status: Triaged → Fix Committed
tags: added: verification-needed verification-needed-disco
do3meli (d-info-e) wrote :

Will that only be fixed in disco or also in bionic?

James Page (james-page) wrote :

Hello Sahid, or anyone else affected,

Accepted neutron into stein-proposed. The package will build now and be available in the Ubuntu Cloud Archive in a few hours, and then in the -proposed repository.

Please help us by testing this new package. To enable the -proposed repository:

  sudo add-apt-repository cloud-archive:stein-proposed
  sudo apt-get update

Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-stein-needed to verification-stein-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-stein-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-stein-needed
James Page (james-page) wrote :

@sil2100 - can we get the nova part accepted as well so the regression testing can start?

description: updated
Changed in nova (Ubuntu):
status: New → Triaged
Changed in nova (Ubuntu Disco):
status: New → Triaged
Changed in nova (Ubuntu):
status: Triaged → Invalid
Changed in nova (Ubuntu Disco):
importance: Undecided → High
Brian Murray (brian-murray) wrote :

Hello Sahid, or anyone else affected,

Accepted nova into disco-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/nova/2:19.0.1-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-disco to verification-done-disco. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-disco. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in nova (Ubuntu Disco):
status: Triaged → Fix Committed
Brian Murray (brian-murray) wrote :

Hello Sahid, or anyone else affected,

Accepted neutron into disco-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/neutron/2:14.0.2-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-disco to verification-done-disco. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-disco. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

James Page (james-page) wrote :

Hello Sahid, or anyone else affected,

Accepted neutron into stein-proposed. The package will build now and be available in the Ubuntu Cloud Archive in a few hours, and then in the -proposed repository.

Please help us by testing this new package. To enable the -proposed repository:

  sudo add-apt-repository cloud-archive:stein-proposed
  sudo apt-get update

Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-stein-needed to verification-stein-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-stein-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

James Page (james-page) wrote :

Hello Sahid, or anyone else affected,

Accepted nova into stein-proposed. The package will build now and be available in the Ubuntu Cloud Archive in a few hours, and then in the -proposed repository.

Please help us by testing this new package. To enable the -proposed repository:

  sudo add-apt-repository cloud-archive:stein-proposed
  sudo apt-get update

Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-stein-needed to verification-stein-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-stein-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

James Page (james-page) wrote :

disco/proposed testing:

======
Totals
======
Ran: 92 tests in 680.1228 sec.
 - Passed: 84
 - Skipped: 8
 - Expected Fail: 0
 - Unexpected Success: 0
 - Failed: 0
Sum of execute time for each test: 907.4907 sec.

tags: added: verification-done verification-done-disco
removed: verification-needed verification-needed-disco
James Page (james-page) wrote :

(had one running for fwaas validation so ran the tempest checks for this bug as well).

======
Totals
======
Ran: 92 tests in 1446.4566 sec.
 - Passed: 84
 - Skipped: 8
 - Expected Fail: 0
 - Unexpected Success: 0
 - Failed: 0
Sum of execute time for each test: 754.1376 sec.

tags: added: verification-stein-done
removed: verification-stein-needed
Corey Bryant (corey.bryant) wrote :

Sahid, Can you re-test since the UCA wasn't syncing correctly until this past weekend?

root@juju-a7adf6-sahidf-18:~# dpkg -s neutron-common | grep -i version
Version: 2:14.0.2-0ubuntu1~cloud0
root@juju-a7adf6-sahidf-21:~# dpkg -s nova-common | grep -i version
Version: 2:19.0.1-0ubuntu1~cloud0

======
Totals
======
Ran: 92 tests in 1257.2802 sec.
 - Passed: 84
 - Skipped: 8
 - Expected Fail: 0
 - Unexpected Success: 0
 - Failed: 0
Sum of execute time for each test: 624.1415 sec.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nova - 2:19.0.1-0ubuntu1

---------------
nova (2:19.0.1-0ubuntu1) disco; urgency=medium

  [ Corey Bryant ]
  * d/p/skip-openssl-1.1.1-tests.patch: Dropped as this is now properly fixed
    by xenapi-agent-change-openssl-error-handling.patch.

  [ Sahid Orentino Ferdjaoui ]
  * New upstream release for OpenStack Stein (LP: #1831754)
  * d/p/eventlet-monkey-patching-should-be-as-early-as-possible.patch: Dropped.
    Fixed upstream in 19.0.1.
  * d/p/xenapi-agent-change-openssl-error-handling.patch: Dropped. Fixed
    upstream in 19.0.1.
  * d/p/bug_1825882.patch: Dropped. Fixed upstream in 19.0.1.
  * d/p/bug_1826523.patch: Dropped. Fixed upstream in 19.0.1.

 -- Sahid Orentino Ferdjaoui <email address hidden> Fri, 07 Jun 2019 10:29:14 +0200

Changed in nova (Ubuntu Disco):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for nova has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package neutron - 2:14.0.2-0ubuntu1

---------------
neutron (2:14.0.2-0ubuntu1) disco; urgency=medium

  * New upstream release for OpenStack Stein (LP: #1831754).
  * d/p/bug1826419.patch: Dropped. Fixed upstream in 14.0.2.
  * d/p/revert-iptables-tcp-checksum-fill-code.patch: Dropped. Fixed
    upstream in 14.0.2.

neutron (2:14.0.1-0ubuntu2) disco; urgency=medium

  * d/p/revert-iptables-tcp-checksum-fill-code.patch: Cherry-picked
    from upstream to revert invalid use of iptables -j CHECKSUM
    (LP: #1722584).

 -- Sahid Orentino Ferdjaoui <email address hidden> Wed, 03 Jul 2019 16:22:58 +0200

Changed in neutron (Ubuntu Disco):
status: Fix Committed → Fix Released
Corey Bryant (corey.bryant) wrote :

The verification of the Stable Release Update for neutron has completed successfully and the package has now been released to -updates. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Corey Bryant (corey.bryant) wrote :

This bug was fixed in the package neutron - 2:14.0.2-0ubuntu1~cloud0
---------------

 neutron (2:14.0.2-0ubuntu1~cloud0) bionic-stein; urgency=medium
 .
   * New upstream release for the Ubuntu Cloud Archive.
 .
 neutron (2:14.0.2-0ubuntu1) disco; urgency=medium
 .
   * New upstream release for OpenStack Stein (LP: #1831754).
   * d/p/bug1826419.patch: Dropped. Fixed upstream in 14.0.2.
   * d/p/revert-iptables-tcp-checksum-fill-code.patch: Dropped. Fixed
     upstream in 14.0.2.
 .
 neutron (2:14.0.1-0ubuntu2) disco; urgency=medium
 .
   * d/p/revert-iptables-tcp-checksum-fill-code.patch: Cherry-picked
     from upstream to revert invalid use of iptables -j CHECKSUM
     (LP: #1722584).

Corey Bryant (corey.bryant) wrote :

The verification of the Stable Release Update for nova has completed successfully and the package has now been released to -updates. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Corey Bryant (corey.bryant) wrote :

This bug was fixed in the package nova - 2:19.0.1-0ubuntu1~cloud0
---------------

 nova (2:19.0.1-0ubuntu1~cloud0) bionic-stein; urgency=medium
 .
   * New upstream release for the Ubuntu Cloud Archive.
 .
 nova (2:19.0.1-0ubuntu1) disco; urgency=medium
 .
   [ Corey Bryant ]
   * d/p/skip-openssl-1.1.1-tests.patch: Dropped as this is now properly fixed
     by xenapi-agent-change-openssl-error-handling.patch.
 .
   [ Sahid Orentino Ferdjaoui ]
   * New upstream release for OpenStack Stein (LP: #1831754)
   * d/p/eventlet-monkey-patching-should-be-as-early-as-possible.patch: Dropped.
     Fixed upstream in 19.0.1.
   * d/p/xenapi-agent-change-openssl-error-handling.patch: Dropped. Fixed
     upstream in 19.0.1.
   * d/p/bug_1825882.patch: Dropped. Fixed upstream in 19.0.1.
   * d/p/bug_1826523.patch: Dropped. Fixed upstream in 19.0.1.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers