swift queens proposed unmet dependencies

Bug #1750950 reported by Ryan Beisner
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Cloud Archive
Undecided
Unassigned

Bug Description

swift queens proposed has unmet dependencies

http://paste.ubuntu.com/p/BxY8Wsc3yW/

(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 64518 files and directories currently installed.)
2018-02-22 03:17:31 DEBUG install Preparing to unpack .../python3-psutil_5.4.2-1_amd64.deb ...
2018-02-22 03:17:31 DEBUG install Unpacking python3-psutil (5.4.2-1) ...
2018-02-22 03:17:31 DEBUG install Setting up python3-psutil (5.4.2-1) ...
2018-02-22 03:17:39 INFO juju-log Registered config file: /etc/swift/swift.conf
2018-02-22 03:17:39 INFO juju-log Registered config file: /etc/swift/proxy-server.conf
2018-02-22 03:17:39 INFO juju-log Registered config file: /etc/haproxy/haproxy.cfg
2018-02-22 03:17:40 INFO juju-log Registered config file: /etc/memcached.conf
2018-02-22 03:17:40 INFO juju-log Registered config file: /etc/apache2/conf.d/swift-rings
2018-02-22 03:17:40 INFO juju-log Registered config file: /etc/apache2/sites-available/openstack_https_frontend
2018-02-22 03:17:41 DEBUG juju-log Hardening function 'install'
2018-02-22 03:17:41 DEBUG juju-log Hardening function 'config_changed'
2018-02-22 03:17:41 DEBUG juju-log Hardening function 'upgrade_charm'
2018-02-22 03:17:41 DEBUG juju-log Hardening function 'update_status'
2018-02-22 03:17:42 DEBUG juju-log No hardening applied to 'install'
2018-02-22 03:17:42 INFO juju-log DEPRECATION WARNING: Function configure_installation_source is being removed on/around 2017-07 : use charmhelpers.fetch.add_source() instead.
2018-02-22 03:17:43 DEBUG install Get:1 http://archive.ubuntu.com/ubuntu bionic-proposed InRelease [235 kB]
2018-02-22 03:17:43 DEBUG install Hit:2 http://nova.clouds.archive.ubuntu.com/ubuntu bionic InRelease
2018-02-22 03:17:43 DEBUG install Hit:3 http://security.ubuntu.com/ubuntu bionic-security InRelease
2018-02-22 03:17:43 DEBUG install Hit:4 http://nova.clouds.archive.ubuntu.com/ubuntu bionic-updates InRelease
2018-02-22 03:17:43 DEBUG install Hit:5 http://nova.clouds.archive.ubuntu.com/ubuntu bionic-backports InRelease
2018-02-22 03:17:44 DEBUG install Get:6 http://archive.ubuntu.com/ubuntu bionic-proposed/main amd64 Packages [122 kB]
2018-02-22 03:17:44 DEBUG install Get:7 http://archive.ubuntu.com/ubuntu bionic-proposed/main Translation-en [53.1 kB]
2018-02-22 03:17:45 DEBUG install Get:8 http://archive.ubuntu.com/ubuntu bionic-proposed/universe amd64 Packages [211 kB]
2018-02-22 03:17:45 DEBUG install Get:9 http://archive.ubuntu.com/ubuntu bionic-proposed/universe Translation-en [118 kB]
2018-02-22 03:17:45 DEBUG install Get:10 http://archive.ubuntu.com/ubuntu bionic-proposed/multiverse amd64 Packages [11.9 kB]
2018-02-22 03:17:45 DEBUG install Get:11 http://archive.ubuntu.com/ubuntu bionic-proposed/multiverse Translation-en [4776 B]
2018-02-22 03:17:45 DEBUG install Fetched 756 kB in 2s (426 kB/s)
2018-02-22 03:17:47 DEBUG install Reading package lists...
2018-02-22 03:17:47 INFO juju-log Installing ['swift', 'swift-proxy', 'memcached', 'apache2', 'python-keystone', 'swift-plugin-s3', 'swauth', 'python-ceilometermiddleware'] with options: ['--option=Dpkg::Options::=--force-confold']
2018-02-22 03:17:47 DEBUG install Reading package lists...
2018-02-22 03:17:48 DEBUG install Building dependency tree...
2018-02-22 03:17:48 DEBUG install Reading state information...
2018-02-22 03:17:48 DEBUG install Some packages could not be installed. This may mean that you have
2018-02-22 03:17:48 DEBUG install requested an impossible situation or if you are using the unstable
2018-02-22 03:17:48 DEBUG install distribution that some required packages have not yet been created
2018-02-22 03:17:48 DEBUG install or been moved out of Incoming.
2018-02-22 03:17:48 DEBUG install The following information may help to resolve the situation:
2018-02-22 03:17:48 DEBUG install
2018-02-22 03:17:48 DEBUG install The following packages have unmet dependencies:
2018-02-22 03:17:48 DEBUG install swift : Depends: python-swift (= 2.17.0-0ubuntu1) but it is not going to be installed
2018-02-22 03:17:48 DEBUG install swift-plugin-s3 : Depends: python-swift (>= 2.14.0) but it is not going to be installed
2018-02-22 03:17:48 DEBUG install swift-proxy : Depends: python-swift (= 2.17.0-0ubuntu1) but it is not going to be installed
2018-02-22 03:17:48 DEBUG install E: Unable to correct problems, you have held broken packages.

Revision history for this message
James Page (james-page) wrote :

Actually this is bionic/proposed, not xenial-queens/proposed.

James Page (james-page)
Changed in cloud-archive:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers