nova-api conflicts with nova-placement-api in newton on xenial

Bug #1700677 reported by Chris Apsey on 2017-06-27
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu Cloud Archive
High
Unassigned
Newton
High
Unassigned
nova (Ubuntu)
High
Unassigned
Yakkety
High
Unassigned

Bug Description

[Impact]
Upgraders using the consolidated nova-api binary are unable to install and configure the nova-placement-api prior to upgrade to Ocata; this results in a short period where instances creation will be broken (until the placement-api is configured and running).

[Test Case]
sudo apt install nova-api nova-placement-api
<conflict prevents installation>

[Regression Potential]
Low; change simply drops the Conflict stanza for nova-placement-api

[Original Bug Report]
While attempting to prepare for upgrade to ocata, I ran into an apt conflict between nova-api and nova-placement-api.

======================================
Package: nova-placement-api
Version: 2:14.0.5-0ubuntu1~cloud0
Priority: extra
Section: net
Source: nova
Maintainer: Ubuntu Developers <email address hidden>
Original-Maintainer: Openstack Maintainers
<email address hidden>
Installed-Size: 56.3 kB
Depends: nova-common (= 2:14.0.5-0ubuntu1~cloud0), init-system-helpers
(>= 1.18~), lsb-base (>= 4.1+Debian11ubuntu7), python:any (>= 2.7~)
Conflicts: nova-api
Download-Size: 6,062 B
APT-Sources: http://ubuntu-cloud.archive.canonical.com/ubuntu
xenial-updates/newton/main amd64 Packages
Description: OpenStack Compute - placement API frontend
=====================================

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: nova-placement-api 2:14.0.5-0ubuntu1~cloud0 [origin: Canonical]
ProcVersionSignature: Ubuntu 4.4.0-79.100-generic 4.4.67
Uname: Linux 4.4.0-79-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.6
Architecture: amd64
CrashDB:
 {
                "impl": "launchpad",
                "project": "cloud-archive",
                "bug_pattern_url": "http://people.canonical.com/~ubuntu-archive/bugpatterns/bugpatterns.xml",
             }
Date: Mon Jun 26 21:50:53 2017
PackageArchitecture: all
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: nova
UpgradeStatus: No upgrade log present (probably fresh install)

Chris Apsey (bitskrieg) wrote :
James Page (james-page) on 2017-06-27
Changed in cloud-archive:
importance: Undecided → High
James Page (james-page) wrote :

I've pushed a fix to the stable/newton branch of the nova package git repository; this fix will have to go in after the current set of SRU's clears proposed testing.

Changed in cloud-archive:
status: New → Fix Committed
Changed in nova (Ubuntu):
status: New → Fix Released
Changed in nova (Ubuntu Yakkety):
status: New → Triaged
importance: Undecided → High
Changed in cloud-archive:
status: Fix Committed → Fix Released
Changed in nova (Ubuntu):
importance: Undecided → High
description: updated
James Page (james-page) wrote :

(Worth noting that the nova-placement-api package in newton uses the simple wsgi_script entry point for standalone binaries, not apache2+mod_wsgi as it does in later package releases - it is possible to configure for use with apache, but that's not done automatically).

This bug is still valid in the 14.0.7 release of nova

<email address hidden>:~# apt-cache depends nova-placement-api
nova-placement-api
  Depends: nova-common
  Depends: init-system-helpers
  Depends: lsb-base
  Depends: <python:any>
    python:i386
    python
  Conflicts: nova-api

<email address hidden>:~# apt-cache policy nova-placement-api
nova-placement-api:
  Installed: (none)
  Candidate: 2:14.0.7-0ubuntu1~cloud0
  Version table:
     2:14.0.7-0ubuntu1~cloud0 500
        500 http://ubuntu-cloud.archive.canonical.com/ubuntu xenial-updates/newton/main amd64 Packages
        500 http://ubuntu-cloud.archive.canonical.com/ubuntu xenial-updates/newton/main i386 Packages
        100 /var/lib/dpkg/status

James Page (james-page) on 2017-08-10
Changed in nova (Ubuntu Yakkety):
status: Triaged → Won't Fix

Hello Chris, or anyone else affected,

Accepted nova into newton-proposed. The package will build now and be available in the Ubuntu Cloud Archive in a few hours, and then in the -proposed repository.

Please help us by testing this new package. To enable the -proposed repository:

  sudo add-apt-repository cloud-archive:newton-proposed
  sudo apt-get update

Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-newton-needed to verification-newton-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-newton-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-newton-needed
James Page (james-page) wrote :

Hi Lars

Apologies; I intended that this go in with the latest set of point releases for Newton, and then missed this bug as there was no new point release for Nova at the time.

Uploaded and pushed to the -proposed testing area.

James Page (james-page) wrote :

Confirmed against cloud-archive:newton-proposed:

sudo apt install nova-api nova-placement-api

...

root@polite-yak:~# apt-cache policy nova-api
nova-api:
  Installed: 2:14.0.7-0ubuntu2~cloud0
  Candidate: 2:14.0.7-0ubuntu2~cloud0
  Version table:
 *** 2:14.0.7-0ubuntu2~cloud0 500
        500 http://ubuntu-cloud.archive.canonical.com/ubuntu xenial-proposed/newton/main amd64 Packages
        100 /var/lib/dpkg/status
     2:13.1.4-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
     2:13.0.0-0ubuntu2 500
        500 http://archive.ubuntu.com/ubuntu xenial/main amd64 Packages
root@polite-yak:~# apt-cache policy nova-placement-api
nova-placement-api:
  Installed: 2:14.0.7-0ubuntu2~cloud0
  Candidate: 2:14.0.7-0ubuntu2~cloud0
  Version table:
 *** 2:14.0.7-0ubuntu2~cloud0 500
        500 http://ubuntu-cloud.archive.canonical.com/ubuntu xenial-proposed/newton/main amd64 Packages
        100 /var/lib/dpkg/status

tags: added: verification-newton-done
removed: verification-newton-needed

The verification of the Stable Release Update for nova has completed successfully and the package has now been released to -updates. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

James Page (james-page) wrote :

This bug was fixed in the package nova - 2:14.0.7-0ubuntu2~cloud0
---------------

 nova (2:14.0.7-0ubuntu2~cloud0) xenial; urgency=medium
 .
   * d/control: Drop Conflicts: nova-api for nova-placement-api binary
     package; it does not conflict with the consolidated nova-api
     binary and should be installed and configured prior to upgrade
     to OpenStack Ocata (LP: #1700677).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers