[SRU] dashboard not workable after upgrade from newton to ocata

Bug #1677207 reported by Fairbanks. on 2017-03-29
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
OpenStack openstack-dashboard charm
High
Unassigned
Ubuntu Cloud Archive
Undecided
Unassigned
Ocata
High
Unassigned
horizon (Ubuntu)
Undecided
Unassigned
Zesty
High
Unassigned

Bug Description

[Description]
Hello,

After an upgrade from newton to ocata using the juju run-action openstack-upgrade the horizon dashboard isn't workable any more.

Several parts of the interface arn't working.
- Switching theme's for instance.
- The instances tabs do not work, except for the "Overview", so log and console arn't working.
- The select all checkbox isn't visible

And maybe some more stuff which i missed.
I think some kind of javascript or css issue because i have used a clean/fresh browser with no cache at all and it still has the same problems.

If i add a new unit which will install a clean ocata version, it works.
Probably there should be something done after the upgrade like a cleanup or re-cache or something?

[Testcase]
juju deploy openstack-dashboard charm with openstack-origin=cloud:xenial-newton
juju config openstack-dashboard openstack-origin=cloud:xenial-ocata

[Regression Potential]
There is minimal regression potential in this fix. In Ocata, we moved the static assets (css, images, etc) from /usr/share to /var/lib. The fix removes the old directory that contained static assets prior to installing the Ocata version of the snap

James Page (james-page) wrote :

Hmm potentially - lemme see if I can reproduce.

James Page (james-page) wrote :

mitaka-newton: OK

James Page (james-page) wrote :

newton->ocata: Looks OK

however I then see most of the symptom described in the original bug report; Marking Confirmed and High priority.

Changed in charm-openstack-dashboard:
status: New → Confirmed
importance: Undecided → High
milestone: none → 18.02
James Page (james-page) wrote :

I don't think this is per-say a charm problem - the package itself deals with cleaning and freshing generated assess; I tried a dpkg-reconfigure openstack-dashboard which should clean and repeat the process, but to no avail - raising bug for Horizon.

Changed in horizon (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Changed in charm-openstack-dashboard:
status: Confirmed → Invalid
Felipe Reyes (freyes) wrote :

I saw this same problem deploying with cloud-archive:xenial-pike/proposed and after everything was working I *downgraded* to the package in pike-updates, so there was no openstack version jump.

tags: added: sts
Corey Bryant (corey.bryant) wrote :

ocata->pike looks fine when upgrading via the charms. I wanted to verify that first.

I have a feeling this is related to the move of static assets into /var/lib/ instead of /usr/share/, which we updated the package to do in 3:11.0.0 (zesty/ocata), so this may be limited to the newton->ocata upgrade path. Testing that now.

Corey Bryant (corey.bryant) wrote :

It looks like we need maintainer script updates (in postrm for newton and in preinst for ocata) to remove the old static assets location: /usr/share/openstack-dashboard/static/, since we moved static assets (as of ocata) from /usr/share to /var/lib/.

no longer affects: horizon (Ubuntu Xenial)
Changed in horizon (Ubuntu):
status: Confirmed → Invalid
Changed in cloud-archive:
status: New → Invalid
Changed in horizon (Ubuntu Zesty):
status: New → Triaged
importance: Undecided → High
Changed in horizon (Ubuntu):
importance: High → Undecided
summary: - dashboard not workable after upgrade from newton to ocata
+ [SRU] dashboard not workable after upgrade from newton to ocata
description: updated
Corey Bryant (corey.bryant) wrote :

Maintainer script update is only needed for ocata preinst. Newton postrm was never changed.

Hello Fairbanks., or anyone else affected,

Accepted horizon into zesty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/horizon/3:11.0.3-0ubuntu3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-zesty to verification-done-zesty. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-zesty. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in horizon (Ubuntu Zesty):
status: Triaged → Fix Committed
tags: added: verification-needed verification-needed-zesty
description: updated
Ryan Beisner (1chb1n) wrote :

Hello Fairbanks., or anyone else affected,

Accepted horizon into ocata-proposed. The package will build now and be available in the Ubuntu Cloud Archive in a few hours, and then in the -proposed repository.

Please help us by testing this new package. To enable the -proposed repository:

  sudo add-apt-repository cloud-archive:ocata-proposed
  sudo apt-get update

Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-ocata-needed to verification-ocata-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-ocata-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-ocata-needed
no longer affects: cloud-archive/newton

The verification of the Stable Release Update for horizon has completed successfully and the package has now been released to -updates. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Ryan Beisner (1chb1n) wrote :

This bug was fixed in the package horizon - 3:11.0.3-0ubuntu3~cloud0
---------------

 horizon (3:11.0.3-0ubuntu3~cloud0) xenial-ocata; urgency=medium
 .
   * New update for the Ubuntu Cloud Archive.
 .
 horizon (3:11.0.3-0ubuntu3) zesty; urgency=medium
 .
   * d/openstack-dashboard.preinst: Clean up /usr/share location of static
     assets (from pre-Ocata package versions) prior to installing Ocata with
     new /var/lib location of static assets (LP: #1677207).

Corey Bryant (corey.bryant) wrote :

I've just verified that theme switching and select all are working after an upgrade (juju deployed) from newton->ocata.

Corey Bryant (corey.bryant) wrote :

That was on xenial-ocata-proposed.

tags: added: verification-ocata-done
removed: verification-ocata-needed
Corey Bryant (corey.bryant) wrote :

This also looks good on zesty-ocata-proposed as well.

tags: added: verification-done-zesty
removed: verification-needed-zesty
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package horizon - 3:11.0.3-0ubuntu3

---------------
horizon (3:11.0.3-0ubuntu3) zesty; urgency=medium

  * d/openstack-dashboard.preinst: Clean up /usr/share location of static
    assets (from pre-Ocata package versions) prior to installing Ocata with
    new /var/lib location of static assets (LP: #1677207).

 -- Corey Bryant <email address hidden> Fri, 29 Sep 2017 12:23:50 -0400

Changed in horizon (Ubuntu Zesty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers