Magnum doesn't include templates on Xenial

Bug #1660223 reported by Connor Catlett on 2017-01-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Cloud Archive
High
Unassigned

Bug Description

On Ubuntu Xenial (16.04) the magnum packages don't install anything in the driver directories (/usr/lib/python2.7/dist-packages/magnum/drivers/*/templates/). The correct files are at https://github.com/openstack/magnum/tree/stable/newton/magnum/drivers.

This effectively makes magnum unusable, as no bays can be launched. As a temporary workaround it is possible to insert the files manually, but this obviously isn't ideal.

Changed in cloud-archive:
status: New → Triaged
importance: Undecided → Medium
importance: Medium → High
Corey Bryant (corey.bryant) wrote :

Thank you for taking the time to report this bug. It looks like the upstream magnum source doesn't have a MANIFEST file so we don't get these files picked up in the package. I think we'll need to install these files manually in d/rules.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers