ceilometer-upgrade failure with local sqlite db

Bug #1631868 reported by James Page on 2016-10-10
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu Cloud Archive
Critical
James Page
ceilometer (Ubuntu)
Critical
James Page

Bug Description

The ceilometer package by default uses a local sqlite db (just to get packages installed - not for production use!), the ceilometer-upgrade command will try to upgrade this on install:

2016-10-10 07:59:32.744 27013 DEBUG ceilometer.cmd.storage [-] Upgrading Gnocchi resource types upgrade /usr/lib/python2.7/dist-packages/ceilometer/cmd/storage.py:59
2016-10-10 07:59:32.745 27013 CRITICAL ceilometer [-] ImportError: No module named gnocchiclient
2016-10-10 07:59:32.745 27013 ERROR ceilometer Traceback (most recent call last):
2016-10-10 07:59:32.745 27013 ERROR ceilometer File "/usr/bin/ceilometer-upgrade", line 10, in <module>
2016-10-10 07:59:32.745 27013 ERROR ceilometer sys.exit(upgrade())
2016-10-10 07:59:32.745 27013 ERROR ceilometer File "/usr/lib/python2.7/dist-packages/ceilometer/cmd/storage.py", line 60, in upgrade
2016-10-10 07:59:32.745 27013 ERROR ceilometer from ceilometer import gnocchi_client
2016-10-10 07:59:32.745 27013 ERROR ceilometer File "/usr/lib/python2.7/dist-packages/ceilometer/gnocchi_client.py", line 14, in <module>
2016-10-10 07:59:32.745 27013 ERROR ceilometer from gnocchiclient import client
2016-10-10 07:59:32.745 27013 ERROR ceilometer ImportError: No module named gnocchiclient
2016-10-10 07:59:32.745 27013 ERROR ceilometer
dpkg: error processing package ceilometer-common (--configure):
 subprocess installed post-installation script returned error exit status 1

by default, the script will try to upgrade the gnocchi resource types, which in a default install don't actually need to be.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: ceilometer-common 1:7.0.0-0ubuntu1~cloud0 [origin: Canonical]
ProcVersionSignature: Ubuntu 4.4.0-38.57-generic 4.4.19
Uname: Linux 4.4.0-38-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.1
Architecture: amd64
CrashDB:
 {
                "impl": "launchpad",
                "project": "cloud-archive",
                "bug_pattern_url": "http://people.canonical.com/~ubuntu-archive/bugpatterns/bugpatterns.xml",
             }
Date: Mon Oct 10 08:13:56 2016
Ec2AMI: ami-0000044a
Ec2AMIManifest: FIXME
Ec2AvailabilityZone: nova
Ec2InstanceType: m1.small.osci
Ec2Kernel: unavailable
Ec2Ramdisk: unavailable
JournalErrors:
 -- Logs begin at Mon 2016-10-10 04:30:04 UTC, end at Mon 2016-10-10 08:06:53 UTC. --
 Oct 10 07:56:21 hostname systemd[1]: ceilometer-collector.service: State 'stop-sigterm' timed out. Killing.
 Oct 10 07:56:21 hostname systemd[1]: ceilometer-collector.service: Failed with result 'signal'.
PackageArchitecture: all
SourcePackage: ceilometer
UpgradeStatus: No upgrade log present (probably fresh install)
mtime.conffile..etc.ceilometer.ceilometer.conf: 2016-10-07T15:42:01.301282

James Page (james-page) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ceilometer (Ubuntu):
status: New → Confirmed
James Page (james-page) on 2016-10-10
Changed in ceilometer (Ubuntu):
importance: Undecided → Critical
Changed in cloud-archive:
importance: Undecided → Critical
Changed in ceilometer (Ubuntu):
status: Confirmed → Triaged
Changed in cloud-archive:
status: New → Triaged
assignee: nobody → James Page (james-page)
Changed in ceilometer (Ubuntu):
assignee: nobody → James Page (james-page)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ceilometer - 1:7.0.0-0ubuntu2

---------------
ceilometer (1:7.0.0-0ubuntu2) yakkety; urgency=medium

  * d/ceilometer-common.postinst: Call ceilometer-upgrade with
    --skip-gnocchi-resource-types as this is only called in the event
    that a local sqlite db is in use, which it won't be if gnocchi is
    being used, resolving issues with installation and upgrade
    (LP: #1631868)

 -- James Page <email address hidden> Mon, 10 Oct 2016 09:32:15 +0100

Changed in ceilometer (Ubuntu):
status: Triaged → Fix Released
James Page (james-page) on 2016-10-10
Changed in cloud-archive:
status: Triaged → Fix Committed
James Page (james-page) wrote :

This bug was fixed in the package ceilometer - 1:7.0.0-0ubuntu2~cloud0
---------------

 ceilometer (1:7.0.0-0ubuntu2~cloud0) xenial-newton; urgency=medium
 .
   * New update for the Ubuntu Cloud Archive.
 .
 ceilometer (1:7.0.0-0ubuntu2) yakkety; urgency=medium
 .
   * d/ceilometer-common.postinst: Call ceilometer-upgrade with
     --skip-gnocchi-resource-types as this is only called in the event
     that a local sqlite db is in use, which it won't be if gnocchi is
     being used, resolving issues with installation and upgrade
     (LP: #1631868)

Changed in cloud-archive:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers