libv8-dev backport breaks some dependencies

Bug #1295723 reported by Bryan Quigley
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Cloud Archive
Undecided
Unassigned
mongodb (Ubuntu)
Medium
James Page

Bug Description

There is no way to to install libv8-dev for version 3.7, as it's provided by the cloud archive and pointing to the 3.14 version. An alternative fix would be for 12.04 to provide a libv8-3.7-dev package. I think it makes sense to drop the libv8-dev from the cloud archive so it matches what is done with -dbg.

This is essential for having puppet-razor and mongodb on the same box.

$ apt-cache search libv8
libv8-3.7.12.22 - v8 JavaScript engine - runtime library
libv8-dbg - v8 JavaScript engine - debugging symbols (3.7)
libv8-3.14-dbg - V8 JavaScript engine - debugging symbols
libv8-3.14-dev - V8 JavaScript engine - development files for 3.14 branch
libv8-3.14.5 - V8 JavaScript engine - runtime library
libv8-dev - V8 JavaScript engine - development files for latest branch (3.14)

Steps to reproduce with a fresh 12.04 image:
sudo add-apt-repository cloud-archive:icehouse
sudo apt-get update
sudo apt-get install nodejs-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 nodejs-dev : Depends: libv8-dev (< 3.8)
E: Unable to correct problems, you have held broken packages.

Revision history for this message
James Page (james-page) wrote :

If we drop the libv8-dev package from the cloud-archive, we can't rebuild mongodb any longer as it requires the version we are shipping.

Revision history for this message
James Page (james-page) wrote :

I'd suggest pinning the Cloud Archive pocket at a lower priority than the main archive so things get picked correctly for nodejs.

Changed in cloud-archive:
status: New → Won't Fix
Revision history for this message
Bryan Quigley (bryanquigley) wrote :

Just depend on "libv8-3.14-dev" package instead?

And apt-pinning does work to force the version from precise to be installed.

Revision history for this message
Bryan Quigley (bryanquigley) wrote :

They just (in debian, it's already in trusy/cloud archive) added support to do this:

libv8-3.14 (3.14.5.8-4) unstable; urgency=low

  [ Jérémy Lal ]
  * Patch: 0013_gcc_48_compat, closes: bug#701312.
  * Allow Build-Dependency on latest libv8 branch version or on a
    specific branch: libv8-<API>-dev or libv8-dev.
    Ensure switching from one dev package to another works properly.
    Add a specific case for libv8-3.14 (<=3.14.5.8-3).

mongodb in trusty can be made to depend on that specific -<API>-

Can we reopen this? This fix should work fine in trusty too.

James Page (james-page)
Changed in mongodb (Ubuntu):
assignee: nobody → James Page (james-page)
status: New → In Progress
importance: Undecided → Medium
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mongodb - 1:2.6.3-0ubuntu5

---------------
mongodb (1:2.6.3-0ubuntu5) utopic; urgency=medium

  * d/p/fix-signed-checks.patch: Fixup comparisons between signed and
    unsigned int, cause of FTBFS on previous upload.
 -- James Page <email address hidden> Fri, 15 Aug 2014 15:11:22 +0100

Changed in mongodb (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers