clicking to expand Command List crashes application

Bug #681943 reported by tjk on 2010-11-26
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
CLI Companion
High
Duane Hinnen
1.0
High
Duane Hinnen

Bug Description

While I had clicompanion open I had to click on expand list then click on
separation, then colapse and then expand then click on the separator... then
it crashes.

Using the test version that I installed today.

Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.6/clicompanionlib/view.py", line 139, in
expanded_cb
    treeview.get_selection().connect('changed',lambda s:
self.mark_selected(s))
AttributeError: 'NoneType' object has no attribute 'connect'
/usr/lib/pymodules/python2.6/clicompanionlib/view.py:286: GtkWarning:
gtk_tree_selection_get_mode: assertion `GTK_IS_TREE_SELECTION (selection)'
failed
  gtk.main()
/usr/lib/pymodules/python2.6/clicompanionlib/view.py:286: GtkWarning:
gtk_tree_selection_get_selected_rows: assertion `GTK_IS_TREE_SELECTION
(selection)' failed
  gtk.main()
Segmentation fault

To Reproduce:

1. Open CLI Companion (Applications --> Accessories --> CLI Companion) or launch from the Terminal (with command 'clicompanion') if you want to see the error printed.
2. Click on Command List (gtk.Expander) triangle to reveal commands
3. Click on the Command List triangle again to close it
4. Again, click on Command List triangle to reveal commands
5. Click on a command in the list.
5. Application crashes.

Duane Hinnen (duanedesign) wrote :

tjk,
thank you for filing this bug. I would greatly appreciate if you could try the following.

1. Open a Terminal and run the command:

clicompanion

2. reproduce your bug.

3. Post here anything printed to the Terminal.

thank you!
duanedesign

Duane Hinnen (duanedesign) wrote :

tjk,
I was not able to reproduce your bug. Well maybe. Could you please check bug 681976
While trying to reproduce your bug I came across this issue. Might be the same bug?

thank you,
duanedesign

Changed in clicompanion:
importance: Undecided → High
assignee: nobody → duanedesign (duanedesign)

Crazy! As per your request I tried it in the terminal, and it didn't
crash. Then I tried it from the menu... no crash. Then I tried it through
Launchy (which I normally use)... didn't crash. I replicated the problem
about 10 times before I reported the bug, but now I can't get it to crash.
I don't know why it did it before and not now...

On Fri, Nov 26, 2010 at 3:24 PM, duanedesign <email address hidden> wrote:

> tjk,
> thank you for filing this bug. I would greatly appreciate if you could try
> the following.
>
> 1. Open a Terminal and run the command:
>
> clicompanion
>
> 2. reproduce your bug.
>
> 3. Post here anything printed to the Terminal.
>
> thank you!
> duanedesign
>
> --
> clicking on column adjuster crashes clicompanion
> https://bugs.launchpad.net/bugs/681943
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in CLI Companion: New
>
> Bug description:
> 1) open clicomp
> 2) click on "command list" to expand list
> 3) find the point in the list header where the cursor changes to <->
> then do a normal click (usually you click hold and drag -- but don't
> do this)
> 4) clicomp crashes
>
> Using the test version that I installed today.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/clicompanion/+bug/681943/+subscribe
>

tjk (tim-klassen) wrote :

I got it to crash again!!
Here's the terminal output:
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.6/clicompanionlib/view.py", line 139, in
expanded_cb
    treeview.get_selection().connect('changed',lambda s:
self.mark_selected(s))
AttributeError: 'NoneType' object has no attribute 'connect'
/usr/lib/pymodules/python2.6/clicompanionlib/view.py:286: GtkWarning:
gtk_tree_selection_get_mode: assertion `GTK_IS_TREE_SELECTION (selection)'
failed
  gtk.main()
/usr/lib/pymodules/python2.6/clicompanionlib/view.py:286: GtkWarning:
gtk_tree_selection_get_selected_rows: assertion `GTK_IS_TREE_SELECTION
(selection)' failed
  gtk.main()
Segmentation fault

While I had clicompanion open I had to click on expand list then click on
separation, then colapse and then expand then click on the separator... then
it crashes.

On Fri, Nov 26, 2010 at 4:06 PM, Tim Klassen <email address hidden> wrote:

> Crazy! As per your request I tried it in the terminal, and it didn't
> crash. Then I tried it from the menu... no crash. Then I tried it through
> Launchy (which I normally use)... didn't crash. I replicated the problem
> about 10 times before I reported the bug, but now I can't get it to crash.
> I don't know why it did it before and not now...
>
>
> On Fri, Nov 26, 2010 at 3:24 PM, duanedesign <email address hidden>wrote:
>
>> tjk,
>> thank you for filing this bug. I would greatly appreciate if you could try
>> the following.
>>
>> 1. Open a Terminal and run the command:
>>
>> clicompanion
>>
>> 2. reproduce your bug.
>>
>> 3. Post here anything printed to the Terminal.
>>
>> thank you!
>> duanedesign
>>
>> --
>> clicking on column adjuster crashes clicompanion
>> https://bugs.launchpad.net/bugs/681943
>> You received this bug notification because you are a direct subscriber
>> of the bug.
>>
>> Status in CLI Companion: New
>>
>> Bug description:
>> 1) open clicomp
>> 2) click on "command list" to expand list
>> 3) find the point in the list header where the cursor changes to <->
>> then do a normal click (usually you click hold and drag -- but don't
>> do this)
>> 4) clicomp crashes
>>
>> Using the test version that I installed today.
>>
>> To unsubscribe from this bug, go to:
>> https://bugs.launchpad.net/clicompanion/+bug/681943/+subscribe
>>
>
>

thank you!
That is *very* helpful.

summary: - clicking on column adjuster crashes clicompanion
+ clicking to expand Command List crashes application
description: updated
Changed in clicompanion:
status: New → Confirmed
Duane Hinnen (duanedesign) wrote :

resolved previous GTKWarning now getting:

: GtkWarning: IA__gtk_tree_selection_get_selected_rows: assertion `GTK_IS_TREE_SELECTION (selection)' failed
  (model, pathlist)=treeselection.get_selected_rows()

Changed in clicompanion:
status: Confirmed → Fix Committed
David Caro (dcaro) wrote :

I was unable to reproduce it in trunk, supposing fix released.

Thanks,
David

Changed in clicompanion:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers