Apps missing in some store categories

Bug #1337864 reported by Nekhelesh Ramananthan
44
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Click Package Index
Fix Released
Critical
James Tait
unity-scope-click (Ubuntu)
Fix Released
High
Alejandro J. Cura

Bug Description

Since the recent introduction of departments in the Ubuntu Store, there are several applications missing. For instance the email client "Dekko" cannot be seen in the Internet->mail category. Flashback is another app that seems to be missing from the Sound & Video section.

There are several departments shown which are empty and I suspect they are missing apps as well.

By manual searching for these by app names, they are returned in the search results indicating they are present in the stores.

Related branches

description: updated
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-scope-click (Ubuntu):
status: New → Confirmed
Revision history for this message
dobey (dobey) wrote :

It's not that the apps are missing (they do show in search results as you said), but that they are not highlighted, and some departments do not currently have highlights; though, even with highlights, all apps in a department won't necessarily appear in a highlight.

Changed in unity-scope-click (Ubuntu):
importance: Undecided → High
Revision history for this message
Mike Nagle (mikenagle) wrote :

Just to clarify, the department landing page should show all apps in that department (including any child departments)

https://sites.google.com/a/canonical.com/unity8dash/scopes/store/department-landing-page

Revision history for this message
James Tait (jamestait) wrote :

This is already possible via the search API:

{
  "_links": {
    "first": {
      "href": "https://search.apps.ubuntu.com/api/v1/search?q=department%3A%22games%22&page=1&size=2"
    },
    "last": {
      "href": "https://search.apps.ubuntu.com/api/v1/search?q=department%3A%22games%22&page=35&size=2"
    },
    "next": {
      "href": "https://search.apps.ubuntu.com/api/v1/search?q=department%3A%22games%22&page=2&size=2"
    },
    "self": {
      "href": "https://search.apps.ubuntu.com/api/v1/search?q=department%3A%22games%22&page=1&size=2"
    },
    "curies": [
      {
        "templated": true,
        "name": "clickindex",
        "href": "https://search.apps.ubuntu.com/docs/relations.html{#rel}"
      }
    ]
  },
  "_embedded": {
    "clickindex:recommendation": [],
    "clickindex:package": [
      {
        "price": 0,
        "icon_url": "https://myapps.developer.ubuntu.com/site_media/appmedia/2013/09/solitaire-games64.png",
        "title": "Solitaire Games",
        "name": "com.ubuntu.developer.labsin.solitaire-games",
        "_links": {
          "self": {
            "href": "https://search.apps.ubuntu.com/api/v1/package/com.ubuntu.developer.labsin.solitaire-games"
          }
        },
        "publisher": "Sam Segers",
        "content": "application"
      },
      {
        "price": 0,
        "icon_url": "https://myapps.developer.ubuntu.com/site_media/appmedia/2014/06/rockpaperscissorslogo_256.png",
        "title": "Rock Paper Scissors",
        "name": "com.ubuntu.developer.11ubuntucg.rockpaperscissors",
        "_links": {
          "self": {
            "href": "https://search.apps.ubuntu.com/api/v1/package/com.ubuntu.developer.11ubuntucg.rockpaperscissors"
          }
        },
        "publisher": "Brian Jaury",
        "content": "application"
      }
    ]
  }
}

However, I accept that this might not be optimal for a couple of reasons:

 - It requires a separate call to the index
 - It requires pagination support on the client

The second point can be mitigated by adjusting the size parameter accordingly to get things off the ground, but that's a temporary work-around - ultimately, the scope is going to have to support pagination, otherwise we'll be returning potentially thousands of results in a single response. It's not just the network usage that's a problem here, but the memory and processing overhead on the client.

The first point can be addressed on the server side by embedding clickindex:package resources in the department response. This is, in fact, the long-term plan. There was an unfortunate mix-up in terminology that led to "browsing search results by department" being misinterpreted as "browsing for arbitrary packages by department" - the former of which is not currently supported, the latter being expressly permitted - and so this embedding was de-scoped for RTM. I'm happy to do the work to support it now, with the caveat that pagination support will be added later.

James Tait (jamestait)
no longer affects: click-package-index
affects: unity-scope-click (Ubuntu) → click-package-index
Changed in click-package-index:
assignee: nobody → James Tait (jamestait)
importance: High → Critical
James Tait (jamestait)
Changed in click-package-index:
status: Confirmed → In Progress
James Tait (jamestait)
Changed in click-package-index:
status: In Progress → Fix Committed
James Tait (jamestait)
Changed in click-package-index:
status: Fix Committed → Fix Released
tags: added: rtm14
Leo Arias (elopio)
tags: added: qa-daily-testing
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-scope-click (Ubuntu):
status: New → Confirmed
Changed in unity-scope-click (Ubuntu):
importance: Undecided → High
Changed in unity-scope-click (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Alejandro J. Cura (alecu)
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-scope-click - 0.1+14.10.20140805-0ubuntu1

---------------
unity-scope-click (0.1+14.10.20140805-0ubuntu1) utopic; urgency=medium

  [ Alejandro J. Cura (alecu) ]
  * New upstream release.
    - Show all remaining apps in the department. (LP: #1337864)
    - Apps category must be expanded and can't be collapsed. (LP: #1350611)
    - Search results category must be expanded. (LP: #1350612)
    - Change top 6 apps: phone, messages, contacts, camera, browser, clock.
      (LP: #1350614)
    - Remove "Apps" category title in searches. (LP: #1350619)
    - Use art not mascot for app icons in store searches. (LP: #1350624)
    - Updated translations.

  [ Ubuntu daily release ]
  * New rebuild forced
 -- Ubuntu daily release <email address hidden> Tue, 05 Aug 2014 13:11:42 +0000

Changed in unity-scope-click (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers