classicmenu-indicator looks for a bunch of stuff I don't have installed

Bug #882415 reported by Grizzly(Francis Smit) on 2011-10-27
26
This bug affects 6 people
Affects Status Importance Assigned to Milestone
ClassicMenu Indicator
High
Florian Diesch

Bug Description

when I run it from the command line I get:
grizzlysmit@pern:~$ classicmenu-indicator &
[1] 17580
grizzlysmit@pern:~$ ClassicMenu Indicator: Failed to open file '/usr/share/xdiagnose/media/icon.png': No such file or directory
ClassicMenu Indicator: Failed to open file '/opt/secondlife-install/etc/../secondlife_icon.png': No such file or directory
ClassicMenu Indicator: Failed to open file '/usr/share/icons/tkabber.xpm': No such file or directory
ClassicMenu Indicator: Failed to open file '/usr/share/pixmaps/bluefish-icon.png': No such file or directory
ClassicMenu Indicator: Failed to open file '/usr/lib/GNUstep/Applications/Gorm.app/Resources/Gorm.tiff': No such file or directory
Traceback (most recent call last):
  File "/usr/bin/classicmenu-indicator", line 9, in <module>
    load_entry_point('classicmenu-indicator==0.06', 'console_scripts', 'classicmenu-indicator')()
  File "/usr/lib/python2.7/dist-packages/classicmenu_indicator/cmindicator.py", line 274, in main
    indicator = ClassicMenuIndicator()
  File "/usr/lib/python2.7/dist-packages/classicmenu_indicator/cmindicator.py", line 62, in __init__
    self.indicator.set_menu(self.create_menu())
  File "/usr/lib/python2.7/dist-packages/classicmenu_indicator/cmindicator.py", line 160, in create_menu
    self.add_to_menu(menu, t)
  File "/usr/lib/python2.7/dist-packages/classicmenu_indicator/cmindicator.py", line 154, in add_to_menu
    self.process_directory(menu, root)
  File "/usr/lib/python2.7/dist-packages/classicmenu_indicator/cmindicator.py", line 137, in process_directory
    self.process_directory(new_menu, item)
  File "/usr/lib/python2.7/dist-packages/classicmenu_indicator/cmindicator.py", line 130, in process_directory
    self.process_entry(menu, item)
  File "/usr/lib/python2.7/dist-packages/classicmenu_indicator/cmindicator.py", line 122, in process_entry
    menu.append(self.create_menu_item(entry))
  File "/usr/lib/python2.7/dist-packages/classicmenu_indicator/cmindicator.py", line 87, in create_menu_item
    gtk.ICON_LOOKUP_USE_BUILTIN)
glib.GError: Unrecognized image file format
grizzlysmit@pern:~$ classicmenu-indicator &^C
[1]+ Exit 1 classicmenu-indicator

Douglas Albert (douglas-albert) wrote :

I first got lots of

Gtk-WARNING **: Unable to locate theme engine in module_path: “pixmap”

but fixed this with

sudo apt-get install gtk2-engines-pixbuf

But I still get

ClassicMenu Indicator: Failed to open file ‘/usr/share/xdiagnose/media/icon.png’: No such file or directory

I am on Ubuntu 11.10.

adrenochrome (adrenochrome) wrote :

"ClassicMenu Indicator: Failed to open file ‘/usr/share/xdiagnose/media/icon.png’: No such file or directory"
i copied the media directory from older version (http://archive.ubuntu.com/ubuntu/pool/universe/x/xdiagnose/xdiagnose_0.2-0ubuntu2_all.deb)

are we meant to add that deb file, I get error newer version already installed???

Florian Diesch (diesch) wrote :

Those "No such file or directory" messages are caused by .desktop files referencing icons that don't exists. Please file bugs for the packages this programs belong to.

The crash on unsupported file formats will be fixed in v0.07.

Changed in classicmenu-indicator:
status: New → In Progress
importance: Undecided → Medium
importance: Medium → High
assignee: nobody → Florian Diesch (diesch)

After creating the media subdirectory and providing in it an icon graphic renamed as "icon.png" in Ubuntu 11.10 Gnome Classic, I no longer see the message:

"ClassicMenu Indicator: Failed to open file ‘/usr/share/xdiagnose/media/icon.png’: No such file or directory"

The Accessories submenu now contains the xdiagnose program and it displays the renamed icon in the media subdirectory.

However, upon running:

classicmenu-indicator

the command appears to hang, with no movement in bash.

The intended creation of the System Preferences and Administration submenus does not take place. That is, the motley sample of the system utilities formerly found in Gnome 2.3X continues to reside in the Other submenu.

Florian Diesch (diesch) on 2011-12-27
Changed in classicmenu-indicator:
status: In Progress → Fix Committed
Florian Diesch (diesch) on 2013-09-06
Changed in classicmenu-indicator:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers