No app starts when choosen in the menu

Bug #1559253 reported by Vincent RUIZ on 2016-03-18
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ClassicMenu Indicator
Critical
Florian Diesch

Bug Description

When an app is choosen in the menu, nothing appends.
I tried to launch classicmenu-indicator in the terminal. It started. When I choose an application, this is the result error :

login$ classicmenu-indicator
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/classicmenu_indicator/cmindicator.py", line 353, in on_menuitem_activate
    appinfo.launch()
  File "/usr/lib/python3/dist-packages/gi/types.py", line 43, in function
    return info.invoke(*args, **kwargs)
TypeError: launch() takes exactly 3 arguments (1 given)

My config : Ubuntu 12.04 64bit - classicmenu-indicator 0.10

Note : it worked perfectly with the 0.9 version

Vincent RUIZ (vince2b-linux) wrote :

For those who would like to revert to previous version, I found a 0.09-1 package in Florian Diesch personnal package archive "testing".
The URL is :
http://ppa.launchpad.net/diesch/testing/ubuntu/pool/main/c/classicmenu-indicator/

That version is working with my 12.04.

Hope that it will not bother Florian.

Christophe (touil1976) wrote :

The same bug occurs when classicmenu-indicator 0.10 is automatically launched at startup or when it is launched via the unity application lens. Also under 12.04 64 bits. Version 0.9 used to work perfectly.

Florian Diesch (diesch) on 2016-03-21
Changed in classicmenu-indicator:
importance: Undecided → Critical
status: New → In Progress
assignee: nobody → Florian Diesch (diesch)
Michael Kummer (michael-kummer) wrote :

The same issue on 12.04.03 64 bit with version 0.10, thanks to Florian work is in progress.

Michael Kummer (michael-kummer) wrote :

With ubuntu 14.04 everything seems to be okay.

Yleeyas (yleeyas) wrote :

Have the same problem as OP on 12.04 32bit.
Also, my records show that Python was updated on the same date. Not saying that's meaningful, just coincidence(?).

Florian Diesch (diesch) on 2016-03-21
Changed in classicmenu-indicator:
status: In Progress → Fix Committed
Florian Diesch (diesch) wrote :

In 12.04 the PyGObject API is in some cases different from newer versions, and my virtual machine for testing 12.04 was actually running 14.04 for some reasons... Ooops

I just released v0.10-1 with a fix for this.

Changed in classicmenu-indicator:
status: Fix Committed → Fix Released
Michael Kummer (michael-kummer) wrote :

Thank you very much, now it works again on ubuntu 12.04.03 64 bit.

Vincent RUIZ (vince2b-linux) wrote :

Problem solved. It works now as it always have to.
Great work ! Thank you very much Florian !

Yleeyas (yleeyas) wrote :

Thanx for the quick fix Florian.
Works on 12.04 32bit.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers