Cirros website is no longer available

Bug #1713358 reported by David Hill on 2017-08-27
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
CirrOS
Undecided
Unassigned
Packstack
Undecided
yatin
puppet-openstack-integration
Undecided
yatin
tripleo
Critical
Sagi (Sergey) Shnaidman

Bug Description

Cirros website is no longer available :

(overcloud) [stack@undercloud-0-trunk cloud]$ wget http://download.cirros-cloud.net/0.3.4/cirros-0.3.4-x86_64-disk.img
--2017-08-27 15:43:48-- http://download.cirros-cloud.net/0.3.4/cirros-0.3.4-x86_64-disk.img
Resolving download.cirros-cloud.net (download.cirros-cloud.net)... failed: Name or service not known.
wget: unable to resolve host address âdownload.cirros-cloud.netâ

Tags: ci Edit Tag help
Lingxian Kong (kong) wrote :

AFAIK, the dns server of cirros-cloud has been suffering from DDoS sine last Friday

Andreas Jaeger (jaegerandi) wrote :

The attack is over according to https://www.dreamhoststatus.com/ - so, might a fallout. I suggest to tell the provider about it.

If somebody needs this file urgently, you can download it from github: https://github.com/sshnaidm/cirros-mirror/raw/master/cirros-0.3.5-x86_64-disk.img

Chris (z-chris-1) wrote :

The domain name has expired. It needs to be renewed otherwise the domain will be lost:
It's currently on clientHold so the DNS is disabled as they weren't able to renew it seems.

   Registry Expiry Date: 2017-08-27T17:56:17Z

whois cirros-cloud.net
   Domain Name: CIRROS-CLOUD.NET
   Registry Domain ID: 1740998474_DOMAIN_NET-VRSN
   Registrar WHOIS Server: whois.dreamhost.com
   Registrar URL: http://www.DreamHost.com
   Updated Date: 2017-08-27T08:05:21Z
   Creation Date: 2012-08-27T17:56:17Z
   Registry Expiry Date: 2017-08-27T17:56:17Z
   Registrar: DreamHost, LLC
   Registrar IANA ID: 431
   Registrar Abuse Contact Email:
   Registrar Abuse Contact Phone:
   Domain Status: clientHold https://icann.org/epp#clientHold
   Name Server: NS1.DREAMHOST.COM
   Name Server: NS2.DREAMHOST.COM
   Name Server: NS3.DREAMHOST.COM
   DNSSEC: unsigned
   URL of the ICANN Whois Inaccuracy Complaint Form: https://www.icann.org/wicf/

Changed in tripleo:
assignee: nobody → Sagi (Sergey) Shnaidman (sshnaidm)
importance: Undecided → Critical
status: New → Triaged
tags: added: alert

Fix proposed to branch: master
Review: https://review.openstack.org/498337

Changed in puppet-openstack-integration:
assignee: nobody → yatin (yatinkarel)
status: New → In Progress
yatin (yatinkarel) wrote :
Changed in packstack:
assignee: nobody → yatin (yatinkarel)
status: New → In Progress
Dr. Jens Harbott (j-harbott) wrote :

In case someone needs other files, they are temporarily available at http://cirros-cloud.de. Please do not direct your CI at that server, fetch the files that you need and setup your own mirror. Even better, donate a public mirror, contact me via email or in #cirros for details.

Changed in cirros:
status: New → Confirmed

Reviewed: https://review.openstack.org/498344
Committed: https://git.openstack.org/cgit/openstack/packstack/commit/?id=187af0d761f3fce28f1e0cd73c3dc4806992a4fd
Submitter: Jenkins
Branch: master

commit 187af0d761f3fce28f1e0cd73c3dc4806992a4fd
Author: yatin <email address hidden>
Date: Mon Aug 28 12:52:10 2017 +0530

    Use alternative cirros url until download.cirros-cloud.net is fixed

    Change-Id: I98e3b04e18137809b6ff7806fa43de3ca672e743
    Closes-Bug: #1713358

Changed in packstack:
status: In Progress → Fix Released
Changed in tripleo:
status: Triaged → In Progress
Scott Moser (smoser) wrote :

cirros-cloud.net is back up.
I'm sorry for the failed renewal and resultant down time.

Thanks to Jens for reaching out to me in IRC.

Changed in cirros:
status: Confirmed → Fix Released
Changed in puppet-openstack-integration:
status: In Progress → Fix Released
tags: added: ci
removed: alert

Change abandoned by yatin (<email address hidden>) on branch: master
Review: https://review.openstack.org/498337
Reason: Jobs are back again as download.cirros-cloud.net is up again

Changed in tripleo:
status: In Progress → Fix Released

Change abandoned by Emilien Macchi (<email address hidden>) on branch: master
Review: https://review.openstack.org/498314
Reason: I need to purge the gate because TripleO CI gate has critical issues right now, I'll make this patch goes to the gate.

Change abandoned by Attila Darazs (<email address hidden>) on branch: master
Review: https://review.openstack.org/498456

Reviewed: https://review.openstack.org/498314
Committed: https://git.openstack.org/cgit/openstack/tripleo-quickstart-extras/commit/?id=ea3e29b5405290b3eeeaaf08cfe109b0a93b664d
Submitter: Jenkins
Branch: master

commit ea3e29b5405290b3eeeaaf08cfe109b0a93b664d
Author: Sagi Shnaidman <email address hidden>
Date: Mon Aug 28 08:42:36 2017 +0300

    Make image path for tempest configurable

    Testing image must be configurable in tempest config scripts.
    Set it default for temporary github mirror until
    1713358 is resolved.
    Related-Bug: #1713358

    Change-Id: Idc979d60e7ed5d36646d2a9c3fd41e5f85ee15ca

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers