Cirros doesn't have DHCPv6 support

Bug #1487041 reported by Daniel Mellado on 2015-08-20
58
This bug affects 11 people
Affects Status Importance Assigned to Milestone
CirrOS
Confirmed
Medium
Unassigned

Bug Description

Current Cirros image (0.3.4) doesn't have DHCPv6 support, so it would work properly using SLAAC or stateless modes but fail when dealing with IPv6 stateful address configuration [1].

This is affecting the implementation of OpenStack's Tempest scenario tests that would fail in the gate due to lack of support of DHCPv6. As the image has already built-in support for ping6, adding also support for IPv6 in its dhcp client would solve this.

* [1] https://tools.ietf.org/html/rfc3315

Changed in cirros:
status: New → Confirmed
Scott Moser (smoser) wrote :

is this fix-committed in trunk ?

Daniel Mellado (daniel-mellado) wrote :

Has there been any work done on this topic?

Scott Moser (smoser) wrote :

Jens points to http://lists.busybox.net/pipermail/busybox/2015-February/082379.html and indicates that busybox's ipv6 dhcp is currently not expected to work , so +CONFIG_UDHCPC6=y isn't really the way to solve this.

thus, we'll apply
 -# BR2_PACKAGE_ODHCP6C is not set
+BR2_PACKAGE_ODHCP6C=y

to all the configs.

i'll do a build with those changes to verify it actually builds and then commit and push a daily build to http://download.cirros-cloud.net/daily/

ofer blaut (oblaut) wrote :

Hi, What is the status of this fix?

thanks

Ofer

Scott Moser (smoser) on 2016-06-29
Changed in cirros:
importance: Undecided → Medium
Scott Moser (smoser) wrote :

At the moment, revno 363 in trunk enables the odhcp6c binary.
I'm not sure what else needs to be done. Input is welcome.

Luis Rueda (userlerueda) wrote :

I tried many options but not really sure how to use this. Cahnging the /etc/network/interfaces to include:

iface eth0 inet6 auto

throws an error.

Luis Rueda (userlerueda) wrote :

The error is also shown when placing "iface eth0 inet6 dhcp" in the /etc/network/interfaces

Dr. Jens Harbott (j-harbott) wrote :

Sadly odhcp6c also failed to acquire an address in my deployments, so I made another switch to dhclient from the ISC DHCP package now and that is working fine for me.

I also added an init script that will run rdisc in order to find out whether dhcpv6 should be used. The patch can be found at lp:~j-rosenboom-j/cirros/dev and it would be great if someone else could test this, too.

Luis Pigueiras (lpigueiras) wrote :

I tried to acquire an IPv6 with the latest image version of cirros and it doesn't work. odhcp6c seems to fail for me (and also I don't think there is any mechanism AFAIK to use this binary at boot time to get IPv6).

Then I tried to use the cirros image with the @j-harbott patch, and it worked with a small modification (the init script for the IPv6 was failing at boot time, but if you execute it login into the machine, it worked). I needed to add a `sleep(5)` in the init script before executing the `dhclient -6` to make it not fail. Probably I could be hitting this bug: https://bugs.launchpad.net/ubuntu/+source/ifupdown/+bug/1447715

Alona Paz (alonapaz) wrote :

Is there any progress with this bug?
I tried to invoke `usr/sbin/odhcp6c eth0` manually and it doesn't work.
Also when the vm gets RA requesting a stateful address (M and O flags are set) no dhcp solicit message is sent.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers