Remove Python 2 testing and gate jobs

Bug #1853372 reported by Brian Rosmaita on 2019-11-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Cinder
High
Brian Rosmaita
cinder-tempest-plugin
High
Brian Rosmaita
cinderlib
High
Luigi Toscano
os-brick
High
Brian Rosmaita
python-cinderclient
High
Brian Rosmaita

Bug Description

With the Ussuri release, OpenStack will no longer support Python 2.

We need to remove Python 2 testing right away, because as other project and libraries remove Python 2 support, our testing and gate jobs may break. (See, for example, the discussion on https://review.opendev.org/#/c/695007/ )

Need to remove the py2* testenvs in tox as well as py2-specific testing configured in .zuul.yaml

Changed in os-brick:
milestone: none → 2.11.0
Changed in python-cinderclient:
milestone: none → 5.1.0
Brian Rosmaita (brian-rosmaita) wrote :

This patch converts the legacy-grenade-dsvm-cinder-mn-sub-* jobs to python 3:
https://review.opendev.org/#/c/695787/

Reviewed: https://review.opendev.org/695317
Committed: https://git.openstack.org/cgit/openstack/cinder/commit/?id=c93000b2cd0faaf5c3da14c8d2f7c91762a4c1a2
Submitter: Zuul
Branch: master

commit c93000b2cd0faaf5c3da14c8d2f7c91762a4c1a2
Author: Brian Rosmaita <email address hidden>
Date: Wed Nov 20 17:46:09 2019 -0500

    Remove Python 2 support from testing and gate jobs

    tox:
    - bumped tox minversion to 3.1.0 to get 'ignore_basepython_conflict'
    - tox 'ignore_basepython_conflict' allows us to factor basepython=
      python3 to the [testenv] but override it when using '-e py37'
      (that way you actually get python 3.7 instead of whatever the system
      has for python3)
    gate:
    - adjusted tempest-dsvm-lvm-lio-barbican to use python 3 for devstack
    - removed openstack-python-jobs template as these tests are covered
      in py3 by openstack-python3-ussuri-jobs
    - dropped integrated-gate template as these tests are covered by the
      integrated-gate-storage template, which is already python3
    - dropped tempest-full jobs as these are covered in py3 by tempest-
      integrated-storage
    - changed openstack-tox-functional to openstack-tox-functional-py37
      and made it voting

    The legacy-grenade-dsvm-cinder-mn-sub-* jobs are converted to py3
    in a different patch, https://review.opendev.org/#/c/695787/

    Left py2 requirements and did not adjust setup.cfg to require py3.
    This prevents breakage for any projects still installing cinder under
    py2. These can be changed by a follow up patch in January.

    Co-authored-by: Sean McGinnis <email address hidden>
    Co-authored-by: Brian Rosmaita <email address hidden>

    Closes-bug: #1853372

    Change-Id: I376bd708ecc864f29c35b7225f875bb20a98cd3c

Changed in cinder:
status: In Progress → Fix Released
Changed in os-brick:
assignee: nobody → Brian Rosmaita (brian-rosmaita)
status: New → In Progress

Fix proposed to branch: master
Review: https://review.opendev.org/697380

Brian Rosmaita (brian-rosmaita) wrote :

python-cinderclient patch is https://review.opendev.org/#/c/691467

Changed in python-cinderclient:
status: New → In Progress
Changed in cinderlib:
milestone: none → 2.0.0
status: New → Triaged

Change abandoned by Brian Rosmaita (<email address hidden>) on branch: master
Review: https://review.opendev.org/697380
Reason: Let's use Luigi's patches instead because they include converting these to zuul v3 instead of just moving them to our repo.

Reviewed: https://review.opendev.org/697374
Committed: https://git.openstack.org/cgit/openstack/os-brick/commit/?id=ecff5ec771f1bc7984f214c0b4b5526eadcb85d3
Submitter: Zuul
Branch: master

commit ecff5ec771f1bc7984f214c0b4b5526eadcb85d3
Author: Brian Rosmaita <email address hidden>
Date: Wed Dec 4 16:24:05 2019 -0500

    Remove Python 2.7 support from testing and gates

    Makes Python 3 the base python for all tox venvs and removes
    py2 jobs from zuul.yaml.

    Remaining:
    - move the legacy gate jobs from openstack-zuul-jobs to the os-brick
      repo and make them py3 jobs
    - adjust setup.cfg to require py3 and remove py2 requirements from
      test-requirements.txt and doc/requirements.txt

    Partial-bug: #1853372

    Change-Id: Ib447656aa213914bafd50380b3821090f93776f8

Changed in cinderlib:
assignee: nobody → Luigi Toscano (ltoscano)
importance: Undecided → High
status: Triaged → In Progress

Reviewed: https://review.opendev.org/701572
Committed: https://git.openstack.org/cgit/openstack/cinderlib/commit/?id=08108b59643698c69ba26298b664ea4f31a7c174
Submitter: Zuul
Branch: master

commit 08108b59643698c69ba26298b664ea4f31a7c174
Author: Luigi Toscano <email address hidden>
Date: Fri Jan 10 15:03:23 2020 +0100

    Use Python 3 by default and drop Python 2

    Follow the rest of OpenStack and consistently switch to
    python3 as default python interpreter and drop python2.

    The "functional" tox target was failing with Python 2
    as cinder/master has cut the Python 2.7 compatibility.
    "functional" now points to the default python3. An explicit
    "functional-py37" target has been added as well.

    Fix the functional jobs as well:
    - move the LVM job to centos-8 and adapt it when needed;
    - move the Ceph job to ubuntu-bionic, as there are no
      CentOS 8 Ceph packages (and the CentOS 7 ones do not
      provide Python 3 bindings).

    Closes-Bug: #1853372
    Change-Id: Iea4f4f53df7400248848399494564910d3870f63

Changed in cinderlib:
status: In Progress → Fix Released
Changed in python-cinderclient:
assignee: nobody → Brian Rosmaita (brian-rosmaita)
Changed in os-brick:
importance: Undecided → High
Changed in python-cinderclient:
importance: Undecided → High

Reviewed: https://review.opendev.org/691467
Committed: https://git.openstack.org/cgit/openstack/python-cinderclient/commit/?id=658de38c20e028898fe0641de2e18686703f7b70
Submitter: Zuul
Branch: master

commit 658de38c20e028898fe0641de2e18686703f7b70
Author: xuanyandong <email address hidden>
Date: Sat Oct 26 14:31:46 2019 +0800

    Drop support for python 2

    Also adds support for py3.6 and py3.7 check and gate jobs.

    Co-authored-by: xuanyandong <email address hidden>
    Co-authored-by: Brian Rosmaita <email address hidden>

    Closes-bug: #1853372

    Change-Id: Ia978b692ade23ee6482957f41b17cb879c96fea7

Changed in python-cinderclient:
status: In Progress → Fix Released

This was addressed for os-brick by https://review.opendev.org/#/c/697374/

Changed in os-brick:
status: In Progress → Fix Released
Changed in cinder-tempest-plugin:
importance: Undecided → High
assignee: nobody → Brian Rosmaita (brian-rosmaita)
milestone: none → 0.4.0
Changed in cinder-tempest-plugin:
status: New → In Progress

Reviewed: https://review.opendev.org/702977
Committed: https://git.openstack.org/cgit/openstack/cinder-tempest-plugin/commit/?id=e0622ed5b8ae42829341aa12d58abfd70ab68d92
Submitter: Zuul
Branch: master

commit e0622ed5b8ae42829341aa12d58abfd70ab68d92
Author: Brian Rosmaita <email address hidden>
Date: Thu Jan 16 15:15:44 2020 -0500

    Drop python 2.7 support and testing

    Change-Id: I3ff7a714d5fd61edd72e00c7a454c81724844f99
    Closes-bug: #1853372

Changed in cinder-tempest-plugin:
status: In Progress → Fix Released

This issue was fixed in the openstack/python-cinderclient 6.0.0 release.

This issue was fixed in the openstack/cinder 16.0.0.0b1 development milestone.

Reviewed: https://review.opendev.org/697385
Committed: https://git.openstack.org/cgit/openstack/os-brick/commit/?id=8ef7c54807dd2a877705d795999b344b113aba62
Submitter: Zuul
Branch: master

commit 8ef7c54807dd2a877705d795999b344b113aba62
Author: Luigi Toscano <email address hidden>
Date: Thu Dec 12 14:40:17 2019 +0100

    Port the os-bricks jobs to Zuul v3

    All existing jobs are converted to native Zuul v3 versions.

    os-brick-cinder-tempest-dsvm-lvm-lio-barbican has been removed
    because it is a duplicate of cinder-tempest-plugin-lvm-lio-barbican
    which does not test against the current os-brick.

    os-brick-src-tempest-lvm-lio-barbican is in fact the same job,
    but it tests against the os-brick codebase being tested.

    Partial-Bug: #1853372

    Depends-On: https://review.opendev.org/672804
    Change-Id: I3e6b8f7fffff8aa2e9d4a3009374c74baa131405

Reviewed: https://review.opendev.org/739817
Committed: https://git.openstack.org/cgit/openstack/os-brick/commit/?id=5418d080a3683beaaa35570c33232a3d7e081617
Submitter: Zuul
Branch: stable/train

commit 5418d080a3683beaaa35570c33232a3d7e081617
Author: Luigi Toscano <email address hidden>
Date: Thu Dec 12 14:40:17 2019 +0100

    Port the os-bricks jobs to Zuul v3

    All existing jobs are converted to native Zuul v3 versions.

    os-brick-cinder-tempest-dsvm-lvm-lio-barbican has been removed
    because it is a duplicate of cinder-tempest-plugin-lvm-lio-barbican
    which does not test against the current os-brick.

    os-brick-src-tempest-lvm-lio-barbican is in fact the same job,
    but it tests against the os-brick codebase being tested.

    Partial-Bug: #1853372

    Depends-On: https://review.opendev.org/672804
    Change-Id: I3e6b8f7fffff8aa2e9d4a3009374c74baa131405
    (cherry picked from commit 8ef7c54807dd2a877705d795999b344b113aba62)

tags: added: in-stable-train
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers