storwize map multi-volumes by two cinder volume nodes parallelly failure

Bug #1603282 reported by xiaoqin
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Cinder
Fix Released
Undecided
xiaoqin

Bug Description

The VDisk-to-host mapping may be fail due to the SCSI LUN id is already uesed by other VDisk mapping to this host with this SCSI LUN id, which is caused by two cinder volume nodes run parallelly.

In the storwize volume driver for a volume attaching shouldn't try to calculate SCSI LUN ID locally during initialize_connection() since two cinder volume nodes may run parallelly. The SCSI LUN ID maybe duplicate during serveral cinder volume nodes run parallelly. The storwize backend can decide SCSI LUN ID.

See the error message:
2016-06-09 15:42:06.135 15042 DEBUG oslo_concurrency.processutils [req-cda98724-4f9d-4c46-b88a-f5d3a841cfaa - - - - -] Result was 1 ssh_execute /usr/lib/python2.7/site-packages/oslo_concurrency/processutils.py:330
2016-06-09 15:42:06.136 15042 ERROR cinder.volume.drivers.san.san [req-cda98724-4f9d-4c46-b88a-f5d3a841cfaa - - - - -] Unexpected error while running command.
Command: svctask mkvdiskhostmap
Exit code: 1
Stdout: u''
Stderr: u'CMMVC5879E The VDisk-to-host mapping was not created because a VDisk is already mapped to this host with this SCSI LUN.\n'

xiaoqin (xiaoqin-li)
Changed in cinder:
assignee: nobody → xiaoqin (xiaoqin-li)
xiaoqin (xiaoqin-li)
description: updated
xiaoqin (xiaoqin-li)
description: updated
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to cinder (master)

Fix proposed to branch: master
Review: https://review.openstack.org/360394

Changed in cinder:
status: New → In Progress
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to cinder (master)

Reviewed: https://review.openstack.org/360394
Committed: https://git.openstack.org/cgit/openstack/cinder/commit/?id=f3d1be2319cb8254aedb4ed9530ec70e8ee61658
Submitter: Jenkins
Branch: master

commit f3d1be2319cb8254aedb4ed9530ec70e8ee61658
Author: Xiaoqin Li <email address hidden>
Date: Thu Aug 25 17:47:50 2016 +0800

    Storwize: remove SCSI LUN ID for volume attaching

    The VDisk-to-host mapping may fail due to the SCSI LUN
    id is already used by other VDisk mapping to this host,
    which is caused by serveral cinder volume nodes run
    parallelly and serveral volumes attaching parallelly.

    storwize volume driver does not need to calculate SCSI LUN
    ID locally for volume attaching. The SCSI LUN ID can be
    decided by storage backend correctly.

    Closes-Bug: 1603282
    Change-Id: Ic8d229b539f1b2b79f530f966eb09154e5f13a2c

Changed in cinder:
status: In Progress → Fix Released
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/cinder 10.0.0.0b1

This issue was fixed in the openstack/cinder 10.0.0.0b1 development milestone.

xiaoqin (xiaoqin-li)
description: updated
xiaoqin (xiaoqin-li)
description: updated
xiaoqin (xiaoqin-li)
information type: Public → Private
information type: Private → Public
xiaoqin (xiaoqin-li)
information type: Public → Public Security
yixuan zhang (yixuan-z)
information type: Public Security → Private
xiaoqin (xiaoqin-li)
information type: Private → Public
xiaoqin (xiaoqin-li)
information type: Public → Private
xiaoqin (xiaoqin-li)
description: updated
Revision history for this message
Jeremy Stanley (fungi) wrote :

Please don't change the type on bugs without at least saying why you're doing it.

information type: Private → Public
Revision history for this message
xiaoqin (xiaoqin-li) wrote :

The description contains some personal information which should not be published in public domain.
As an immediate workaround, I've set the bug private. See the details in
https://answers.launchpad.net/launchpad/+question/673729/

Revision history for this message
Colin Watson (cjwatson) wrote :

"Contained" rather than "contains" - we redacted the description yesterday.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.