No notification for volume type access control

Bug #1568707 reported by Hiroyuki Eguchi
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Cinder
Fix Released
Undecided
Michael Dovgal

Bug Description

No notification will be sent when executing "cinder volume-access-add" or "volume-access-remove".

Changed in cinder:
assignee: nobody → Hiroyuki Eguchi (h-eguchi)
Revision history for this message
Sheel Rana (ranasheel2000) wrote :

Could you please clear a bit more about notification?

Is it related to status of operation to be shown to user on executing cinder type access add or related to ceilometer notifiactions?

Revision history for this message
Sheel Rana (ranasheel2000) wrote :

If this is related to type-access-add operation details to be shown to user, this is duplicate of https://bugs.launchpad.net/cinder/+bug/1567376
Please confirm.

Revision history for this message
Hiroyuki Eguchi (h-eguchi) wrote :

I apologize for any confusion.

I'm talking about a "NotificationSystem".
(https://wiki.openstack.org/wiki/NotificationSystem)

So, it differs what you have reported in "https://bugs.launchpad.net/cinder/+bug/1567376".

Revision history for this message
Sheel Rana (ranasheel2000) wrote :

Thank you for clarification.

Revision history for this message
Sean McGinnis (sean-mcginnis) wrote : Owner Expired

Unassigning due to no activity.

Changed in cinder:
assignee: Hiroyuki Eguchi (h-eguchi) → nobody
Michael Dovgal (mdovgal)
Changed in cinder:
assignee: nobody → Michael Dovgal (mdovgal)
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to cinder (master)

Fix proposed to branch: master
Review: https://review.openstack.org/418369

Changed in cinder:
status: New → In Progress
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to cinder (master)

Reviewed: https://review.openstack.org/418369
Committed: https://git.openstack.org/cgit/openstack/cinder/commit/?id=2f409f9ba1a999c3b9e3a3199224a6217dbdbd34
Submitter: Jenkins
Branch: master

commit 2f409f9ba1a999c3b9e3a3199224a6217dbdbd34
Author: Michael Dovgal <email address hidden>
Date: Fri Jan 6 18:25:13 2017 +0200

    Add volume type access operations notification

    According to existing notification system we have notify methods
    for different cinder operations such as volume create/delete, etc.
    This patch extend our notification system and add missing notifications
    for commands:
            type-access-add
            type-access-remove

    The notifications could be used for billing and event notifications.

    Change-Id: I55bbb69be9507b243cce245e92037ab00920a29c
    Closes-Bug: #1568707

Changed in cinder:
status: In Progress → Fix Released
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/cinder 10.0.0.0b3

This issue was fixed in the openstack/cinder 10.0.0.0b3 development milestone.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers