Quotas API is not compatible with keystone API v2

Bug #1517043 reported by Szymon Borkowski
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Cinder
High
Szymon Borkowski

Bug Description

File: cinder/api/contrib/quotas.py line 19: the keystone client is imported from v3. So we cannot perform any calls through API v2.

Steps to reproduce:
1. Open in text editor /etc/cinder/cinder.conf:

2. Add or modify the line in [keystone_authtoken] region:

auth_uri = http://localhost:5000/v2.0

3. Restart cinder services

4. Type 'cinder quota-show <tenant_id>'

5. The quotas API will return error code 500.

Revision history for this message
Mitsuhiro Tanino (mitsuhiro-tanino) wrote :

I think this bug could be duplicate of this bug:

https://bugs.launchpad.net/cinder/+bug/1516085

Revision history for this message
Michal Dulko (michal-dulko-f) wrote :

@Mitsuhiro: I don't think so, this is a valid bug. One thing is that we're getting the URL from wrong place, second point is that code is compatible only with V3 Keystone client.

description: updated
Changed in cinder:
assignee: nobody → Szymon Borkowski (szymon-borkowski)
status: New → In Progress
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to cinder (master)

Fix proposed to branch: master
Review: https://review.openstack.org/259134

Changed in cinder:
assignee: Szymon Borkowski (szymon-borkowski) → Dirk Mueller (dmllr)
Revision history for this message
OpenStack Infra (hudson-openstack) wrote :

Fix proposed to branch: master
Review: https://review.openstack.org/259360

Changed in cinder:
assignee: Dirk Mueller (dmllr) → Szymon Borkowski (szymon-borkowski)
Changed in cinder:
assignee: Szymon Borkowski (szymon-borkowski) → Dirk Mueller (dmllr)
Changed in cinder:
assignee: Dirk Mueller (dmllr) → Szymon Borkowski (szymon-borkowski)
Yaguang Tang (heut2008)
tags: added: liberty-backport-potential
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to cinder (master)

Reviewed: https://review.openstack.org/259360
Committed: https://git.openstack.org/cgit/openstack/cinder/commit/?id=ffd32c7e1947189eee701c417d9f72982f720a11
Submitter: Jenkins
Branch: master

commit ffd32c7e1947189eee701c417d9f72982f720a11
Author: Szymon Borkowski <email address hidden>
Date: Thu Dec 17 13:18:31 2015 +0100

    Quota API is now compatible with keystone API v2

    Before, the quota API used to fail to perform calls with specified
    keystone API v2, because the keystone client used in code was set
    to v3 and all quota operations used to assume that the user would
    use only keystone API v3.
    Now, we use the generic client, which discovers the version of the
    keystone API, so depending on that, the quota API can perform
    appropriate operations.

    Change-Id: I32595a37a9fe74ede77c92f76e0865f4c9371f65
    Closes-Bug: 1517043

Changed in cinder:
status: In Progress → Fix Released
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to cinder (stable/liberty)

Fix proposed to branch: stable/liberty
Review: https://review.openstack.org/262162

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Change abandoned on cinder (master)

Change abandoned by Dirk Mueller (<email address hidden>) on branch: master
Review: https://review.openstack.org/259134
Reason: https://review.openstack.org/#/c/259360/ is good enough

Revision history for this message
Thierry Carrez (ttx) wrote : Fix included in openstack/cinder 8.0.0.0b2

This issue was fixed in the openstack/cinder 8.0.0.0b2 development milestone.

Eric Harney (eharney)
Changed in cinder:
importance: Undecided → High
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to cinder (stable/liberty)

Reviewed: https://review.openstack.org/262162
Committed: https://git.openstack.org/cgit/openstack/cinder/commit/?id=bd3b972e72bb17b0a0f08f972a7bcdb39c6dd35f
Submitter: Jenkins
Branch: stable/liberty

commit bd3b972e72bb17b0a0f08f972a7bcdb39c6dd35f
Author: Szymon Borkowski <email address hidden>
Date: Thu Dec 17 13:18:31 2015 +0100

    Quota API is now compatible with keystone API v2

    Before, the quota API used to fail to perform calls with specified
    keystone API v2, because the keystone client used in code was set
    to v3 and all quota operations used to assume that the user would
    use only keystone API v3.
    Now, we use the generic client, which discovers the version of the
    keystone API, so depending on that, the quota API can perform
    appropriate operations.

    Change-Id: I32595a37a9fe74ede77c92f76e0865f4c9371f65
    Closes-Bug: 1517043
    (cherry picked from commit ffd32c7e1947189eee701c417d9f72982f720a11)

tags: added: in-stable-liberty
Revision history for this message
Doug Hellmann (doug-hellmann) wrote : Fix included in openstack/cinder 7.0.2

This issue was fixed in the openstack/cinder 7.0.2 release.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote :

This issue was fixed in the openstack/cinder 7.0.2 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers