Driver parameter in VOLUME_CONF is wrong

Bug #1396265 reported by Aviram Bar-Haim on 2014-11-25
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Cinder
Undecided
git-harry

Bug Description

The 'lld' parameter name, in https://github.com/openstack/cinder/blob/master/cinder/brick/iscsi/iscsi.py#L94 and
 https://github.com/openstack/cinder/blob/master/cinder/brick/iscsi/iscsi.py#L101, should be 'driver' according to http://linux.die.net/man/5/targets.conf .

Changing its default value from iscsi to iser takes effect only with the name 'driver' .

Rushi Agrawal (rushiagr) wrote :

Hi Aviram, do you have more info if you're facing any failure? Like logs, error message, etc?

Aviram Bar-Haim (aviramb) wrote :

Since 'default-driver' is set to iscsi by default, and this parameter only overrides default-driver, I think that iscsi is the default value for the driver anyway in this case.
So I'm not sure there will be errors, but still, this parameter is with the wrong name..

Fix proposed to branch: master
Review: https://review.openstack.org/141162

Changed in cinder:
assignee: nobody → git-harry (git-harry)
status: New → In Progress
tags: added: juno-backport-potential

Reviewed: https://review.openstack.org/141162
Committed: https://git.openstack.org/cgit/openstack/cinder/commit/?id=a835e70cbf33936c8bf6cbcfdcca4973363d1784
Submitter: Jenkins
Branch: master

commit a835e70cbf33936c8bf6cbcfdcca4973363d1784
Author: git-harry <email address hidden>
Date: Thu Dec 11 20:49:44 2014 +0000

    Brick: fix bug in tgt conf for volume

    872b7ca0fc5ce4911fdaadee464d46be5a38058d was intended to explicitly
    specify the driver being used by tgt for each target. The issue is that
    'lld' is not a valid directive therefore the default is being used. The
    default used by tgt is iscsi.

    This commit replaces 'lld' with the correct directive of 'driver'.

    Change-Id: I6153ee8b24039aedc4ab471f7d00517411791dac
    Closes-bug: #1396265

Changed in cinder:
status: In Progress → Fix Committed

Reviewed: https://review.openstack.org/147108
Committed: https://git.openstack.org/cgit/openstack/cinder/commit/?id=ebf3ba4839e60bd4f07038a5df48145000416ce6
Submitter: Jenkins
Branch: master

commit ebf3ba4839e60bd4f07038a5df48145000416ce6
Author: git-harry <email address hidden>
Date: Wed Jan 14 10:49:11 2015 +0000

    Fix bug in tgt conf for volume

    'lld' is not a valid directive.

    This commit replaces 'lld' with the correct directive of 'driver'.

    Change-Id: I165339a9652fe882c50a5a7e270675e343dceb30
    Related-bug: #1396265

Mike Perez (thingee) on 2015-01-16
Changed in cinder:
milestone: none → kilo-2
Thierry Carrez (ttx) on 2015-02-05
Changed in cinder:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2015-04-30
Changed in cinder:
milestone: kilo-2 → 2015.1.0
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers