ionice not in rootwrap config

Bug #1300496 reported by Bryan D. Payne on 2014-03-31
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Cinder
Critical
Bryan D. Payne

Bug Description

Bryan D. Payne (bdpayne) wrote :
Changed in cinder:
assignee: nobody → Bryan D. Payne (bdpayne)
Changed in cinder:
status: New → Incomplete
status: Incomplete → Confirmed
importance: Undecided → Critical
tags: added: icehouse-backport-potential
Thierry Carrez (ttx) on 2014-04-01
no longer affects: cinder/icehouse
tags: added: icehouse-rc-potential
removed: icehouse-backport-potential
Changed in cinder:
status: Confirmed → In Progress
Thierry Carrez (ttx) on 2014-04-03
Changed in cinder:
milestone: none → icehouse-rc2
tags: removed: icehouse-rc-potential

Reviewed: https://review.openstack.org/84272
Committed: https://git.openstack.org/cgit/openstack/cinder/commit/?id=d5c74a954b260567874c45c39b92904f3756b806
Submitter: Jenkins
Branch: master

commit d5c74a954b260567874c45c39b92904f3756b806
Author: Bryan D. Payne <email address hidden>
Date: Mon Mar 31 15:50:43 2014 -0700

    Adds ionice command permutations to rootwrap filters

    When setting volume_clear_ionice, the ionice command is prepended to a dd
    command before executing it. Previously, this would have failed because it
    wasn't allowed through the default rootwrap filters. This commit fixes this
    problem.

    Note that due to the way that the RegExpFilter works, we need three different
    expressions to cover all cases. This is because the various options result
    in a different number of arguments. And this filter will fail immediately
    if the number of arguments is incorrect.

    Change-Id: Ie29f7fa21b34982ed5394c2c8f38c3e066ef0112
    Closes-Bug: #1300496

Changed in cinder:
status: In Progress → Fix Committed

Reviewed: https://review.openstack.org/85375
Committed: https://git.openstack.org/cgit/openstack/cinder/commit/?id=d3516176bba5d6ac258d31f775353f8702df56a6
Submitter: Jenkins
Branch: milestone-proposed

commit d3516176bba5d6ac258d31f775353f8702df56a6
Author: Bryan D. Payne <email address hidden>
Date: Mon Mar 31 15:50:43 2014 -0700

    Adds ionice command permutations to rootwrap filters

    When setting volume_clear_ionice, the ionice command is prepended to a dd
    command before executing it. Previously, this would have failed because it
    wasn't allowed through the default rootwrap filters. This commit fixes this
    problem.

    Note that due to the way that the RegExpFilter works, we need three different
    expressions to cover all cases. This is because the various options result
    in a different number of arguments. And this filter will fail immediately
    if the number of arguments is incorrect.

    Change-Id: Ie29f7fa21b34982ed5394c2c8f38c3e066ef0112
    Closes-Bug: #1300496
    (cherry picked from commit d5c74a954b260567874c45c39b92904f3756b806)

Changed in cinder:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2014-04-17
Changed in cinder:
milestone: icehouse-rc2 → 2014.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers