bin/cinder-* scripts are not unit tested

Bug #1291875 reported by Eric Harney on 2014-03-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Cinder
Low
Thang Pham

Bug Description

We should add something that does at least basic testing on bin/cinder-{all, api, backup, manage, rtstool, scheduler, volume} to prevent issues like the one fixed in https://review.openstack.org/#/c/79791/ from slipping through.

Changed in cinder:
assignee: nobody → Verónica Musso (veronica-a-musso)
Changed in cinder:
assignee: Verónica Musso (veronica-a-musso) → nobody
Thang Pham (thang-pham) on 2014-06-09
Changed in cinder:
assignee: nobody → Thang Pham (thang-pham)
Eric Harney (eharney) wrote :

I suspect that part of this should be moving to entry points for most of the code in these scripts. I looked at this some time ago in https://review.openstack.org/#/c/52229/ which can be used as an example.

Thang Pham (thang-pham) wrote :

This looks like a big change.

After reading what John Griffith posted in the review, I will start a cinder-specs and blueprint to track this and get it approve. I understand that the reason behind the change is to use pbr to setup the correct console scripts that will call the main function in cinder.cmd. It will allow us to import from cinder.cmd and individually test each command. I see that nova and glance does a similar thing.

Is there anything else (other than the reasons above) that I should include in the cinder-specs?

Thang Pham (thang-pham) wrote :

The blueprint for this has been added and is pending review: https://blueprints.launchpad.net/cinder/+spec/unit-test-cases-for-cinder-scripts

Ivan Kolodyazhny (e0ne) on 2014-07-30
Changed in cinder:
status: New → Confirmed
Thang Pham (thang-pham) on 2014-12-10
Changed in cinder:
status: Confirmed → Fix Committed
Thierry Carrez (ttx) on 2014-12-18
Changed in cinder:
milestone: none → kilo-1
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2015-04-30
Changed in cinder:
milestone: kilo-1 → 2015.1.0
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers